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MATLAB Report Generator Product Description

1-2

Design and automatically generate reports from MATLAB applications

MATLAB Report Generator provides functions and APIs that integrate reporting
capabilities into MATLAB applications. You can develop programs that generate reports in
PDF, Microsoft® Word, Microsoft PowerPoint®, and HTML. MATLAB Report Generator
enables you to dynamically capture results and figures from your MATLAB code and
document those results in a single report that can be shared with others in your
organization. You can use the prebuilt, customizable Word and HTML templates or design
reports based on your organization’s templates and standards.

Key Features

* Automated reporting from MATLAB

* PDEFE Microsoft Word, Microsoft PowerPoint, and HTML formats
» Templates for programmatic reporting

» Comprehensive APIs for creating scalable report generators
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What Is a Reporter?

Reporters are MATLAB objects that generate formatted content when added to a MATLAB
Report Generator Report object. MATLAB Report Generator provides reporters for
generating common report components, such as title pages, tables of contents, chapters,
subsections, figures, and MATLAB variables values. You can customize the content and
appearance of these reporters. You can also create your own reporters. For a list of built-
in Report API objects, enter this MATLAB command:

help mlreportgen.report

Reporters and DOM Objects

In addition to reporters, MATLAB Report Generator provides another set of objects for
generating report content. These objects are Document Object Model (DOM) objects.
They implement a model of a document used by HTML, Word, and other document
creation software. The model defines a document as a hierarchy of objects commonly
found in documents, such as text strings, paragraphs, images, and tables. The DOM API
contains software objects that generate these basic document objects. For a list of the
DOM objects, enter this MATLAB command:

help mlreportgen.dom

Reporters, by contrast, create high-level document structures, such as title pages, tables
of contents and chapters, that occur in many, but not all types of documents. The
advantage of reporters is that a single reporter can create content that would require
many DOM objects. However, a report generator program typically requires both DOM
and reporter objects. For example, a chapter reporter generates the title and page layout
of a report chapter, but not its content. The DOM API provides text, paragraph, table, list,
image, and other objects that you can use to create reporter content.

The following MATLAB program illustrates using both reporters and DOM objects to
create a PDF report. The program uses a DOM Text object to add a block of text to the
chapter. All other objects in this example (Report, TitlePage, TableOfContents, and
Chapter) are reporter objects.

rpt = mlreportgen.report.Report('myreport', 'pdf');

add(rpt,mlreportgen.report.TitlePage('Title', 'My Report’', ...
'"Author’', 'Myself'))

add(rpt,mlreportgen.report.TableOfContents)

ch = mlreportgen.report.Chapter('Title', 'Sample Text');
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add(ch,mlreportgen.dom.Text. ..

('Here is sample text using a DOM Text object.'))
add(rpt,ch)
close(rpt)
rptview(rpt)

My Report
Myself

16-Jul-2018

Table of Contents
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Chapter 1. Sample Text

Here is sample text using a DOM Text object.

Reporter Elements

A reporter typically includes the following elements:

Template documents that define the appearance, fixed content, and holes for dynamic
content generated by the reporter. A reporter typically provides a set of templates
files, one for each supported output type: Word, PDF, and HTML. Each template file
contains a library of templates used by the reporter to format its content. For example,
the Report API TitlePage reporter uses a template named TitlePage to format a
title page. The TitlePage template is stored in the template libraries of its template
files. You can modify this template to rearrange or add content to a title page. For
information, see “Templates”.

Properties that specify the dynamic content generated by the reporter. These
properties correspond to holes in the reporter template. A reporter fills the template
holes with the values of the corresponding properties.

MATLAB class that defines the reporter properties and methods you use to create and
manipulate the reporter. Reporter class names begin with the prefix,
mlreportgen. report. For example, the title page reporter is
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mlreportgen.report.TitlePage. You can omit the prefix in a MATLAB script or
function by inserting this statement at the beginning of the script or function:

import mlreportgen.report.*

Likewise, you can include import mlreportgen.dom. * to use short DOM class
names.

Constructor method that creates a reporter object as an instance of the reporter class.
The name of the constructor is the same as the name of the class.

DOM object that contains the content generated by the report. This object is referred
to as the implementation of the reporter. Each reporter has a getImpl method that
creates the implementation object, which is typically a DOM DocumentPart object.

Using Reporters in a MATLAB Program

To generate content in a report program, follow these steps:

g A W N =

“Create a Report Object” on page 1-6

“Create an Instance of the Reporter” on page 1-7

“Set the Properties of an Existing Reporter” on page 1-7
“Add the Reporter to a Report” on page 1-7

“Close the Report Object” on page 1-7

The example program described in these steps creates a simple document that includes
only a title page. However, the steps demonstrate the tasks to create a full report. The full
program listing is shown after the step descriptions.

Create a Report Object

Create a Report object (mlLreportgen.report.Report) to contain the content
generated by the report. The report object uses a DOM Document object to hold content
generated by reporters added to the report. This code imports the Report API package,
which enables the code to use short class names. Then, it creates a PDF report object

(rpt).

import mlreportgen.report.*
rpt = Report('myReport', 'pdf');
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Create an Instance of the Reporter

Create an instance of the reporter class, that is, instantiate the reporter, using its
constructor. The constructor can also set the properties of the reporter object it creates.
For example, this code creates a title page reporter (tp) and sets its Title and Author
properties.

tp = TitlePage('Title', 'My Report', 'Author', 'John Smith');
Set the Properties of an Existing Reporter

To set reporter properties after a program has created a reporter, the program can use
MATLAB dot notation. For example, this code sets the Subtitle and PubDate properties
of a TitlePage reporter (tp).

tp.Subtitle = 'on My Project';
tp.PubDate = date;

Add the Reporter to a Report

To generate content using a reporter, a report program must add the reporter to the
report object, using the add method of the report object. The add method works by
invoking the getImpl method of that reporter. The getImpl method creates the
implementation of the reporter. Then, the add method adds the implementation to the
DOM Document object that serves as the implementation of the report object. You can
also use the add method to add DOM objects to the report. You cannot, however, add
another DOM Document to a report.

For example, this code adds the title page reporter (tp) to the report (rpt).
add(rpt, tp)
Close the Report Object

When a report program has finished adding content to a report, it must close the report,
using the close method of the report object. Closing a report writes the report content to
a document file of the type, such as PDF, specified by the constructor of the report object.

close(rpt)
This code is the complete program for the report, which includes only a title page.

import mlreportgen.report.*
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rpt = Report('myReport', 'pdf');

tp = TitlePage('Title', 'My Report',...

"Author', 'John Smith');
tp.Subtitle = 'on My Project';
tp.PubDate = date;

add(rpt, tp)
close(rpt)
rptview(rpt)

My Report

on My Project
John Smith

16-Jul-2018

See Also

mlreportgen.dom.Text | mlreportgen.report.Report |
mlreportgen.report.TableOfContents | mlreportgen.report.TitlePage

More About

. “Create a Report Program” on page 13-3
. “Define New Types of Reporters” on page 1-9
. “Subclass a Reporter Definition” on page 1-13

1-8
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Define New Types of Reporters

MATLAB Report Generator allows you to define reporter types to meet specialized
reporting requirements. For example, if the MATLAB Report Generator TitlePage
reporter type does not meet your needs, you can define your own title page reporter type.

Note The following procedure creates a package of files that define your reporter type.
To see how reporter definition packages are structured, subclass a built-in reporter, such
as the TitlePage reporter (see “Subclass a Reporter Definition” on page 1-13). After
performing the following steps, the reporter package for your new reporter type will be
similar to the subclassed one.

To define a new reporter type:

1

Create a subfolder for your class definition in the folder containing the report
program in which it is to be used. Prefix the name of the class definition folder with
@, for example, @MyTitlePage.

Note To use the new class in programs that reside in other folders, add the class
definition folder to the MATLAB path.

Create a subfolder named resources in your class definition folder. Create a
subfolder named templates in the resources folder.

Create subfolders named pdf, docx, and html in the templates folder. If you do not
want to support all output types, create folders only for the types you want to
support.

Use mlreportgen.dom.Document.createTemplate to create an empty template
named default in each of the resource template folders for the output types you
intend to support. For example, to create an empty template in the pdf template
folder for your MyTit1lePage reporter, enter:

cd @MyTitlePage/resources/templates/pdf
mlreportgen.dom.Document.createTemplate('default’', 'pdf);

Edit each empty template file to create a template library that contains the templates
to be used by your reporter. You must create a template library even if your reporter
uses only one template. For example, for your MyTitlePage reporter, add a template
named TitlePage to the template library in each of the reporter's template
documents. The template documents for PDE Word, and HTML reports are
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default.pdftx, default.dotx, and default.htmtx, respectively. In the
TitlePage template, define the title page fixed content and holes for the title page
dynamic content the title page reporter generates. Define the styles used by the
template in the style sheet of the main template.

6 Using the MATLAB editor, create a class definition (classdef) file for the new reporter
type in the class definition folder. The name of the class definition file must be the
name of the new reporter type, for example, MyTit1lePage.m. The classdef file must
define the following:

* The base class for reporters (mlLreportgen.report.Reporter) as the base
class for your new type of reporter.

* A property for each of the holes defined by your templates, including holes in the
headers and footers. The property corresponding to a hole must have the same
name as the hole. For example, if your reporter template defines a hole named
Title, your class definition file must define a property named Title. This code is
example of a class definition file.

classdef MyTitlePage < mlreportgen.report.Reporter
properties
Title = "'
Author = "'
Version = '1.0'
end

methods
function obj = MyTitlePage(varargin)
obj = obj@mlreportgen.report.Reporter(varargin{:});

The next line assumes that you have defined a template
named TitlePage in the template library of the main
template used by this reporter. The base reporter class
fills the holes in this template with the contents of the
corresponding properties defined by your class.

0° o° o° o° o°

obj.TemplateName = 'MyTitlePage';
end
end

methods (Hidden)

This function is used by the base Reporter class to
retrieve the MyTitlePage reporter template corresponding
to the output type of the report to which the reporter
is added. For example, if you add this reporter to a

0° o° o° o°
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Report object whose output type is PDF, the base reporter
class returns the path of the PDF template residing in the
resources/templates/pdf directory of your reporter
definition package.
function templatePath = getDefaultTemplatePath(~, rpt)
import mlreportgen.report.*
path = MyTitlePageTemplate.getClassFolder();
templatePath = ...
ReportForm.getFormTemplatePath(path, rpt.Type);
end

0° o° o° o°

end
methods (Static)
function path = getClassFolder()
[path] = fileparts(mfilename('fullpath'));
end
end

end

Note This example does not define property value pairs in its constructor. Instantiate the
reporter before you set its properties.

This example shows how to use your title page reporter (MyTit1lePage), which is defined
in the sample classdef file. The example also shows how to set properties after creating
an instance of the reporter.

import mlreportgen.report.*
import mlreportgen.dom.*

rpt = Report('myreport', 'pdf');
tp = MyTitlePage;

tp.Title = 'My Report';
tp.Author = 'Myself';

add(rpt, tp);

close(rpt);
rptview(rpt);
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See Also

mlreportgen.dom.Document | mlreportgen.dom.Text |

mlreportgen.report.Report | mlreportgen.report.TableOfContents |
mlreportgen.report.TitlePage

More About

. “Create an HTML or PDF Template” on page 13-146

. “Create a PDF Document Part Template Library” on page 13-43
. “What Is a Reporter?” on page 1-3

. “Subclass a Reporter Definition” on page 1-13
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Subclass a Reporter Definition

If a built-in reporter meets some of your requirements, consider subclassing the reporter.
Subclassing a reporter allows you to rearrange and expand the content of a built-in
reporter. To subclass a built-in reporter:

1

Create a custom reporter definition based on the class definition of the built-in
reporter, using the customizeReporter method of the built-in reporter.

For example, the following code creates a folder named @MyTitlePage in the
current folder.

mlreportgen.report.TitlePage.customizeReporter('@MyTitlePage');

The created folder contains a class definition file named MyTitlePage.m. The class
definition file defines a subclass of the built-in Tit1lePage reporter. The class
definition folder also contains copies of the TitlePage reporter templates, which are
stored in a subfolder named resources.

Edit the template copies to rearrange the holes for the content of the built-in reporter
or add holes for additional generated content.

If you add holes to the templates of the new reporter, edit the reporter class
definition file to define properties that specify the content that fills the holes. Define a
property for each hole that you have added to the template of the new reporter. The
name of the property must be the same as the name of the hole.

See Also

mlreportgen.report.TitlePage

More About

“What Is a Reporter?” on page 1-3
“Define New Types of Reporters” on page 1-9
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Java Memory Usage

MATLAB Report Generator uses Java heap memory to generate PDF documents. The
default Java heap size that MATLAB allocates may not be enough to convert large PDF
documents. The error that occurs if your report conversion runs out of Java heap memory
is:

Document conversion failed. Java exception occurred:
java.lang.OutOfMemoryError

To generate your PDF document, increase the Java heap space to the maximum amount:

Click Preferences on the MATLAB toolbar.
Expand General
To open the MATLAB General Java Heap memory Preferences panel, click Java Heap

Memory
4\ Preferences — O
4 MATLAB * | MATLAB General Java Heap Memory Preferences

Add-Ons
App Designer Java Heap Size
Code Analyzer The heap size determines how much memory is available for Java ohjects. Increasing
Colors this value may help you avoid "OutOfMemoryError: Java heap space” errors,
Command History '
Command Window 7635 MB
Comparison 128 1560 2995

Current Folder
Editor/Debugger

Current value 768 MB. Default value 768 MB.

Figure Copy Template
Fonts
4 General
MAT-Files

Confirmation Dialegs

GUIDE

Help

Keyboard

Toolbars v

Cancel Apply Help
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Java Memory Usage

4

5

Move the slider all the way to the right so set the Java Heap Size to the maximum
value.

Java Heap 5ize

The heap size determines how much memery is available for Java cbjects. Increasing
this value may help you avoid "OutOfMemoryError: Java heap space” errors,

2,993 - MEB

128 1560 2083

Current value 768 MB. Default value 768 ME.

ir) You must restart MATLAE for the above change to take effect.

To enable the new Java heap size, restart MATLAB.
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Working with the Report Explorer

1-16

In this section...

“About the Report Explorer” on page 1-16
“Interactive Report Generation Workflow” on page 1-18

Note Do not create new reports using the Report Explorer app. This information is
provided for maintaining existing reports only. To create a new report generator, use the
Report and DOM APIs. See “Create a Report Program” on page 13-3.

About the Report Explorer

Use the Report Explorer to:

* Create and modify report setup files.

* Apply style sheets to format the generated report.
» Specify the report file format.

* Generate reports.

Open the Report Explorer using one of these approaches:

* From the MATLAB Toolstrip, in the Apps tab, in the Database Connectivity and
Reporting section, click Report Generator.

* In the MATLAB Command Window, enter report.
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Report Generator Help Menu

2 Report Explorer 7
File Edit Yiew Tools Help

[RE1 IPLY RS AR R LX)

[ Name | | |Report Generator
|5 - fizpoint [Mtoolbo] ---eeeeeeeee —Actions
27 Eptzeportipt __] |Create and edit a new Report file
1 - reqmgt [Mtoolboxhslvny] ----eee
g’;’ requirements. rpt [5 |0 eh a Report file or stylesheet

1= - components [\toolboxhsimulink] ...

~ ) ﬁﬁ' Convert XML source file to document format
modeladvisor.rpt

b3
;; slbook.rpt ﬁl&eateanew user-defined reporting compol
[© - staeflow [tooboristatefion] --... Create or modify document conversion styl
truthtable.rpt

1= - vab (Moolbox\database) - gIEx ort Simulink model to web viewer
databasetlbx.rpt

159 - rtw [stoolbowhrtw] -eeeeeees

f} codegen.ipt

1= - rptgendemos [Mtoolboxbrptaen) -...

% chil-tutorial.ipt ~Getting Started
% figloop-tutorial.rpt

e

AN

Y . This is the main interface for the Report Gener
magic-square.rpt existing Report Generator file from the list or cr
% miile-report.ipt

?}7 simple-report.rpt
27 wsvarreport.ipt

Outline pane Library pane Properties pane

The Report Explorer has three panes:

* The Outline pane on the left shows the hierarchy of components in currently opened
report setup files. Report components can reside within other report components,
creating parent, child, and sibling relationships.

* The Library pane in the middle lists the objects available in the context of the Outline
pane.
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Outline Pane Context Library Pane Contents
No report setup file is open. Reports

Report setup file is open. Components

Style sheet is open. Style sheet attributes

* The Properties pane contents depend on the Outline pane context. If no report setup
file is open, on the right displays tasks the Report Explorer can perform. If a report
setup file is open, the Properties pane displays the properties for the item that is
currently selected in the Options pane.

Outline Pane Context Properties Pane Contents

No report setup file is open. Tasks that the Report Explorer can
perform

Report setup file is open. Properties for the item that is currently
selected

After you create a report setup file, the
Properties pane initially displays
properties for the report setup file as a
whole.

Tip If the Report Explorer window opens with only two panes, one of the panes is hidden.
You can move the vertical boundaries between the panes to reveal any hidden pane, or to
make visible panes wider or narrower.

Interactive Report Generation Workflow

1 Open the Report Explorer.
2 Create a report setup file. For details about report setups, see “Report Setup”.

3 Add content by adding to the report setup file existing components or custom
components that you create. For details about using components, see “Work with
Components” “Insert Components” on page 4-12.

4  Use Microsoft Word, HTML, or PDF templates to format reports. For details about
templates, see “Report Templates” on page 7-2.

5 Generate the report. See “Generate Reports”.

1-18



Create Your First Report

* “Create a Report Generator” on page 2-2
¢ “Maintain Interactive MATLAB Report” on page 2-13
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Create a Report Generator

2-2

This example shows how to create a simple report that explains and illustrates magic
squares - matrices whose columns, rows, and diagonals each add up to the same number
(see the magic function reference in the MATLAB documentation).

Note The complete example code is included after the step-by-step instructions.

1 TImport the base classes.

To eliminate the need to use fully qualified names of Report and DOM API objects,
use these statements. For example, instead of using mlreportgen. report.Report,
you can use Report.

import mlreportgen.report.*
import mlreportgen.dom.*
2  Create a report object.

Create the report object. Use 'magic' as its file name and 'html"' as its report type.
rpt = Report('magic', 'html');

To customize properties that apply to the whole report, see
mlreportgen.report.Report.

3 Add a title page.

Create a title page and specify its title, subtitle and author. Then, add the title page to
the report.

tp = TitlePage;

tp.Title = 'Magic Squares';

tp.Subtitle = 'Columns, Rows, Diagonals: All Equal Sums';
tp.Author = 'Albrecht Durer';

add(rpt, tp);
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Magic Squares
Columns, Rows, Diagonals: All Equal Sums

Albrecht Durer

11-Jul-2017

To customize additional title page properties, see
mlreportgen.report.TitlePage.

Add a table of contents.

Add a default table of contents object to the report.

add(rpt,TableOfContents);

=] Table of Contents

Chapter 1. Introduction
Chapter 2. 10 x 10 Magic Square
Chapter 3. 25 x 25 Maqgic Square

To customize the table of contents, see mlreportgen. report.TableOfContents.
Add a chapter and chapter sections.

Create a chapter object for the introduction and specify the chapter title. Add a
section, add a paragraph to that section, and add that section to the chapter. Create
another section and add a paragraph to it.

chl = Chapter;

chl.Title = 'Introduction';

secl = Section;

secl.Title = 'What is a Magic Square?’';
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para = Paragraph(['A magic square is an N-by-N matrix '...
‘constructed from the integers 1 through N*2 '...

'with equal row, column, and diagonal sums.']);
add(secl,para)

add(chl,secl)

sec2 = Section;

sec2.Title = 'Albrect Durer and the Magic Square';

para = Paragraph([ ...

'"The German artist Albrecht Durer (1471-1528) created '...
'many woodcuts and prints with religious and '...
'scientific symbolism. One of his most famous works,
'Melancholia I, explores the depressed state of mind '...
'which opposes inspiration and expression. '...
'Renaissance astrologers believed that the Jupiter '...
'magic square (shown in the upper right portion of '...
‘the image) could aid in the cure of melancholy. The '...
‘engraving''s date (1514) can be found in the '...

'lower row of numbers in the square.']);

add(sec2,para)

add(chl,sec2)

1.1. What is a Magic Square?

A magic square 15 an N-by-IN matrix constructed from the integers 1 through N2 with equal row,
column. and diagonal sums.

1.2. Albrect Durer and the Magic Square

The German artist Albrecht Durer (1471-1328) created many woodcuts and prints with religious and
scientific svmbolism. One of his most famous works. Melancholia I. explores the depressed state of
mind which opposes mspiration and expression. Renaissance astrologers believed that the Tupiter magic
square (shown in the upper right portion of the 1mage) could aid in the cure of melancholy. The
engraving's date (1514) can be found in the lower row of numbers in the square.

For information on customizing chapters and sections, see
mlreportgen.report.Chapter and mlreportgen.report.Section
respectively.

6 Add a figure.
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Create an image of Durer in a figure window. Create the image in a MATLAB figure.
Add the figure to the second section of introduction chapter and then, add the
chapter to the report.

durerImage=load(which('durer.mat'),'-mat');
figure('Units', 'Pixels', 'Position’,...
[200 200 size(durerImage.X,2)*.5 ...
size(durerImage.X,1)*.5 1);
image(durerImage.X);

colormap (durerImage.map);
axis('image');

set(gca, 'Xtick',[],'Ytick',[1,...
'Units', 'normal', 'Position',[0 0 1 1]);
add(sec2,Figure)

add(rpt,chl)

close gcf
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For more information on figures, see mlreportgen. report.Figure. For more
information on images, see mlreportgen. report.FormalImage.

7 Add a table.

Add another chapter object and specify its title. Specify the MATLAB code to create a
10-by-10 magic square. Add the results to a table and set these table properties:
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* Row and column separators
* Table border
* Alignment of table entries

Then, add the table to the chapter and the chapter to the report.

ch2 = Chapter();
ch2.Title = sprintf('10 x 10 Magic Square');

square = magic(10);
tbl = Table(square);

tbl.Style = {
RowSep('solid', 'black', '1px'),...
ColSep('solid', 'black', '1px'),};

tbl.Border = 'double';

tbl.TableEntriesStyle = {HAlign('center')};

add(ch2,tbl);
add(rpt,ch2);
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Chapter 2. 10 x 10 Magic Square

92199 1 | 8|15|67(74{51|58[40

9880 7 |14 55[57) 6441

4 |81 88 |20|22|54|56(63| 70|47

8587 19 2

75152(34

[ ]
=
]
o
=
—
L=
]

17)24) 76 |83|90(42|49(26

790 6 13 95|97

12| 94 |196| 78|35

11) 18| 100 77)84{36(43|50(27|5
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For more information on tables, see mlreportgen.dom.Table.
Add a MATLAB figure to a chapter.

Add another chapter object and specify its title. Specify the MATLAB code to create a
25-by-25 magic square and a color-coded figure of the magic square. Then, create a
figure object and set its height, width, and caption. Add the figure to the chapter and
the chapter to the report.

ch3 = Chapter();
ch3.Title = sprintf('25 x 25 Magic Square');

square = magic(25);

clf;

imagesc(square)

set(gca, 'Ydir', 'normal')
axis equal

axis tight

fig = Figure(gcf);

fig.Snapshot.Height = '4in';

fig.Snapshot.Width = '6in';

fig.Snapshot.Caption = sprintf('25 x 25 Magic Square');

add(ch3,fig);

add(rpt,ch3);
delete(gcf)
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Chapter 3. 25 x 25 Magic Square

Figure 3.1. 23 x 25 Magic Square

For more information on figures, see mlreportgen.report.Figure.
9 Close and run the report.

close(rpt)
rptview(rpt)

The complete code is:

import mlreportgen.report.*
import mlreportgen.dom.*
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rpt = Report('magic', "html');

tp = TitlePage;

tp.Title = 'Magic Squares';

tp.Subtitle = 'Columns, Rows, Diagonals: All Equal Sums';
tp.Author = 'Albrecht Durer';

add(rpt, tp);

add(rpt,TableOfContents);

chl = Chapter;

chl.Title = 'Introduction';

secl = Section;

secl.Title = 'What is a Magic Square?';

para = Paragraph(['A magic square is an N-by-N matrix '...
‘constructed from the integers 1 through N*2 '...

'with equal row, column, and diagonal sums.']);
add(secl,para)

add(chl,secl)

sec2=Section;

sec2.Title = 'Albrect Durer and the Magic Square';

para = Paragraph([ ...

'"The German artist Albrecht Durer (1471-1528) created '...
'many woodcuts and prints with religious and '...
'scientific symbolism. One of his most famous works,
'Melancholia I, explores the depressed state of mind
'which opposes inspiration and expression. '...
'Renaissance astrologers believed that the Jupiter '...
'magic square (shown in the upper right portion of '...
‘the image) could aid in the cure of melancholy. The
‘engraving''s date (1514) can be found in the '...
'"lower row of numbers in the square.']);
add(sec2,para)

add(chl,sec2)

durerImage=load(which('durer.mat'),'-mat');
figure('Units', 'Pixels', 'Position’,...

[200 200 size(durerImage.X,2)*.5 ...
size(durerImage.X,1)*.5 1);
image(durerImage.X);

colormap (durerImage.map);

axis('image');

set(gca, 'Xtick',[], 'Ytick',[1,...

'Units', 'normal', 'Position',[0 0 1 1]);
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add(sec2,Figure)
add(rpt,chl)
close gcf

ch2 = Chapter();

ch2.Title = sprintf('10 x 10 Magic Square');
square = magic(10);

tbl = Table(square);

tbl.Style = {...
RowSep('solid', 'black"', '1px'), ...
ColSep('solid', 'black', '1px"'),};

tbl.Border = 'double’;
tbl.TableEntriesStyle = {HAlign('center')};
add(ch2,tbl);

add(rpt,ch2);

ch3 = Chapter();

ch3.Title = sprintf('25 x 25 Magic Square');
square = magic(25);

clf;

imagesc(square)

set(gca, 'Ydir', 'normal’)

axis equal

axis tight

fig = Figure(gcf);

fig.Snapshot.Height = '4in’;
fig.Snapshot.Width = '6in"';
fig.Snapshot.Caption = sprintf('25 x 25 Magic Square');
add(ch3,fig);

add(rpt,ch3);

delete(gcf)

close(rpt)
rptview(rpt)

See Also

rptview
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Maintain Interactive MATLAB Report

Note Do not create new reports using the Report Explorer app. This information is
provided for maintaining existing reports only. To create a new report generator, use the
Report and DOM APIs. See “Create a Report Program” on page 13-3.

This example shows how a basic report was created using the Report Explorer. This
report explains and illustrates magic squares - matrices whose columns, rows, and
diagonals each add up to the same number (see the magic function reference in the
MATLAB documentation).

To create this report, you perform these main tasks:

* “Create a Report Setup File” on page 2-13
* “Add Report Content Using Components” on page 2-14

Note You do not need to know the MATLAB software to use this example. However,
knowledge of MATLAB is helpful for understanding the MATLAB code that executes
during report generation.

This example includes separate sections for different kinds of report creation and
generation tasks. Each section builds on the previous sections. However, if you want to
work through a later section without having done the previous sections, you can view the
completed report setup file: Magic Squares Report.

Create a Report Setup File

To set up the magic squares report, first create a setup file to store the setup. Then add
MATLAB objects, called components, to the setup to specify the report content.

To create the report setup file:

Start a MATLAB software session.

Open the Report Explorer. From the MATLAB Toolstrip, in the Apps tab, in the
Database Connectivity and Reporting section, click Report Generator.

3 Select File > New to create a report setup file. The new report setup has the default
name Unnamed. rpt.
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4 In the Properties pane on the right:

a  To save the report in the current working folder, select Present working
directory from the Directory list.

b Set File format to HTML (from template) to generate the report output as
HTML. Using the (from template) option creates the report table of contents
in a format that you can expand and collapse.

¢ In the Report description text box, replace the existing text with the following
text.

This report creates a series of magic squares
and displays them as images.

A magic square is a matrix in which the
columns, rows, and diagonal all add up to the
same number.

Note When you change a Properties pane field, its background color changes. This
indicates that there are unapplied changes to that field. As soon as you perform any
action with another component, MATLAB Report Generator applies the changes, and
the background color becomes white again.

5 Save your report. Select File > Save As and name your report setup file
magic squares.rpt.

The new file name appears in the Outline pane.

El‘/nj R eport Generatar
f? Report - magic_squares. rpt

To create the content for the report, see “Add Report Content Using Components” on
page 2-14.

Add Report Content Using Components

* “Report Components” on page 2-15
* “Specify Report Variables” on page 2-16
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“Create a Title Page” on page 2-19

“Add a Chapter” on page 2-22

“Add Introductory Text to the First Chapter” on page 2-23
“Add an Image” on page 2-25

“Create the Magic Squares and Their Images” on page 2-30
“Create a For Loop” on page 2-30

“Add a Chapter for Each Square” on page 2-32

“Determine the Matrix Size” on page 2-33

“Insert the Magic Square Size into the Report” on page 2-34
“Create the Magic Square” on page 2-35

“Add Display Logic” on page 2-37

“Display the Magic Square” on page 2-39

Report Components

Report components specify the information to include in the report. The following figure
shows a sample page from the report that you create in this example, highlighting
components that you use to produce the report.

2-15



2 Create Your First Report

Magic Squares

Columns, Rows, Diagonals: Every one is equal
Title Page
component \___‘Albrecht Durer

Copyright © 1988 The Mathworks
Abstract

An introduction to Magic Squares and thewr meaning.

Table of Contents

1 Magic Squares Explained

Chapter . .
p —» Chapter 1. Magic Squares Explained
component
MAGIC Magic square. MAGIC(N) is an N-by-N matrix constructed from the integers 1 through
Text N2 with equal row. column. and diagonal sums. Produces valid magic squares for all N = 0 except
t N =2 Reference page in Doc Center doc magic The German artist Albrecht Durer (1471-1528)
component created many woodcuts and prints with religious and scientific symbolism. One of his most famous
works. Melancholia I. explores the depressed state of mund that opposes inspiration and expression.
Renaissance astrologers believed that the Jupiter magic square (shown m the upper night portion of
the image) could aid in the cure of melancholy. The engraving's date (1514) can be found in the
lower row of numbers in the square.
Figure
Snapshot —
component

Specify Report Variables

The magic squares report uses variables defined in the MATLAB workspace to specify the
number and sizes of squares to display and whether to display the variables as tables of
numbers or images of color-coded squares:

* The magicSizeVector variable specifies an array of magic square sizes

» largestDisplayedArray variable specifies the size of the largest magic square to be
displayed as an array of numbers
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You could require that a user create these variables in the MATLAB workspace before
running the report. However, a better solution is to let the report create the variables,
using the Evaluate MATLAB Expression component.

To use the Evaluate MATLAB Expression component to define the report variables:

1 In the Outline pane on the left, select the root component of the report setup.

4 ?J Report Generator
4 ?,.? Report - magic_squares.rpt

2 In the Library pane in the middle, under MATLAB, select Evaluate MATLAB
Expression.

Evaluate MATLAR Expression
Insert V ariable

kATLAR Property Table
MATLAB ST oolbow Werzion Murmber
Wariable Table

B B BB

3 In the Properties pane on the right, click the icon next to Add component to
current report to insert the Evaluate MATLAB Expression component into the
report.

You can edit the component information in the Properties pane only after you add the
component to the report.

In the Outline pane, the Eval component appears under the magic squares report.

4 ‘?J Report Generator
4 ‘ff? Report - magic_squares.rpt®
Eval - ScEvaluate this string in the bas...

The icon in the upper left corner of the Eval component indicates that this
component cannot have child components. By default, any components you add with
the Eval component selected are siblings to this component.

The options for the Evaluate MATLAB Expression component appear in the
Properties pane.
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Evaluate MATLAB Expression
| Insert MATLAB expression in report &

+| Display command window output in report

Expression to evaluate in the base workspace: Eval Now

$Evaluate this string in the base workspace

1

+| Evaluate this expression if there is an error

% The exception generated above can be referenced by evalIxception 4
% See the default code below for an example
warningMessagelevel = 2;
displayWarningMessage = true;
failGenerationWithException = false;
failGenerationWithoutException = false;

Revert Help

4 To exclude the MATLAB code details and its output in this report, clear the Insert

MATLAB expression in report and Display command window output in report
check boxes.

5 In the Expression to evaluate in the base workspace text box, replace the
existing text with the following MATLAB code.

Tip Copy and paste this text from the HTML documentation into the Report Explorer.

%This MATLAB code sets up two variables
%that define how the report runs.
%smagicSizeVector is a list of MxM
%Magic Square sizes to insert into

%the report. Note that magic

%squares cannot be 2x2.

magicSizeVector=[4 8 16 32];
%largestDisplayedArray sets the
%limit of array size that will be
%inserted into the report with the
%Insert Variable component.

largestDisplayedArray=15;

2-18



Maintain Interactive MATLAB Report

7

In the Evaluate this expression if there is an error text box, replace the existing
text with the following text.

disp(['Error during eval: ', evalException.message])

This causes an error to display if the MATLAB code fails.

Tip To execute these commands immediately, in the top right corner of the Report
Explorer, click the Eval Now button. This confirms that your commands are correct,
to reduce the chances of report generation problems.

Save the report..

Create a Title Page

Note This section builds on the previous tasks described in the step-by-step example
summarized in “Maintain Interactive MATLAB Report” on page 2-13.

If you have not completed the previous sections of this example, open the completed
report setup file: Magic Squares Report.

To create a title page for the report, use the Title Page component.

1

In the Outline pane on the left, select the Eval component.

4 ?J Report Generator
4 f? Report - magic_squares.rpt®
@ Eval - %eThis MATLAE code sets up two va...

In the Options pane in the middle, under Formatting, add the Title Page component
to the report.

Because the Eval component icon indicates that this component cannot have
children, the Title Page component is a sibling of the Eval component. Likewise, the
Title Page component cannot have child components.

4 4| Report Generator
4 % Report - magic_squares.rpt*
@ Eval - %This MATLAB code sets up two va...
A\ Title Page - <No Title>
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Note To use a Title Page component, your report needs a Chapter component. You
have not yet added a Chapter component, so the Properties pane displays a message
indicating that a chapter is required for the Title Page component to appear
correctly. Because later in this example you add Chapter components to this report,
you can ignore that message.

In the Properties pane on the right, use the Main tab to enter the title page
information.

In the Title text box, enter Magic Squares.

In the Subtitle text box, enter Columns, Rows, Diagonals: Everyone is
Equal.

Under Options, choose Custom author from the list.

Options

|Custon'| author: v|

| Include report creation date: dd-mmm-yyyy HH:MM:SS (07-Sep-2011 10:31:51) -
Include copyright holder and year:

Display legal notice on title page

In the field to the right of the Custom author field, enter Albrecht Durer.

Albrecht Durer created an etching that contains a magic square. Your final report
includes an image of that etching.

Select the Include copyright holder and year check box.
In the next text box, enter The MathWorks.
In the second text box, enter 1988.
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Title Page
Error

A Chapters are required for component "Title Page" (section) to appear correctly.
Add chapters to template.

Main | Image Abstract Legal notice |

Title
Title: Magic Squares

Subtitle: Columns, Rows, Diagonals: Everyone is Equal

Options

[Custom author: v | Albrecht Durer

Include report creation date: dd-mmm-yyyy HH:MM:SS (07-Sep-2011 10:40:26)
Include copyright holder and year:  The MathWorks 1988|

[] pisplay legal natice on title page

4 In the Properties pane, in the Abstract tab, enter:

An introduction to Magic Squares and their meaning.
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Title Page
Erraor

& Chapters are required for component "Title Page™ (section) to appear correctly.
Add chapters to template.

Abstract | Legal notice

Abstract Text

An introduction to Magic Squares and their meaning.

Style

[ Bold 7] subscript

[ rtalic ] superscript

[ Underline [] Retain spaces and carriage returns

[ strikethrough [] show text as syntax-highlighted MATLAB code
Color:  Auto -

5 Save the report.
Add a Chapter

Note This section builds on the previous tasks described in the step-by-step example
summarized in “Maintain Interactive MATLAB Report” on page 2-13.

If you have not completed the previous sections of this example, open the completed
report setup file: Magic Squares Report.

Add a chapter to the report by using the Chapter/Subsection component.
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1 In the Outline pane on the left, select the Title Page component.

4 2| Report Generator
4 % Report - magic_squares.rpt®
8 Eval - %This MATLAB code sets up two va..
& Title Page - Magic Squares

2 In the Library pane in the middle, under Formatting, add a Chapter/Subsection
component.

4 ?J Feport Generator
4 ?,.? Report - magic_squares.rpt®
B Eval - %This MATLAB code sets up two va...
A Title Page - Magic Squares
4 Chapter - Section Title

The Eval, Title Page, and Chapter components are all child components of the
report's top level and are siblings of one another.

3  For the custom chapter title, in the Properties pane on the right, enter Magic
Squares Explained.

The Outline pane displays the chapter title.

4 ’Z Report Generator
4 é? Report - magic_squaras.rpt®
B Eval - %This MATLAB code sets up two va...
kit Title Page - Magic Squares
4 ‘ﬁﬂ Chapter - Magic S5quares Explained

4  Save the report.

Add Introductory Text to the First Chapter

Note This section builds on the previous tasks described in the step-by-step example
summarized in “Maintain Interactive MATLAB Report” on page 2-13.

If you have not completed the previous sections of this example, open the completed
report setup file: Magic Squares Report.
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Include introductory text in the first chapter by adding the Paragraph and Text
components.

In the Outline pane on the left, select the Chapter component.
In the Library pane in the middle, under Formatting , add a Paragraph component.

In the Outline pane, the new component appears as a child of the Chapter
component.

4 ﬂ Report Generator
4 ?,? Report - magic_squares.rpt*
kit Eval - %eThis MATLAE code sets up two va..,
kit Title Page - Magic Squares
4 ‘E%E Chapter - Magic Squares Explained
".ﬁﬂ Paragraph - <Mo Text>

By default, the Paragraph component inherits its text from its child components.
Add two Text components.

Note The Text component must have a Paragraph component as its parent.

In the Library pane, under the Formatting category, add two Text components to the
outline.

4 ﬂ Report Generator
4 f? Report - magic_squares.rpt*
A Eval - %2This MATLAE code sets up two va..,
A Title Page - Magic Squares
4 ‘ﬁﬂ Chapter - Magic Squares Explained

4 ¢§E Paragraph - <Text from children=
ki Text - <Mo Text=
ki Text - <Mo Text=

In the Outline pane, select the first Text component.
In the Text to include in report text box, enter %<help('magic')>.
The % sign and angle brackets <> indicate to the MATLAB Report Generator software

that this is MATLAB code to evaluate. The command help('magic') displays
information about the MATLAB magic function.
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In the Outline pane, select the second Text component.
In the Text to include in report text box, enter this text.

The German artist Albrecht Durer (1471-1528)

created many woodcuts and prints with religious

and scientific symbolism. One of his most famous
works, Melancholia I, explores the depressed state

of mind that opposes inspiration and expression.
Renaissance astrologers believed that the Jupiter magic
square (shown in the upper right portion of the image)
could aid in the cure of melancholy. The engraving's
date (1514) can be found in the lower row of numbers

in the square.

Save the report.

The contents of the first chapter are now complete.

Add an Image

Note This section builds on the previous tasks described in the step-by-step example
summarized in “Maintain Interactive MATLAB Report” on page 2-13.

If you have not completed the previous sections of this example, open the completed
report setup file: Magic Squares Report.

Create an image of Albrecht Diirer and include it in the report.

1
2

In the Outline pane on the left, select the Chapter component.

In the Library pane in the middle, under MATLAB, add an Evaluate MATLAB
Expression component.
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4 ’?J Report Generator
4 ?,.? Report - magic_squares.rpt*
B Eval - %This MATLAB code sets up two va...
ki Title Page - Magic Squares
4 ‘ﬁﬂ Chapter - Magic 5quares Explained
H Eval - %=Evaluate this string in the bas...

4 ‘E%E Paragraph - <Text from children=
ki Text - %< help{'magic’]>
# Text - The German artist Alb...

3  Move the Eval component under the Paragraph component so that the image
follows the introductory text. To move it, on the toolbar, click the down arrow.

4 ‘Eﬂ Report Generator
4 ﬁ.? Feport - magic_squares.rpt*
ki Eval - %This MATLAE code sets up two va...
B Title Page - Magic Squares
4 ".EE Chapter - Magic 5quares Explained

4 ".ﬁﬂ Paragraph - <Text from children=
ki Text - %o<help('magic)=
B Text - The German artist Alb...

A Eval - %cEvaluate this string in the bas...

4 With the Eval component selected, set these properties:

a C(Clear the Insert MATLAB expression in report and Display command

window output in report check boxes. You do not want to include the code or

its output in the report.

b In the Expression to evaluate in the base workspace text box, replace the
existing text with this MATLAB code.

%This loads a self-portrait of Albrecht
%Durer, a German artist. There is a
%magic square in the upper right corner
%0f the image.

durerData=load('durer.mat','-mat');
figure('Units', 'Pixels’, ...
'Position', [200 200 size(durerData.X,2)*.5 size(durerData.X,1)*.5 1);

image(durerData.X);
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colormap(durerData.map);
axis('image');

set(gca,...
'Xtick',I[1,...
'Ytick',I[1,...

'Units', 'normal', ...
'Position', [0 0 1 11);

clear durerData

This MATLAB code displays the Durer etching in a MATLAB figure window.

In the Evaluate this expression if there is an error text box, replace the
existing text with the following text:

disp(['Error during eval: ', evalException.message])

This code executes if an error occurs while loading the Durer etching.
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Evaluate MATLAB Expression
[ Insert MATLAB expression in report

[ Display command window output in report

Expression to evaluate in the base workspace: Eval Mow |

%This loads & self-portrait of Albrecht
%Durer, = Fermen artist. There is =

fmagic sgquare in the upper right corner
%0f the image.

durerData=load('durer mat"', "-mat');
figure('Units", "Pixels", __.
"Position’, [200 200 size({durerData_¥,2)*.5 size{durerDate

image (durerDate.X) ;
colormap (durerData .map) ;
gxis("image');
setigoa, - .-
"Ktiek', [1, .- -
"Ytick', [1, ...
'"Units", '"mormal", ...
"Position', [0 O 1 11);

clear durerData

4| | i

[V Evaluate this expression if there is an error:

disp([Error during Eval: ', evelException.message]

Revert | Help |

5 In the Outline pane on the left, select the Eval component.

6 In the Library pane in the middle, under Handle Graphics, add a Figure Snapshot
component to the report.
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11

To inline an image component (such as Image or Figure Snapshot), include it in a
Paragraph component.

In the Properties pane:

In the Paper orientation list, select Portrait.
In the Invert hardcopy list, select Don't invert.

Selecting this option specifies not to change the image's onscreen colors for
printing.

The next three steps set up the report to delete the image from the MATLAB
workspace after the image has been added to the report.

In the Outline pane, select the Figure Snapshot component.

In the Library pane, under MATLAB, add an Evaluate MATLAB Expression
component to the report.

In the Properties pane:

Clear the Insert MATLAB expression in report and Display command
window output in report check boxes. You do not want to include the code or
its output in the report.

In the Expression to evaluate in the base workspace text box, replace the
existing text with:

%This command deletes the Durer image
delete(gcf);

The delete(gcf) command deletes the current image in the MATLAB
workspace, in this case, the Durer etching.

In the Evaluate this expression if there is an error text box, replace the
existing text with the following text:

disp(['Error during eval: ', evalException.messagel])

This code executes if an error occurs while deleting the Diirer etching.

Save the report.
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Create the Magic Squares and Their Images

Add a chapter to the report for each magic square specified by the magicSizeVector
report variable. You use a For Loop component to perform this repetitive task. To create
the magic squares and their images, you perform these tasks:

“Create a For Loop” on page 2-30

“Add a Chapter for Each Square” on page 2-32

“Determine the Matrix Size” on page 2-33

“Insert the Magic Square Size into the Report” on page 2-34
“Create the Magic Square” on page 2-35

“Add Display Logic” on page 2-37

“Display the Magic Square” on page 2-39

Create a For Loop

Note This section builds on the previous tasks described in the step-by-step example
summarized in “Maintain Interactive MATLAB Report” on page 2-13.

If you have not completed the previous sections of this example, open the completed
report setup file: Magic Squares Report.

1
2

In the Outline pane on the left, select the Chapter component.

In the Library pane in the middle, under Logical and Flow Control, add a For Loop
component to the report.
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4 ’Z Report Generator
4 é? Report - magic_squares.rpt*
kit Eval - %eThis MATLAE code sets up two va..
kit Title Page - Magic Squares
4 ‘?ﬁ Chapter - Magic Squares Explained
"’:%5 for RPTGEN_LOOP = 1:1:5
4 ".ﬁﬂ Paragraph - <Text from children=>
kit Text - %o<help('magic)=
8 Text - The German artist Alb...
kit Eval - %:This loads a self-portrait of 4.,
) Figure Snapshot
ki Eval - %2This command deletes the Durer ..,

This For Loop component appears inside the Chapter component. However, the
magic squares should be processed after the first chapter, so make the for
component a sibling of the Chapter component, not a child.

In the Outline pane, select the for component.

4  Click the left arrow to make the for component a sibling of the Chapter component.

4 ﬂ Report Generator
4 ?,? Report - magic_squares.rpt*
kit Eval - %eThis MATLAE code sets up two va..,
kit Title Page - Magic Squares
4 ‘E%E Chapter - Magic Squares Explained
4 ".ﬁﬂ Paragraph - <Text from children=
kit Text - So< help('magic)=
8 Text - The German artist Alb...
h::i Eval - %:This loads a self-portrait of A...
ki Figure Snapshot
ki Eval - %2This command deletes the Durer ...
‘E%@ for RPTGEMN_LOOP = 1:1:5

5 In the Properties pane on the right:

a In the End text box, replace the existing text with this text:
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length(magicSizeVector)

This is the length of the vector that contains the various sizes for the magic
square matrices.

b In the Variable name text box, replace the existing text with the following text:
MAGIC SQUARE INDEX

This variable acts as a loop index.

4 ?J Report Generator
4 é? Report - magic_squares.rpt*
kit Eval - %eThis MATLAE code sets up two va..,
kit Title Page - Magic Squares
4 ‘fﬁﬂ Chapter - Magic Squares Explained
4 ".ﬁﬂ Paragraph - <Text from children=
kit Text - %o< help('magic)=
B Text - The German artist Alb...
ki Eval - %cThis loads a self-portrait of A..
ki Figure Snapshot
A Eval - %:This command deletes the Durer ...
":%5 for MAGIC_SQUARE_IMDEX = 1:1:length(magicsiz

6 Save the report.

Add a Chapter for Each Square

Note This section builds on the previous tasks described in the step-by-step example
summarized in “Maintain Interactive MATLAB Report” on page 2-13.

If you have not completed the previous sections of this example, open the completed
report setup file: Magic Squares Report.

Create a chapter for each square by adding a Chapter component to the report as a child
of the For Loop component. This causes the Report Generator to create a chapter on
each iteration of the for loop during report generation.

1 In the Outline pane on the left, select the for component.
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4

In the Library pane in the middle, under Formatting, add a Chapter/Subsection
component to the report setup.

It becomes a child of the for component.

In the Properties pane on the right, select Custom from the Title list and enter this
for the chapter title:

Magic Square # %<MAGIC SQUARE_INDEX>

Save the report.

Determine the Matrix Size

Note This section builds on the previous tasks described in the step-by-step example
summarized in “Maintain Interactive MATLAB Report” on page 2-13.

If you have not completed the previous sections of this example, open the completed
report setup file: Magic Squares Report.

Extract the size of each magic square matrix from magicSizeVector using an Evaluate
MATLAB Expression component.

In the Outline pane on the left, select the bottom Chapter component.

In the Library pane in the middle, under MATLAB category, add an Evaluate
MATLAB Expression component to the report setup.

In the Properties pane:

a C(Clear the Insert MATLAB expression in report and Display command
window output in report check boxes.

b Inthe Expression to evaluate in the base workspace text box, replace the
existing text with:
magic_Square Size=magicSizeVector(MAGIC SQUARE_INDEX);

This command extracts the next size for the magic square from the vector of
sizes initialized in the first Eval component of the report. The variable
magic_Square_ Size represents the size of the current magic square being
processed.

¢ In the Evaluate this expression if there is an error text box, replace the
existing text with this text:
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disp(['Error during eval: ', evalException.messagel])

This code executes if an error occurs while attempting to extract a value from
magicSizeVector.

4 ﬂ Report Generator
4 f,? Report - magic_squares.rpt*
H Eval - %=This MATLAE code sets up two va...
B Title Page - Magic Squares
4 ‘*.EE Chapter - Magic S5quares Explained
4 ‘ﬁﬂ Paragraph - <Text from childrenz
H Text - %< help'magic)=
8 Text - The German artist Alb...
ki Eval - %eThis loads a self-portrait of A...
ki Figure Snapshot
ki Eval - %cThis command deletes the Durer ...
4 ‘}.EE for MAGIC_SQUARE_INDEX = 1:1:length(magicsizeVector)
4 ".ﬁﬂ Chapter - Magic Square # %8« MAG...
ki Eval - magic_Square_Size=magicsizeVecto...

4  Save the report.

Insert the Magic Square Size into the Report

Note This section builds on the previous tasks described in the step-by-step example
summarized in “Maintain Interactive MATLAB Report” on page 2-13.

If you have not completed the previous sections of this example, open the completed
report setup file: Magic Squares Report.

Insert the size of the magic square into the report using the Paragraph and Insert
Variable components.

1 In the Outline pane on the left, select the bottom Eval component.

2 In the Library pane in the middle, under Formatting, add a Paragraph component
to the report setup.
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Do not change the properties. The variable that contains the size of the magic square
goes in this paragraph.

3 In the Outline pane, select the Paragraph component (below the for component).

In the Library pane, under MATLAB, add an Insert Variable component into the
report setup.

5 In the Properties pane on the right:

a In the Variable name text box, enter magic Square Size.
b  From the Display as list, select Inline text.

4 ‘?J Report Generator
4 f? Report - magic_squares.rpt®
A Eval - %2This MATLAE code sets up two va..,
A Title Page - Magic Squares
4 ‘ﬁﬂ Chapter - Magic Squares Explained
4 ¢§E Paragraph - <Text from children=
A Text - Se<help('magic)=
8 Text - The German artist Alb...
h:id Eval - %This loads a self-portrait of 4.,
kit Figure Snapshot
ki Eval - %2This command deletes the Durer ...
4 ?:%E for MAGIC_SQUARE_IMDEX = 1:1:length(magicsizeVector)
4 ‘ﬁﬂ Chapter - Magic Square # %8<MAG...
A Eval - magic_Square_Size=magicSizeVedto...
4 ".EE Paragraph - <Text from children=
kit Variable -magic_5Square_5ize

6 Save the report.

Create the Magic Square

Note This section builds on the previous tasks described in the step-by-step example
summarized in “Maintain Interactive MATLAB Report” on page 2-13.

If you have not completed the previous sections of this example, open the completed
report setup file: Magic Squares Report.
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To create the magic square and display the associated matrix or image, use the Evaluate
MATLAB Expression component.

1
2

5

In the Outline pane on the left, select the bottom Paragraph component.

In the Library pane in the middle, under MATLAB, add an Evaluate MATLAB
Expression component to the report setup.

Make this Evaluate MATLAB Expression component a sibling of the Paragraph
component. In the Outline pane, select the Eval component. Click the left arrow on
the toolbar.

In the Properties pane on the right:

Clear the Insert MATLAB expression in report and Display command
window output in report check boxes.

In the Expression to evaluate in the base workspace text box, replace the
existing text with this MATLAB code.

This MATLAB script produces a magic
square of size magic_Square Size
and creates an image of that square.

o® o o°

mySquare=magic(magic_Square Size);

clf

imagesc(mySquare);

title(sprintf('Magic Square N=%i',magic_Square_Size))
set(gca, 'Ydir', 'normal');

axis equal;

axis tight;

This code creates a magic square matrix mySquare of size
magic Square Size, and opens an image of that matrix in the MATLAB figure
window.

In the Evaluate this expression if there is an error text box, replace the
existing text with this text:

disp(['Error during eval: ', evalException.messagel])

This code executes if an error occurs while creating and displaying the magic
square.

Save the report.
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Add Display Logic

Note This section builds on the previous tasks described in the step-by-step example
summarized in “Maintain Interactive MATLAB Report” on page 2-13.

If you have not completed the previous sections of this example, open the completed
report setup file: Magic Squares Report.

Use Logical If, Logical Then, and Logical Else components to determine
whether to display the magic square as an array of numbers or as an image.

1 In the Outline pane on the left, select the Eval component.

4 ‘?J Report Generator
4 ﬁ? Report - magic_squares.rpt
kit Eval - %eThis MATLAE code sets up two va...
kit Title Page - Magic Squares
4 ".EE Chapter - Magic Squares Explained
4 °§E Paragraph - <Text from children=
kit Text - %< help('magic)=
8 Text - The German artist Alb...
B Eval - %This loads a self-portrait of 4.
A Figure Snapshot
ki Eval - %2This command deletes the Durer ...
4 ‘?ﬁ for MAGIC_SQUARE_IMDEX = 1:1:length(maqgicsizeVector)
4 ".EE Chapter - Magic Square # %8<MAG...
kit Eval - magic_Square_size=magicsizeVecto,.,
4 ".ﬁﬂ Paragraph - <Text from children=
ki “ariable -magic_Square_5ize
@ Eval - %This MATLAB script produces a m...

2 On the Library pane in the middle, under Logical and Flow Control, double-click
Logical If.

3 On the Properties pane on the right, in the Test Expression text box, replace the
existing text with this text:

magic Square Size<=largestDisplayedArray
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This command tests whether the current matrix size (magic Square Size) is less
than or equal to the value assigned in the first Eval component of the report
(largestDisplayedArray=15).

To process the result of this Logical If component, create two child components—
Logical Then and Logical Else. If magic_Square Size isless than or equal to 15,
the matrix variable appears in the report. If magic Square Size is greater than 15,
the matrix image appears in the report.

On the Outline pane, select the 1 f component.

4 ‘a Report Generator
4 ?,.? Report - magic_squares.rpt®
ki Eval - %:This MATLAE code sets up two va...
B Title Page - Magic Squares
4 °§E Chapter - Magic 3quares Explained
4 ".ﬁﬂ Paragraph - <Text from children=
ki Text - %o« help('magic)=
8 Text - The German artist Alb...
kit Eval - %2This loads a self-portrait of A..
kit Figure Snapshot
ki Eval - %eThis command deletes the Durer ...
4 ".EE for MAGIC_SQUARE_IMDEX = 1:1:length(magicSizeVectar)
B ".EE Chapter - Magic Square # %oéi< MAG,.,
ki Eval - magic_Square_5ize=magicsizeVedto...
4 ‘?ﬁ Paragraph - <Text from children=
# variable -magic_Square_Size
A Eval - %This MATLAE script produces a m...
‘ﬁﬁ if (magic_Square_sizedlt:=largestDisplayedArray)

On the Library pane, under Logical and Flow Control, double-click Logical Else.
On the Outline pane, select the if component again.
On the Library pane, under Logical and Flow Control, double-click Logical Then.

The then component appears above the else component.
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4 gﬂ Report Generator
4 f? Report - magic_squares.rpt®
B Eval - %This MATLAB code sets up two va...
A Title Page - Magic Squares
4 ".ﬁﬂ Chapter - Magic Squares Explained
4 "ﬁﬂ Paragraph - <Text from children=
ki Text - %< help('magic)=
B Text - The German artist Alb...
kit Eval - %This loads a self-portrait of A...
kit Figure Snapshot
@ Eval - %This command deletes the Durer ...
4 ‘ﬁﬂ for MAGIC_SQUARE IMDEX = 1:1:length(magicSizeVectar)
4 ".EE Chapter - Magic Square # Yoéi< MAG,.,
A Eval - magic_Square_size=magicsizeVecto...
4 ‘ﬁﬂ Paragraph - <Text from children=
# variable -magic_Square_Size
A Eval - %cThis MATLAE script produces a m..
4 ?:%E if ([magic_Square_Sized&lt: =largestDisplayedArray)

‘ﬁﬂ then
ﬁﬂ else

8 Save the report.

Display the Magic Square

Note This section builds on the step-by-step example presented in “Maintain Interactive
MATLAB Report” on page 2-13.

To see the completed report setup file, open Magic Squares Report.

1 In the Outline pane on the left, select the then component.

In the Library pane in the middle, under MATLAB, double-click Insert Variable.
3 In the Properties pane on the right:

a In the Variable name text box, enter mySquare, which is the variable that
contains the magic square of the specified size.
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b  From the Title list, select None.

¢ In the Array size limit text box, enter 0.
This Variable component displays the magic square matrix, stored in the
mySquare variable.

In the Outline pane, select the else component.

In the Library pane, under Handle Graphics, double-click Figure Loop.

Do not change its properties.

In the Outline pane, select the Figure Loop component.

In the Library pane, under Handle Graphics, double-click Figure Snapshot.
In the Properties pane:

a In the Paper orientation list, select Portrait.
b In the Image size list, select Custom.

(o]

Under the Image size list, enter [5 4] for the custom image size.

o

In the Invert hardcopy list, select Invert.
This option changes dark axes colors to light axes colors, and vice versa.

The Outline pane looks like this.
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4 ﬂ Report Generator
4 ?,.? Report - magic_squares.rpt®
B Eval - %This MATLAB code sets up two va...
A Title Page - Magic Squares
4 ‘ﬁﬂ Chapter - Magic S5quares Explained
4 ‘fﬁﬂ Paragraph - <Text from children=
ki Text - %< help('magic’)>
8 Text - The German artist Alb...
kit Eval - %cThis loads a self-portrait of A..
kit Figure Snapshot
 Eval - %This command deletes the Durer ...
4 "E for MAGIC_SQUARE_IMNDEX = 1:1:length{magicSizeVector)
B ":%E Chapter - Magic S5quare # Yoéi< MAG..,
A Eval - magic_Square_size=magicsizeVecto...
4 ﬁﬂ Paragraph - <Text from children=
B variable -magic_Square_Size
A Eval - %This MATLAE script produces a m..,
4 ?ﬁﬂ if ([magic_Square_Size&lt:=largestDisplayedArray)
4 48 then
B variable -mySquare
e ":%E glse
4 ?ﬁﬂ FigureLoop - Current
@ Figure Snapshot

9 Save the report.

Error Handling for MATLAB Code

You can add MATLAB code to a report, by using the Evaluate MATLAB Expression
component (also called the Eval component).

The Evaluate MATLAB Expression component dialog box includes an Evaluate this
expression if there is an error check box. The dialog box includes default error
handling code that you can use, or you can create your own error handling code.

If you do not change the default error handling code, then when you generate the report,
and there is an error in the MATLAB code that you added:
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* Ifyou clear Evaluate this expression if there is an error check box, then the
complete report is generated, without displaying an error message at the MATLAB
command line.

* Ifyou select Evaluate this expression if there is an error check box, then the
complete report is generated and an error message appears at the MATLAB command
line.

To stop report generation when an error occurs in the MATLAB code that you added,
change the second and third lines of the following default error handling code, as
described below:

warningMessagelLevel = 2;
displayWarningMessage = true;
failGenerationWithException = false;
failGenerationWithoutException = false;

To stop report generation and display an exception, change the default code to:

displayWarningMessage = false;
failGenerationWithException = true;

To stop report generation without displaying an exception, change the default code to:

displayWarningMessage = false;
failGenerationWithoutException = true;

If you want to replace the default error handling code, use the
evalException.message variable in your code to return information for the exception.

Generate a Report

Note This section builds on the step-by-step example presented in “Maintain Interactive
MATLAB Report” on page 2-13.

To see the completed report setup file, open Magic Squares Report.

At the beginning of this example, you specified HTML (from template) as the output
format of the report. If you did not, or if you opened the completed report setup file later
in the tutorial, set it that way now.


matlab:setedit magic-square.rpt
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On the toolbar, click the Report button to generate the report.

While the report generates, in the Message List window, specify the level of detail
you want the Message List window to display.

A Message List =10l x|
3 Important messages (running a loop) ;I

0 Mo messages

1) Error messages only

2)Warning messages

3 Imporkant messages (running a loop)

4 Standard messages {running a component)
5 Low-level messages {skatus information)

6) All messages

In the Report Explorer Outline pane, each component of the report setup file
highlights as it executes.

When processing finishes, the MATLAB Web browser opens and displays the HTML file.
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@ 'eb Browser - Magic Squares EI@
Magic Squares + H M H @ kY
L Al @& | Location: fileyfFFC  Users/bgitelmas/2ppDatafLocal/ Ternp/mireportgen/root.hteml -

Magic Squares

Columns, Rows, Diagonals: Everyone is Equal

Albrecht Duerer
Published 07-Tun-2016 15:11:32
Abstract

An introduction to Magic Squares and their meaning,

[H Tahle of Contents

Chapter 1. Magic Squares Explained

MAGIC Magic sdquare.
MAGIC(N) is an N-by-N matrix constructed from the integers
1 through N42 with equal row, column, and diagonal sums.
Produces walid magic squares for all N > 0 except N = Z.

Reference page in Doc Center
doc magic -

When you choose HTML (from template) as the output type, the table of contents
appears collapsed in the report. Expand or collapse each node by clicking the plus or

minus sign on the node. Press Ctrl+click to expand or collapse the entire structure (CMD

+click on Macintosh platforms).
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* “Open a Template File” on page 3-2

» “Reporter Templates” on page 3-5

* “Add Report Explorer Content to a Report” on page 3-20
* “Customize Chapters” on page 3-21

* “Customize Chapter Page Headers” on page 3-30
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Each report output type has a default template file for each output type, Microsoft Word,
PDE and HTML. Each template file contains a template library of document part
templates. The names of document part templates for a reporter start with the name of
that reporter to distinguish them from built-in Word templates. For Word output, the
template library is in a Word template file named default.dotx. Its document part
templates are in the Word Quick Parts Gallery. For PDE HTML, and single-file HTML
output, the template libraries are in default.pdftx and default.htmtx or
default.htmt template text files, respectively. Each document part template is in a
separate section of the template file. The default.pdftx and default.htmtx files are
zipped files packages and must be unzipped before you can edit them.

Open a Word Template File

To open a Word template file, which contains a template library, right-click the
default.dotx file name and select Open.

Note To open a Word template file, do not double-click its . dotx file name. Double-
clicking its file name opens a Word document (.docx) file that uses the .dotx file as its
template.

For some reporters, such as the Section and Chapter reporters, when you open the Word
template file, a blank page appears. To see images of the individual templates, click the
Explore Quick Parts icon in the Text section of the Insert ribbon. The document part
templates for reporters are of type mlreportgen.



Open a Template File

Header ~
D Footer =
[# Page Mumber -

Header & Footer

Text
Box~

Section

IT Equation -

TITLEL

COMTENT

Section?

Explore Quick Parts

TITLEZ

COMTENT

Section3

TITLES

COMTENT

To view the contents of an individual template, click its image in the Quick Parts Gallery
to copy it into the main part of the document.

To see its holes, select Design Mode in the Developer Ribbon. If the Developer Ribbon is
not displayed, select File Options and then, Customize Ribbon. In the Customize the
Ribbon list, check Developer.

To display paragraph and other formatting marks, select File Options and then, select
Display. Check Show all formatting marks.
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Note If you do not want to change the template file, remove all copied templates from
the main part of the document before you close or save the template file.

Open a PDF Template Library File

To open a PDF template library file, use unzipTemplate to unzip the default.pdftx
file. Then, use any text editor to open the docpart template.html template library
file. The template library file has an html extension because PDF templates are based on
HTML templates.

Open an HTML Template Library File
Open an HTML Template Library File

To open an HTML template library file, use unzipTemplate to unzip the
default.htmtx file. Then, use any text editor to open the docpart template.html
template library file.

Open a Single-File HTML Template Library File

To open a single-file HTML template, use any text editor to open the default.htmt
template library file.
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Reporter Templates

This reference describes the templates used by these reporters:

* Section (see “Section Templates” on page 3-5)
* Chapter (see “Chapter Templates” on page 3-18)

Use this information to create custom templates for use with one of these reporters or
from a reporter derived from these reporters.

Section Templates

The Section reporter uses six sets of templates for each of the three output types
supported by MATLAB Report Generator: docx, pdf, and html. Each set corresponds to the
six levels of section hierarchy that the Section reporter can generate. The first set
corresponds to a top-level section, the second set to a second-level subsection of a top-
level section, and so on.

Each level set contains three templates:

* A section body template named SectionN, where N is the level of a section (see
“Section1 Template” on page 3-5 and “Section2 - Section6 Templates” on page 3-
11).

* A numbered section title template named SectionNumberedTitleN (see “Numbered
Section Title Templates” on page 3-15).

* An unnumbered section title template names SectionTitleN (see “Unnumbered Section
Title Templates” on page 3-17).

A Section reporter determines which set to use when your report program adds the
reporter to a report object. For example, when your report program adds a Section
reporter to a Report object, the Section reporter uses the top-level template set. A
Section reporter uses the second-level template set when the report's add method adds
it to the report as part of the content of a top-level section reporter. A Section reporter
uses the third-level template set when the report add method adds it to the report as part
of the content of a second-level reporter, etc.

Sectionl Template

The Section reporter's Word, PDF, and HTML Section1 templates specify the format of a
top-level section generated by the Section 1 reporter in a Word, PDFE, and HTML report,
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respectively. All three templates specify the location of the holes and the default styles for
the Section reporter's Title and Content properties.

In addition, the PDF and Word templates specify the page layout properties of a top-level
section, including page orientation, margins, page headers, and page footers of a top-level
Word or PDF section. The Word and PDF templates specify a different header for the first
page of a section and for the pages that follows. The header of the first page contains only
a rule. The header of subsequent pages, called default header, contains the section title.
The first page footer and subsequent page footers are identical.

A top-level section starts on a new page having the properties specified by the top level
Section reporter's template. All subsequent pages needed to accommodate the top-level
section content have the same page layout, unless the content itself specifies a new page
layout, in which case, the page layout of subsequent pages changes. Default lower-level
section templates do not specify a page layout. As a result, adding subsections to a
section does not change the page layout. The content of subsections has the same layout
as the top-level sections.

* Word Section1 Template

The Word Sectionl template resides in the QuickParts gallery of the Section
reporter's default.dotx template file. The QuickParts gallery serves as the Section
reporter's Word template library. To view or edit the Section1 template, you must open
the default.dotx file in Word and create an instance of the template in the
default.dotx template . The Sectionl template appears as follows in Word:

°I'|

Title TITLEL Title )

Content| CONTENT | Content . ) Section Break (Next Page)

Note When you display a copy of the Word Sectionl template, it scrolls to the default
page header on the second page, which displays an error message. Refer to the note
below for an explanation of this error message. To see the template holes, scroll to the
top of the template.
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The Section 1 template specifies a header for the first page of a section that differs
from the header of succeeding pages. The header of all but the first page is called the
default header. The first page header contains a rule but is otherwise empty.

[ First Page Header -Section 1- |.I

Note The rule is implemented as an empty paragraph with a bottom border. The font
size of the paragraph is set to a very low value to minimize the paragraph's height.

The first page footer contains a Word page number field. When this template or a
report generated from it is opened in Word, Word replaces the field with the number of
the page on which the footer appears.

First Page Footer -Section 1- |

The Sectionl's default page header contains a Word StyleRef field that references the
section's title style (that is, SectionTitle). When the template or a report generated
from the template is opened in Word, Word replaces the StyleRef field with the content
of the first paragraph in the section that has the SectionTitle style. In a report, that
paragraph contains the section's title. Thus, the section's title appears in page headers
that follow the first page. (This is called a running head in document design.)

Note The Sectionl template occupies less than a page. Thus, when you copy the
Sectionl template from the Section reporter's QuickPart's gallery (that is, template
library) to the body of the default.dotx template, only the first page of the section
appears. However, Word creates a page with a new section (Section 2) that inherits
the Sectionl template's page headers. Word replaces the StyleRef field in the header
of this new section with an error message because there is no paragraph in the new
section with the referenced style.
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Header -Section 2-

Error!-No-text-of-specified-style-in-document.f|

The Sectionl template specifies a default page footer that is identical in content and
format to the first page footer.

Note To view or edit the default page footer, you must insert a page in the Sectionl
template as follows:

1

Copy the template from the Section reporter template's QuickParts gallery (that
is, its template library) to the body of the reporter template.

Insert a paragraph after the Content hole in the template.
Enable the paragraph's Page Break Before property.

Footer -Section 2-
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PDF Sectionl Template

The PDF Sectionl template resides in the template library of the Section reporter's
PDF template file (default.pdftx). The template file is a zip file. It stores the
template library in a file named docpart templates.html. To view or edit the
Section1 template:

1

Unzip a copy of the default.pdftx file using the Report API unzipTemplate
command.

Open the docpart templates.html file in the MATLAB editor or any other text
editor.

When you are finished editing the Section1 template, save the
docpart templates.html file.

Rezip the default.pdftx file, using the Report API zipTemplate command.
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For more information, see “Create a PDF Document Part Template Library” on page
13-43.

The PDF Sectionl template uses the following HTML markup to define the page layout
of a top-level PDF section generated by the Section reporter. The markup also
defines the location of the holes to be filled with the content of the Section reporter's
Title and Content properties.

<dptemplate name="5ection1">
<layout style="page-margin: 0.5in 1in 0.5in 1in 0.5in 0.5in 0in; page-size: 8.5in 11in portrait">
<pheader type="first" template-name="5ectionFirstPageHeader"/>
<pfooter type="first" template-name="5SectionFirstPageFooter"/>
<pheader type="default" template-name="5ectionDefaultPageHeader"/>
<pfooter type="default" template-name="5ectionDefaultPageFooter"/>
<pheader type="even" template-name="5SectionEvenPageHeader"/>
<pfooter type="even" template-name="SectionEvenPageFooter"/>
<pnumber format="1" />
</layout=
<hole id="Title" default-style-name="5ectionTitle1"=TITLE</hole>
<hole id="Content” default-style-name="SectionContent">CONTENT=</hole>
</dptemplate>

The pheader and pfooter elements in the Sectionl layout specify templates used to
define the content and layout of a top-level section's page headers and footers. The
header and footer templates reside in the same template library file
(docpart_templates.html) as the Sectionl template itself. The Section reporter
uses only the first page and default page templates.

The first page header and footer templates are

<dptemplate name = "SectionFirstPageHeader":
<p class="SectionTitleHeader"></p>
<hr/>

<fdptemplate>

<dptemplate name = "SectionFirstPageFooter":
<hr/>
<p class="SectionTitleFooter"=<page/></p>
<fdptemplate>
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The header template specifies an empty paragraph followed by a horizontal rule. The
empty paragraph specifies the style SectionTitleHead. It is defined in the template's
style sheet (see below). The first page footer template specifies a horizontal rule
followed by a page number.

The default page header template

<dptemplate name = "SectionDefaultPageHeader™:
<p class="SectionTitleHeader"><3tyleRef style-name="SectionTitlel"/></p>
<hr /=

</dptemplates>

3-10

specifies a paragraph containing a styleref followed by a horizontal rule. During report
generation, the Report API replaces the styleref element with the content of the top-
level section's title paragraph, thereby creating a running head.

The default page footer template

<dptenplate name = "SectionDefaultPageFooter™:>
<hr/>
<p claszs="SectionTitleFooter"><page/></p>
</dptemplates

specifies a horizontal rule followed by an automatically generated page number.

The styles for the header and footer templates are in the pdf/stylesheets/
root.css file.
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p-SectionTitleHeader |

font-family: 'Noto Sans', 'Noto Sans COJE JP', 'Noto Sans CJE
32", "MNoto Sans CJE ER';

font-=size: llpt;

color: black;

white-space: pre;

text-align:center;

}

p-SectionTitleFooter |

font-family: 'Noto Sans', 'Noto Sans COJE JP', 'Noto Sans CJE
32", "MNoto Sans CJE ER';

font-=size: llpt;

color: black;

white-space: pre;

text-align:center;

* HTML Sectionl Template

The Sectionl document part template in the default.htmt file specifies the Title and
Content holes.

<dptemplate name="5Section1"=
<hole id="Title" default-style-name="5ectionTitle1">TITLE</hole>
<hole id="Content">CONTENT</hole>

</dptemplate=

Section2 - Section6 Templates

The Section2-Section6 templates specify the format of subsections generated by the
Section reporter. Each template contains hole elements that specify the location of holes
to be filled with the content of the Section reporter's Title and Content properties,
respectively. The Title hole in each template specifies a default title style specific to the
subsection level defined by the template.

*  Word Section2 - Section6 Templates
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As an example, this image shows the Section2 template.

Title TITLEZ Title 4]

Content| CONTEMNT | Content - g

* PDF and HTML Section2 - Section6 Templates

As an example, this image shows the Section2 template.

<dptemplate name="5ection2">
<hole id="Title" default-style-name="SectionTitle2"=TITLE</hole=
<hole id="Content">CONTENT</hole>

</dptemplate>

Section Template Holes

All of the Section templates (Sectionl - Section6) have the holes described in this table.
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Hold ID

Hole Type

Description

Title

Block

The Section reporter fills

this hole with content based
on the type of the content of
its Title property as follows.

o Ifthe Tit'le property
content is an inline
object, such as a string
or
mlreportgen.domText
object, the Section
reporter uses a
SectionTitle reporter
to format and generate
the inline content as a
title. It then adds the
generated content to the
Title hole. The
SectionTitle reporter
use templates to format
the inline content.

o Ifits Title property
content is a paragraph or
other block-level object,
the Section reporter
adds the paragraph to
the Title hole.

o Ifits Title property
content is another
reporter, the Section
reporter adds the
content generated by the
reporter to the Title hole.

Content

Block

Content of the section
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Section Template Styles

The Section templates use styles to format some content. The Word templates define the
styles they use in the style sheet in the default.dotx template file. The PDF and HTML
templates define the styles in the stylesheets/root.css file in the default.pdftx
and default.htmt files, respectively. The following table describes the styles used by

the Section templates.

Style Name

Style Type

Description

SectionContent

Character

The Content hole in the
Section1-Section6 templates
specify this style as the
default text style for content
that fills the hole. The
content can specify styles or
formats that override the
default style.

SectionTitlel - SectionTitle6

Character

The Title hole in the
corresponding section
template specifies the
corresponding style name as
the default style for the
section's title. For example,
the Title hole in the
Sectionl template specifies
SectionTitlel as the name of
the default style for the title
of a top-level section.
Content added to the Title
hole can specify formats or
styles that override the
default style.

SectionTitleHeader

Character

The Sectionl page headers
use this style to center the
header content.

SectionTitleFooter

Character

The Sectionl page footers
use this style for the footer
content.
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Section Title Templates

If the content of the Section reporter's Title property is a string, Text, or other inline
object, it uses a SectionTitle reporter to generate the content used to fill the Title hole
in its section level templates. The SectionTitle reporter in turn uses templates to
format the inline content as a title. The SectionTitle reporter use two sets of templates
for each output type, one to create hierarchically numbered titles (1.1, 1.2, 1.2.1, and so
on), the other to create unnumbered titles. Each set contains six templates corresponding
to the six levels of sections that the Section reporter can generate. The templates reside
in the template libraries of the Section reporter's Word, PDF, and HTML template files,
default.dotx, default.pdftx, and default.htmt, respectively.

Numbered Section Title Templates

If a report or Section reporter specifies that its titles be numbered, the SectionTitle
reporter uses automatically numbered templates to format the inline content of the
Section reporter's Title property. The titles are named SectionNumberedTitleN, where
N is the section level to which the template applies. For example, the name of the
template for a top-level section title is SectionNumberedTitle1. Each template contains a
paragraph element that specifies the same style as is specified by the Title hole in the
corresponding section level template, for example, SectionTitlel for a top-level section
title. See “Section Template Styles” on page 3-14.

The title paragraph contains the following holes.
* NumberPrefix hole to be filled with the content of SectionTitle reporter's
NumberPrefix property (empty by default)

* Autonumber markup that is replaced by a hierarchical number during report
generation. The autonumber markup differs for each level template so as to generate
the hierarchical number appropriate to that level.

* NumberSuffix hole to be filled with the content of the SectionTitle reporter's
NumberSuffix property (empty by default).

» Content hole to be filled with the content of the SectionTitle reporter's Content
property.

The following images show the Word, PDE, and HTML SectionNumberedTitle1 templates,
respectively. Lower-level templates are similar.

*  Word SectionNumberedTitlel Template
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NumberPrefix | NUMBER_PREFIX®) 1| Numbersuffic NUMBER_SUFFIX®) )( Content 'TITLE-

CONTENT )
1

* PDF SectionNumberedTitlel Template

<dptemplate name="SectionNumberedTitle1">
<h1 class="SectionTitle1" style="counter-increment:sect1;counter-reset.sect2? sect3 sect4 sectd sectt figure table;"
=<hole iId="NumberPrefix">NUMBER_PREFIX</hole
»<autonumber stream-name="sect1"></autonumber
><hale id="NumberSuffix" *NUMBER_SUFFIX</hole
><hale id="Content">TITLE CONTENT</hole
></h1>
</dptemplate>

* HTML SectionNumberedTitlel Template

<dptemplate name="5ectionNumberedTitle1">
<h1 class="5ectionTitle1" style="counter-increment:sect1;counter-reset:figure table;"
=<hole id="NumberPrefix">NUMBER_PREFIX</hole
»<autonumber stream-name="h1" format="n"></autonumber
=<hole id="NumberSuffix" *=NUMBER_SUFFIX</hole
><hole id="Content">TITLE CONTENT</hole
=</h1=

</dptemplate>

During report generation, the Section reporter sets the Content property of the
SectionTitle reporter to the inline content of the Section reporter's Title property.
It does not set the NumberPrefix and NumberSuffix properties. As a result, the title
generated by the SectionTitle reporter consists by default of a hierarchical number
followed by the title text.

The SectionTitle reporter provides the NumberPrefix and NumberSuffix holes to
facilitate labeling of titles by derived reporters. For example, the Chapter reporter,
which is derived from the Section reporter, sets the NumberPrefix property to Chapter
in English locales. In some East Asian locales, the Chapter reporter sets the
NumberSuffix to the character designating chapter.
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Note If you customize a numbered section template, do not remove or replace the SEQ
fields in a Word template or the autonumber markup in a PDF or HTML template. To
generate unnumbered sections, use the “Unnumbered Section Title Templates” on page 3-

17.

SectionNumberedTitle Template Holes

All of the SectionNumberedTitle templates (Sectionl - Section6) have the holes described
in this table.

Hole ID Hole Type Description

NumberPrefix Inline Prefix to display before the
section number.

NumberSuffix Inline Suffix to display after the
section number.

Content Inline Content of the title

Unnumbered Section Title Templates

If the report specifies that the current section uses unnumbered titles, the
SectionTitle reporter uses unnumbered templates to generate section titles. The
unnumbered templates are named SectionTitleN where N is the level of the section whose
title is to be generated. For example, the template for a top-level section is named
SectionTitlel. Each template contains a paragraph element that specifies the same style
as is specified by the Title hole in the corresponding section level template, for example,
SectionTitlel, for a top-level section title. See “Section Template Styles” on page 3-14.
The title paragraph contains a hole to be filled by the content of the SectionReporter's
Content property (set by the Section reporter during report generation).

The follow images show the Word, PDF, and HTML versions of the SectionTitle1
templates. Lower-level templates are similar.

*  Word SectionTitle Template

All levels of the Word SectionTitle templates have the same content hole.
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Content 'TITLE-CONTENT | /Y
1

* PDF and HTML SectionTitlel Template

<dptemplate name="5ectionTitle1">
<h1 class="SectionTitle1"
=<hole id="Content">title text</hole
=</h1>

</dptemplate>

* PDF and HTML SectionTitle2 - SectionTitle6 Templates

These section title templates include a Content hole, as in SectionTitlel template.
Each of these sections specifies its title style.

<dptemplate name="5ectionTitle2">
<h2 class="SectionTitle2"
=<hole id="Content" default-style-name="5ectionTitle 1">title text</hole
=afh2=

</dptemplate=

3-18

SectionTitle Template Hole

All of the SectionTitle templates (Sectionl - Section6) contain the hole described in this
table.

Hole ID Hole Type Description
Content Inline Content of the title
Chapter Templates

The Chapter reporter, a subclass of the Section reporter, uses the Section reporter's
top-level template set to generate its content. This is because a Chapter-generated
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section is nearly identical to a Section-generated section. However, the two types of
sections differ in two respects:

* The title of a chapter section contains the word Chapter in English locales or the
equivalent in other locales supported by the Report API. The Chapter reporter
includes the word Chapter in titles by setting the NumberPrefix or NumberSuffix
properties of the SectionTitle reporter used to generate the chapter title.

» All Section-generated top-level sections start on page 1. By contrast, only the first
chapter generated by a Chapter reporter starts on page 1. Succeeding chapters
continue page numbering from the previous chapter. The Chapter reporter
implements this behavior programmatically, thus avoiding the need to use a modified
version of the Section top-level template.

See “Section1 Template” on page 3-5, “Numbered Section Title Templates” on page 3-15,
and “Unnumbered Section Title Templates” on page 3-17
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Add Report Explorer Content to a Report

3-20

Use the Report API's RptFile reporter to add Report Explorer content to a Report API
report. For example, this script adds content generated by a Report Explorer setup file
named recontent. rpt to a report generated by the Report API.

import mlreportgen.report.*

rpt = Report('myreport', 'docx');
add(rpt,TitlePage("Title", "My Report"));

add(rpt, RptFile( "recontent.rpt"));

close(rpt);
rptview(rpt);

Note To work with the Report API, a Report Explorer setup file must conform to certain
restrictions. See mlreportgen. report.RptFile for more information.
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Customize Chapters

You can customize the content and format of chapters generated by the Report API
Chapter reporter, mlreportgen. report.Chapter. You can perform some
customizations by setting properties. For example, you can use the Chapter reporter
Layout property to change the chapter layout from portrait to landscape. For more
information on chapter customizations that are available by setting properties, see
mlreportgen.report.Chapter.

For other customizations, you must modify the Chapter reporter template, class definition
file, or both the template and class definition file. To customize only static content, such
as a logo in a page header, modify the Chapter reporter default template and use the
modified template with the reporter. To customize dynamic content or both dynamic and
static content, create a custom Chapter reporter and modify its template and class
definition file.

For an example that customizes chapter page headers with fixed and dynamic content,
see “Customize Chapter Page Headers” on page 3-30.

Customize Static Content

If your chapter customization includes only static content, create a copy of a chapter
template, edit the copy, and use the new template when you generate a report.

Create the Template

Create a copy of the chapter template for the type of report that you plan to generate. For
example, to copy the template for a PDF chapter to the file mychapter.pdftx in the
folder mytemplates, enter:

mlreportgen.report.Chapter.createTemplate( 'mytemplates/mychapter', 'pdf');

Edit the Template

The way that you edit a chapter template depends on the type of report that you are
generating:

+ “Edit a PDF Template” on page 3-23
+ “Edit a Word Template” on page 3-25
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Use the Template
In your report generation program:

1 Define a chapter reporter.
2 Setthe TemplateSrc property of the reporter to the path of the custom template.
For example:

chapter = mlreportgen.report.Chapter;
chapter.TemplateSrc = 'mytemplates/mychapter.mychapter.pdftx"';

Customize Dynamic Content

If your chapter customization includes dynamic content, you must create a skeleton
custom reporter class so that you can define properties for the dynamic content. When
you create the skeleton custom chapter reporter, the chapter templates for all report
types (PDF, Word, and HTML) are copied to a resources/templates folder. Edit the
chapter template to contain the content that you want to generate. Add holes for the
dynamic content. When you generate a report, use the custom chapter reporter and
assign values to the properties that correspond to the holes.

Create a Skeleton Custom Reporter Class
Use the mlreportgen.report.Chapter.customizeReporter method to:

* Create a skeleton reporter class.
* Copy the default templates for each type of report to a resources/templates folder.

For example, this code creates a class named Chapter and copies the templates to the
resources/templates folder in the folder +myCompany/@Chapter:

mlreportgen.report.Chapter.customizeReporter('+myCompany/@Chapter')

Edit the Template

The way that you edit a chapter template depends on the type of report that you are
generating:

+ “Edit a PDF Template” on page 3-23
+ “Edit a Word Template” on page 3-25
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Define the Properties for the Dynamic Content

In the custom reporter class, define a property for each hole that you added to the
template. For example:

classdef myChapter < mlreportgen.report.Chapter
properties
Project = "'
Date = "'
end

end

A property name must match a hole ID in the PDF template or a hole Title in the Word
template.

Use the Custom Reporter Class
In your report generation program:

» Create a chapter reporter from the custom chapter reporter class.
* Assign values to the reporter properties that correspond to the holes in the template.

For example:

chapter = myCompany.Chapter();
chapter.Project = 'ABC Project';
chapter.Date = date;

Edit a PDF Template

The PDF chapter template file is a zip file. To modify the template, unzip the template file,
edit docpart_templates.html in a text editor, and package the extracted files back
into the zip file. See “Chapter Templates” on page 3-18.

Locate the Template File

If your template file was created by using
mlreportgen.report.Chapter.createTemplate, the packaged template file is in the
location that you specified. For example, this code creates the template file
mychapter.pdftx in the mytemplates folder:
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mlreportgen.report.Chapter.createTemplate('mytemplates/mychapter"', 'pdf');

If your template file was created by using
mlreportgen.report.Chapter.customizeReporter, the template file has the name
default.pdftx and is in the resources/templates/pdf subfolder of the folder that
contains the chapter reporter class definition file.

Unzip the Template File

Unzip the package file by using the unzipTemplate function. For example, this code
extracts files from the template file mytemplates/mychapter.pdftx into the folder
mychapter:

unzipTemplate('mytemplates/mychapter.pdftx', 'mychapter');
The extracted files include:

* docpart templates.html
* root.html
* Folders for images and stylesheets

Edit the Markup
Open docpart templates.html in a text editor and edit the markup.

To define a hole for dynamic content, use the hole element. When you add a property for
the hole in the custom chapter reporter, the property name must match the hole id value.

Modify a header or footer by editing the header or footer template. The templates for
headers and footers are SectionFirstPageHeader, SectionFirstPageFooter,
SectionDefaultPageHeader, SectionDefaultPageFooter,
SectionEvenPageHeader, and SectionEvenPageFooter.

To specify the same header or footer for all chapter pages, provide only the
SectionDefaultPageHeader or SectionDefaultPageFooter in the list of header
and footer templates in the Section1 dptemplate element. Remove the other headers
and footers from the list.

Package the Template Files

Package the files back into the template file by using the zipTemplate function. For
example, if mytemplates/mychapter contains the unzipped files, this code packages
the files into mychapter.pdftx in the mytemplates folder.
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zipTemplate('mytemplates/mychapter.pdftx', 'mytemplates/mychapter');

Edit a Word Template

To edit a Word template:

Open the template file in Word.

Create a temporary copy of the Sectionl template in the template document,. The
Sectionl template, which is used for both chapters and top-level sections, is in the
Quick Parts gallery of the template document.

3 Edit the temporary copy and save the copy to the Quick Parts gallery.
Delete the temporary copy from the template document and save the template file.

Locate the Template File

If your template file was created by using
mlreportgen.report.Chapter.createTemplate, the template file is in the location
that you specified. For example, this code creates the template file mychapter.dotx in
the mytemplates folder:

mlreportgen.report.Chapter.createTemplate('mytemplates/mychapter’, 'docx");

If your template file was created by using
mlreportgen.report.Chapter.customizeReporter, the template file has the name
default.dotx and is in the resources/templates/docx subfolder of the folder that
contains the chapter reporter class definition file.

Open the Template File in Word
Open the template file by using one of these methods:

* In MATLAB, in the Current Folder pane, right-click docpart templates.dotx
and click Open Outside MATLAB.

* Outside of MATLAB, right-click docpart templates.dotx and click Open.

Note Do no double-click a Word template file to open it. Double-clicking the file opens a
Word document file that uses the template.

The template document opens to an empty page.
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Show the Formatting Symbols

To make the paragraph and formatting symbols visible, on the Home tab, click the Show/
Hide ' button.

Copy the Sectionl Template into the Template Document

1  Position the cursor in front of the paragraph in the template document.

2 On the Insert tab, in the Text group, click Quick Parts, then click the Sectionl
building block.

D 4 | # signature Line - T[ D
|

|E_.1. Date & Time

F{;laur:;Ii Wn:nidﬁkrt [ Object - Equitin:nn S}fr‘r:htﬂ
mireportgen -
Section1

TIMEL

COMTENT

Word inserts a copy of the Sectionl template and a dummy Section? section. The
dummy section is ignored when you generate a report. The cursor is positioned in the
body of the dummy section.

3 Scroll up to the Sectionl first page template.

TITLE1Y]

CONTENTHY) Section Break (Mext Page)
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Edit the template to contain the content that you want to generate. To add holes to a
Word template, see “Add Holes in a Microsoft Word Template” on page 13-135.

To modify headers and footers, see “Tips for Editing Headers and Footers in a Word
Template” on page 3-28.

Save the Template in the Quick Parts Gallery

1

If the header or footer is open, close it by double-clicking the page outside of the
header.

Select all of the content in the template by pressing Ctrl+A.
On the Insert tab, click Quick Parts, and then click Save Selection to Quick Parts
Gallery.

In the Create New Building Block dialog box, in the Name field, enter Sectionl.
Set Gallery to Quick Parts, Category to mlreportgen, and Save in to the name of
the template file.

Create Wew Building Block 7 X
Mame: Sectionl
Gallery: Quick Parts e

o EL 1L mireportgen

Description:
Save in: default A
Dptions: Insert content only e
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Save the Template File

It is a best practice to delete the content from the body of the template document before
you save the template file.

Tips for Editing Headers and Footers in a Word Template

Here are some tips for editing headers and footers in a Word Template.

* To control whether headers and footers on the first page differ from headers and
footers on the following pages, double-click a header. Then, under Header and
Footer Tools, on the Design tab, select or clear the Different First Page check box.

Header & Footer Tools

Design

[| Different First Page 4 Hea

[ | Different Odd & Even Pages "'+ Foo

Show Document Text Inse
Options

* To control whether even page headers and footers differ from odd page headers and
footers, select or clear the Different Odd and even Pages check box.

* To see the headers and footers for pages that follow page one, add empty paragraphs
to page one until a second Sectionl page is created. Double-click the header on the
new page.

* The default first page header includes a horizontal rule, which is the bottom edge of a
small paragraph. To make the rule invisible, select the small paragraph. Then, on the
Home tab, in the Paragraph group, Borders > No Border.
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See Also

TMormal | SectionCi
Bottorm Border
Top Border
Left Border

Eight Border

ﬂﬁﬂrd er

See Also

mlreportgen.report.Chapter |unzipTemplate | zipTemplate

More About

“Reporter Templates” on page 3-5

“Open a Template File” on page 3-2

“Add Holes in a Microsoft Word Template” on page 13-135
“Add Holes in HTML and PDF Templates” on page 13-148
“Customize Chapter Page Headers” on page 3-30

3-29



3 Report API Reports

Customize Chapter Page Headers
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This example shows how to customize chapter page headers that are generated by the
Report API chapter reporter. You can customize chapter page headers for PDF and
Microsoft® Word reports. The example generates a report for a fictitious company, ABC
Services. The custom header contains the company logo, project name, and report date.

ABC

Renvices Control Systems Consulting 18-Jul-2019

The company logo is fixed in the header. The project name and report date are dynamic.
They are created when the report is generated.

The workflow is:

Create a custom chapter reporter class.
Modify the headers in the PDF or Word chapter template.

Add properties to the custom reporter class for the dynamic content in the custom
headers.

4 Write a report program that uses the custom reporter and specifies values for the
properties.

Create a Custom Chapter Reporter Class

Create a skeleton chapter reporter class by calling the
mlreportgen.report.Chapter.customizeReporter method. Name the class
Chapter and save it in a class folder inside of a package folder.

mlreportgen.report.Chapter.customizeReporter('+abc/@Chapter');

This method call also copies the chapter template for each report type to the +abc/
@Chapter/resources/templates folder.

Modify the Headers in the Chapter Template for a PDF Report
To modify the header definitions in the chapter template for a PDF report:

1  Unzip the template file.
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2 Edit the header definitions in the docpart templates.html file using a text editor.
3 Package the extracted files into the template file.

Unzip the Template File

Change the current folder to the folder that contains the PDF template file,
default.pdftx and then unzip the file.

cd('+abc/@Chapter/resources/templates/pdf');
unzipTemplate('default.pdftx');

The extracted files are in a folder named default.
Copy the Image File

Copy the image file for the company logo to the default/images folder. Use the image
file, abc_logo.png, attached to this example, or your own image file.

Edit the Header Definitions

In the MATLAB® editor or a text editor, open docpart templates.html, which is in
the folder named default.

To make the headers the same on all pages, in the Sectionl dptemplate element, delete
SectionFirstPageHeader and SectionEvenPageHeader from the list of header and
footer templates.

<dptemplate name="Sectionl">
<layout style="page-margin: 0.5imn lin 0.5in lin 0.5in 0.5in Oin; page-size: 8.5in 1lin portrait™>

kpheader type="rirst™ template-name="sSectionFirstPageHeader™/> I

<pfooter type="first™ temp1ate—name=FhectiDnFi:StPageFooter"f)

nDefaultPageHeadexr "/ >

<pheader type="default" template-name="Secti

<pfooter type="default" template-name="SectionDefaultPageFooter/"/>

|{pheader type=—Tevenn temp1ate—name=FhectionEvenPageHeader"f) |
<pfooter type="even™ template-name="SectionEvenPageFootexr™/>
<pnumber format="1" />
<flayout>
<hole id="Title" default-style-name="SectionTitlel">TITLE</hole>
<hole id="Content" default-style-name="SectionContent">CONTENT</hole>
<fdptemplate>

SectionDefaultPageHeader is now the template for all chapter page headers. Find the
SectionDefaultPageHeader template.
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<dptemplate name = "SectionDefaultPageHeader">
<p class="SectionTitleHeader"><StyleRef style-name="SectionTitlel"/></p>
<hr/>

</dptemplate>

Replace it with this markup:

<dptemplate name = "SectionDefaultPageHeader">
<table width="100%">
<tr style="border-bottom: 1lpt solid #ccc;">
<td style="text-align:left; padding-bottom:2pt" valign="bottom"><img src=":
<td style="text-align:center; padding-bottom:2pt; font-family:arial; font-
font-weight: bold" valign="bottom"><hole id="Project">PROJECT</hole
<td style="text-align:right; padding-bottom:2pt; font-family:arial; font-s:

</tr>
</table>
</dptemplate>

The markup defines a one-row, three-column table with these characteristics:
* The table cells contain the company logo, a hole for the project name, and a hole for

the report date.

* The contents of the first, second, and third cells are left-aligned, center-aligned, and
right-aligned, respectively.

* The padding between the bottom of the cell and the cell contents is 2pt.
* The cell contents are aligned with the bottom of the cell.

* The font for the text in the second cell is Arial, 10pt, and bold. The font for the text in
the third cell is Arial and 10pt.

* The bottom border of the row is visible. The table does not have borders because the
HTML does not specify the border property.

Package the Extracted Files

If you edited docpart templates.html in the MATLAB Editor, close the file before you
package the files.

Make sure that you are in the +abc/@Chapter/resources/templates/pdf folder,
which contains the folder named default. Package the files in default back into the
original PDF template file.

zipTemplate('default.pdftx', 'default');
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Modify the Headers in the Chapter Template for a Word Report

In Word, the Sectionl template is used for chapters and top-level sections. The template
is in the Quick Parts gallery.

To modify the headers in the Sectionl template:

1 Open the template file in Word.

Create a temporary copy of the Sectionl template in the body of the template
document.

Specify whether all pages have the same header.
Edit the headers.
Save the modified Sectionl template to the Quick Parts gallery.

S U A W

Delete the content from the body of the template document and save the template
file.

Open the Template File
Navigate to +abc/@Chapter/resources/templates/docx.

Open the template file by using one of these methods:

* In MATLAB, in the Current Folder pane, right-click docpart templates.dotx and
click Open Outside MATLAB.

* Outside of MATLAB, right-click docpart templates.dotx and click Open.

The template document opens to an empty page.

Display Formatting Symbols

To make paragraph and formatting symbols visible, on the Home tab, click the Show/
Hide button

Copy the Sectionl Template into the Template Document

On the Insert tab, in the Text group, click Quick Parts, and then click the Sectionl
building block.
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|;| 4 [ # Signature Line ~ IJ'E Q

o [T F;'g.DateE-:Time . S
uic ardArt quation Symbo
Parte= - ™ Object ~ - .
mireportgen

Sectioni

TITLEL
CONTENT

In the template document, Word inserts a copy of the Sectionl template and a dummy
Section2 section. The dummy section is ignored when you generate a report.

Error!-No-text-of-specified-style-in-document.

The cursor is in the dummy Section2. Scroll up to the Sectionl template. To open the
header, double-click it.

First Page Header -Section 1- |

COMNTENTHY] Section Break (Mext Page)
Specify That All Pages Have the Same Header

Under Header and Footer Tools, on the Design tab, clear the Different First Page
check box.
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Header & Footer Tool

Different First Page Lot H
%ﬁliﬁerent Odd & Even Pages . '+Fc
Show Document Text In

Options

The header for pages that follow the first page is copied to the first page header.

Error!-No-text-of-specified-style-in-document. 1|

CONTENTY]

Section Break (Mext Page).

Add a Table to the Header

On the Insert tab, Click Table. Move the pointer over the grid until you highlight three

columns and one row.

Insert Design Layout Refl

B
| o) lag) [
Table  Pictures Online Shapes

- Pictures -
3x1 Table

LI NOOooodd
Nt

Delete the message Error! No text of specified style in document and the

paragraph that contains it.
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The horizontal rule from the original header is the bottom border of a paragraph. To make
it invisible, click the paragraph and then, on the Home tab, in the Paragraph group,

click the arrow to the right of Borders " and then click No Border.
Add the Logo to the First Table Cell

Copy and paste the company logo into the first table cell. Use the attached
abc_logo.png file or your own image file.

Add Holes for the Project and Date

If the Developer ribbon is not available, click File > Options, and then click Customize
Ribbon. Under Customize the Ribbon, select Developer.

On the Developer tab, click Design Mode so that you can see hole marks with the title
tag when you create a hole.

%’Daign Mode
=

2=| Properties

. Fl XML Mapping
Pane

rols Mapping

In the second cell, add a few spaces before the entry mark so that the hole that you add is
an inline hole.

Click in front of the spaces.

Click the Rich Text Content Control button A2, A rich text content control displays.

ABC : :
Services [ Klick-ortap-here-ta-enter- o
text. | |-H
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Replace the text in the control with text that identifies the hole, for example, Project
Name.

On the Developer tab, click Properties.

In the Content Control Properties dialog box:

* in the Title field, enter Project.
* In the Tag field, enter Hole.

Content Control Properties ? >
General

Title: Project

Tag: Hole

Show as: |Bounding Box| ~

Color: & b

[ ] iUse a style to format text typed into the empty control;

Style: [Default Paragraph Font| s

Select the Use a style to format text typed into the empty control check box. Then,
click New Style.

In the Create New Style from Formatting dialog box, enter Project in the Name
field. For the formatting, specify Arial, 10pt. Click the Bold button. Click OK.
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Create Mew Style from Formatting

Properties
Mame: Project
Style type: Character
Style based on: d Default Paragraph Font

Style for following paragraph

Formatting

Arial w10~ |iB] T U Automatic ~

In the Content Control Properties dialog box, click OK.

Add an inline hole for the date in the third cell. Use the steps that you used to add a hole
to the second cell.
1 Add a few spaces before the entry mark.

Click in front of the spaces.

Click the Rich Text Content Control button Aa.
4 Delete the spaces that you added.

Replace the text in the control with text that identifies the hole, for example, Report
Date.

6 On the Developer tab, click Properties. In the Content Control Properties dialog
box, enter Date in the Title field and Hole in the Tag field.

7  Select the Use a style to format text typed into the empty control check box.
Then, click New Style.

8 In the Create New Style from Formatting dialog box, enter ReportDate in the
Name field. For the formatting, specify Arial and10pt.

The table looks like:

ABC

| services 1y Project | Project-Name) Date |Report-Date | 0
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Specify the Table Cell Bottom Margin
To specify the cell bottom margin:

Select and right-click the table.
Click Table Properties, then on the Table tab, click Options.

In the Table Options dialog box, under Default cell margins, in the Bottom field,
enter 2pt.

Table Options ? *

Default cell margins

Top: ar Left: 0.08°

L LA ] L
A k| Ak

Eottom: | 2pt Right: |0.08"

Default cell spacing

4|k

|:| Allow spacing between cells

Options
Automatically resize to fit contents

Align the Cell Contents

Left-align the logo in the first cell. Center the hole in the third cell. Right-align the hole in
the third cell.

To align cell contents:

1 Select the image or hole in the table.

2  On the Home tab, in the Paragraph group, click the Align Left, Center, or Align
Right button.
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1|
I1f
1
Il
=
11|
4
&
4
4

Paragraph Ta

Make the Top and Side Borders of the Table Invisible

To display only the bottom border of the table:

1  Select the table.
2 Under Table Tools, on the Design tab, click Borders > No Border.
3 Click Borders > Bottom Border.
4 Set the Line Weight to 1pt.
1pt . o=

Jorder o Borders Border
ityles - wm PEN Color~ - Painter

Borders M

Save the Custom Template
Close the header by double-clicking the page outside of the header.
To select all of the content in the template, press Ctrl+A.

On the Insert tab, click Quick Parts, and then click Save Selection to Quick Parts
Gallery.

In the Create New Building Block dialog box, in the Name field, enter Sectionl. Set
Gallery to Quick Parts, Category to mlreportgen, and Save in to default. Click OK.
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Hame: Sectioni

Gallery: Quick Parts w
Category: mlreportgen v
Description:

Save in: default e
Dptions: Insert content only A

3

When you see the message Do you want to redefine the building block
entry?, click Yes.

Save the Template File

It is a best practice to delete the content from the body of the template document before
you save the template file.

With the content selected, press Delete.

To hide the formatting symbols, on the Home tab, in the Paragraph group, click the click

the Show/Hide button
Save the template file.
Add Properties to the Custom Reporter Class

Because the custom header has holes for dynamic content, you must define properties for
the holes.

Navigate to the +abc/@Chapter folder.

In the class definition file, Chapter.m, add the properties that correspond to the
Project and Date holes in the header. Replace the empty properties section with:

3-41



3 Report API Reports

3-42

properties
Project = ''
Date = ''
end

Save the class file.
Generate the Report Using the Custom Chapter Reporter

When you generate the report, create the chapter reporter from the abc.Chapter class.
Assign values to the properties that correspond to the holes in the header.

Before running the following code, navigate to the folder that contains the +abc folder.
Alternatively, to add the folder that contains the +abc folder to the MATLAB path:

1 [n the MATLAB Toolstrip, on the Home tab, in the Environment group, click Set
Path.

In the Set Path dialog box, click Add Folder.
In the Add Folder to Path dialog box,click the folder and then click Select Folder.

You cannot add packages to the MATLAB path. Add the folder that contains the package
folder.

Generate a PDF Report

import mlreportgen.dom.*
import mlreportgen.report.*

report = Report("Consulting Report","pdf");
chapter = abc.Chapter();

chapter.Project = "Control Systems Consulting";
chapter.Date = date;

chapter.Title="0Overview";

add(chapter, "Chapter content goes here.");
add(report, chapter);

close(report);

rptview(report);

Generate a Word Report

import mlreportgen.dom.*
import mlreportgen.report.*

report = Report("Consulting Report","docx");



See Also

chapter = abc.Chapter();

chapter.Project = "Control Systems Consulting";
chapter.Date = date;

chapter.Title="0Overview";

add(chapter, "Chapter content goes here.");
add(report, chapter);

close(report);

rptview(report);

See Also

mlreportgen.report.Chapter |unzipTemplate | zipTemplate

More About

. “Customize Chapters” on page 3-21

. “Reporter Templates” on page 3-5

. “Add Holes in a Microsoft Word Template” on page 13-135
. “Add Holes in HTML and PDF Templates” on page 13-148
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* “Report Setups” on page 4-2

* “Create a New Setup File” on page 4-4

* “Open a Report Setup” on page 4-6

* “Close a Report Setup” on page 4-9

* “Save a Report Setup” on page 4-10

* “Load Report Setup into MATLAB Workspace” on page 4-11
* “Insert Components” on page 4-12

* “Set Component Properties” on page 4-13

* “Move Components” on page 4-14

* “Delete Components” on page 4-16

* “Deactivate Components” on page 4-17

* “Send Components to the MATLAB Workspace” on page 4-18
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Report Setups

4-2

In this section...

“Setup Hierarchy” on page 4-2
“Setup Files” on page 4-3

“Create a Report Setup” on page 4-3

Note Do not setup or create new reports using the Report Explorer app. This information
is provided for maintaining existing reports only. To create a new report generator, use
the Report and DOM APIs. See “Create a Report Program” on page 13-3.

A report setup is a set of MATLAB objects, called components, that specified the content
and form of a report.

The MATLAB Report Generator provides a setup editor, called the Report Explorer, that
you used to create and edit report setups.

Once you created a setup, you can generate a report from it, using the Report Explorer or
MATLAB commands.

Setup Hierarchy

A report setup has a hierarchical structure that generally mirrors the structure of the
type of report that it defines.

For example, a report typically has a title page and one or more chapters. Each chapter
contains one or more sections, each of which contains one or more paragraphs, figures,
tables, lists, etc. A report setup typically comprises components that correspond to these
structural elements of a report.

In a report setup, child-parent relationships among the components correspond to the
containment relationships among the structural elements of the report. In particular, all
setups contain a root component that serves as the ancestor for all other components in
the setup. The root component also specifies the setup name and report generation
options, such as the document type of the generated report (for example, HTML or PDF)
and the path for the generated report. The root component typically parents a title page
component and one or more chapter components that in turn parent one or more section
components that parent one or more paragraph, figure, table, and list components.
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Setup Files

The report generator stores setups in files called setup files. The name of a setup file
consists of the name of the setup that it stores followed by the file extension . rpt. For
example, the name of the setup file for a setup named myreport would be

myreport. rpt.

Create a Report Setup

To create a report setup:

Create a new setup file on page 4-4.

Insert components on page 4-12 to define the content and format of the report.
Set component properties on page 4-13.

Save the setup on page 4-10.

Once you create a template, you can execute it to generate an instance of the type of
report that it defines.
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Create a New Setup File

4-4

In this section...

“Create Setup File Using the Report Explorer” on page 4-4
“Create Setup File Programmatically” on page 4-4
“Working with Setup Files” on page 4-5

“Report Description” on page 4-5

Note Do not setup or create new reports using the Report Explorer app. This information
is provided for maintaining existing reports only. To create a new report generator, use
the Report and DOM APIs. See “Create a Report Program” on page 13-3.

Create a new setup file either interactively from the Report Explorer or programmatically.

Create Setup File Using the Report Explorer

1 [f the Report Explorer is not already open, from the MATLAB Toolstrip, in the Apps
tab, in the Database Connectivity and Reporting section, click Report
Generator.

2 In the Report Explorer, use one of these approaches:

¢ Select File > New.

* On the Report Explorer toolbar, click the new template button.

The Outline pane displays a new setup named Unnamed, as a child of the Report
Generator node.

Create Setup File Programmatically

To create a setup file programmatically (from the MATLAB command line), use the
setedit command. For example, assuming a setup named myreport does not already
exist in the current directory, use the following command:

setedit myreport.rpt



Create a New Setup File

Working with Setup Files

For details about performing operations on report setup files, see:

* “Open a Report Setup” on page 4-6
* “Close a Report Setup” on page 4-9
* “Save a Report Setup” on page 4-10

Report Description

To record notes and comments about your report setup, use the Report Description
field. This text that you enter appears in the Properties pane when you select a report
setup file in the Outline pane.
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Open a Report Setup
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In this section...

“Opening a Setup on the MATLAB Path” on page 4-6
“Opening a Setup Not on the MATLAB Path” on page 4-7
“Opening a Setup Programmatically” on page 4-7

To make changes to a saved report setup, you must open its setup file. Open a report
setup either interactively from the Report Explorer or programmatically.

Opening a Setup on the MATLAB Path

Tip Use the setedit command to obtain a list of all the report setups on the MATLAB
path.

To open a setup that resides on the MATLAB path:

1 If the Report Explorer is not already open, from the MATLAB Toolstrip, in the Apps
tab, in the Database Connectivity and Reporting section, click Report
Generator.

2 In the Report Explorer, in the Outline pane on the left, select the Report
Generator node.
The Library pane in the middle displays a list of all the setup files that exist on the
MATLAB path.

3 Inthe Library pane, select the setup file that you want to open.

The setup properties dialog box appears in the Properties pane on the right.
4 To open the setup, in the Report Explorer use one of these approaches:

* On the Properties pane, click the Open report button.
* On the Library pane, double-click the entry for the setup.
* On the Library pane, from the context menu for the setup, select Open report.

The setup appears in the Outline pane as a child of the Report Generator node.
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Opening a Setup Not on the MATLAB Path

Tip Use the setedit command to obtain a list of all the report setups on the MATLAB
path.

To open a setup that resides off the MATLAB path:

1 [f the Report Explorer is not already open, from the MATLAB Toolstrip, in the Apps
tab, in the Database Connectivity and Reporting section, click Report
Generator..

2 Inthe Report Explorer, select File > Open or select the file open button on the
Report Explorer toolbar.
A file browser opens.

3 Use the file browser to find the report setup in your file system and enter the setup
name in the file browser File name field.

4  Select the file browser Open button.

The setup appears in the Outline pane as a child of the Report Generator node.

Opening a Setup Programmatically

To open a report programmatically, use the setedit command. For example, the
following command opens the simple-report. rpt example that comes with the
MATLAB Report Generator.

setedit simple-report

This command opens the Report Explorer, if it is not already open, and opens the
simple-rpt setup in the Report Explorer.

Tip If a setup exists on the MATLAB path, you do not need to specify its full path when
using the setedit command. Use the setedit command to obtain a list of all the report
setups on the MATLAB path.
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The newly opened report appears in the Outline pane as a child of the Report
Generator node.
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Close a Report Setup

In this section...

“Close a Setup Using the Report Explorer” on page 4-9
“Close a Setup Programmatically” on page 4-9

Closing a setup removes the setup from the Report Explorer and from memory.

Close a Setup Using the Report Explorer
1 In the Report Explorer, in the Outline pane, select the setup root node.
2 In Report Explorer, use one of these approaches:

e Click the Delete button.
* Select File > Close.

* From the context menu of the root node of the setup file, select Close.

Close a Setup Programmatically

You can close a report that you have previously opened. For example, the following code
opens a setup and then closes it.

setup('simple-report.rpt');

root = RptgenML.Root;
root.closeReport('simple-report');
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Save a Report Setup

In this section...

“Save a Setup Under Its Existing Name” on page 4-10

“Save a Setup Under a New Name” on page 4-10

Save a Setup Under Its Existing Name

1 In the Report Explorer, in the Outline pane, select the setup root node.
2 In Report Explorer, use one of these approaches:

* Click the Save button.
* Select File > Save.
* From the context menu of the root node of the setup file, select Save.

Save a Setup Under a New Name

In the Report Explorer, in the Outline pane, select the setup root node.
Select File > Save As.

A file browser opens.
3  Use the file browser to select a new path for the setup.
In the file browser, click Save.
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Load Report Setup into MATLAB Workspace

To load a setup into the MATLAB workspace without loading it into the Report Explorer,
use the rptgen.loadRpt function.

You can then modify the setup programmatically. For example, the following code loads a
setup into memory, sets its output type to PDE and generates a report.

setupRoot = rptgen.loadRpt('simple-report');

setupRoot.Format = 'pdf-fop';
setupRoot.execute;
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Insert Components

4-12

In this section...

“Point-and-Click Method” on page 4-12
“Drag-and-Drop Method” on page 4-12
“Fix Context Violations” on page 4-12

Point-and-Click Method

1 In the Report Explorer, in the Outline pane, select the parent node of the component
to be inserted. For example, if you are inserting a paragraph into a section, select the
section that will contain the paragraph.

2 In the Library pane, select the type of component that you want to insert in the
report setup.

3 In the Properties pane, select the Add component to current report button.

Drag-and-Drop Method

1 In the Report Explorer, in the Library pane, select the type of component that you
want to insert in the setup.

2 Drag the component from the Library pane into the Outline pane and drop it onto the
parent of the component to be created.

Fix Context Violations
The Report Explorer allows you to insert components into invalid contexts.

For example, a Chapter/Subsection component is a valid parent for a Paragraph
component, but not vice-versa. Nevertheless, the Report Explorer allows you to insert a
Chapter/Subsection as a child of a Paragraph. If you insert a component in an invalid
context, the Report Explorer displays a warning.

Although you can create an invalid setup hierarchy, you cannot generate a report from an
invalid hierarchy. You must fix the context violations first. For example, move components
from invalid contexts to valid contexts (see “Move Components” on page 4-14).




Set Component Properties

Set Component Properties

In this section...
“Edit Component Property Values” on page 4-13
“Computed Property Values” on page 4-13

Edit Component Property Values

Most components have properties that you can set to select optional features. For
example, the Text component lets you specify the color of the text that it generates
among other properties.

To set component properties:

1 In the Report Explorer, in the Outline pane, select the component.

The Properties dialog box for the component appears in the Properties pane.
2 Use the Properties dialog box to set component properties.

Computed Property Values

During report generation, the Report Generator can compute the values of component
properties, using MATLAB expressions that you specify. This enables dynamic creation of
report content. For example, you can use MATLAB expressions to compute the content of
Paragraph components and the value of looping components that generate repeated
content.

You can use MATLAB expressions to compute the value of any character vector property
of a component. To specify a MATLAB expression as a character vector property value, in
the Properties dialog box, in the property edit box, enter %s<expr>, where expr is a
MATLAB expression that evaluates to a character vector.
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Move Components
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In this section...

“Point-and-Click Method” on page 4-14
“Drag-and-Drop Method” on page 4-15

Point-and-Click Method

1

In the Report Explorer, in the Outline pane, select the component that you want to
move.

Reposition the component in the setup hierarchy, using one of these approaches:

* On the Report Explorer toolbar, use the move buttons.
* From the Edit menu, use the move commands.

* From the context menu of the component, use the move commands.

Note The move buttons and commands are enabled only if they are valid in the
context of the component to be moved. For example, if a component cannot move
further to the right in the hierarchy, the Move Right button is disabled.

The following table summarizes the available move buttons and commands.

Move Command or |Effect

Button

Move Up Moves a component ahead of the sibling that formerly
preceded it in the hierarchy. If the component is the first
child of its parent, the component becomes a sibling of
its former parent.

Move Down Moves a component after the sibling that formerly
followed it in the hierarchy. If a component is the last
sibling of its parent, it moves up one level in the
hierarchy to become a sibling of its former parent.

Move Left Moves a component up one level in the hierarchy. The
component becomes a sibling of its former parent.




Move Components

Move Command or |Effect
Button
Move Right Moves a component down one level in the hierarchy. The
component becomes the child of the sibling that
formerly preceded it in the hierarchy.

Drag-and-Drop Method

1 In the Report Explorer, in the Outline pane, select the component that you want to
move.

2 Drag the component and drop it on the component that you want to be its parent.
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Delete Components

1 In the Report Explorer, in the Outline pane, select the component that you want to

delete.
2 Delete the component, using one of these approaches:

* On the Report Explorer toolbar, click the Delete button.
* Select Edit > Delete.

From the context menu of the component, select Delete.
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Deactivate Components

You can deactivate any component in a report setup. Deactivating a component causes it
to be skipped during generation of a report.

Deactivating components can be useful for debugging setups. For example, you can
deactivate a component that you suspect is causing an error or you can activate only the
components you want to debug, thereby cutting the time required to verify a fix.

To deactivate (or reactivate) a component:

1 In the Report Explorer, in the Outline pane, select the component that you want to
deactivate (or reactivate).

2 Select the appropriate Activate/Deactivate Component option from either the Edit
menu or from the context menu of the component.
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Send Components to the MATLAB Workspace

4-18

You can send the components of a setup from the Report Explorer to the MATLAB

workspace. This allows you to inspect and set their properties at the MATLAB command
line.

Sending components to the workspace can be useful for creating or debugging MATLAB
programs that create report setups and generate reports from them.

To send a component to the MATLAB workspace:

1 In the Report Explorer, in the Outline pane, select the component that you want to
send to the workspace.

2 From the context menu of the component, select Send to Workspace.
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* “Generate a Report” on page 5-2

» “Select Report Generation Options” on page 5-4

* “Report Generation Preferences” on page 5-12

* “Change Report Locale” on page 5-16

* “Convert XML Documents to Different File Formats” on page 5-17
* “Create a Report Log File” on page 5-20

* “Generate MATLAB Code from Report Setup File” on page 5-21

* “Troubleshooting Report Generation Issues” on page 5-24
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Generate a Report

5-2

In this section...

“Run a Report” on page 5-2
“Report Output Options” on page 5-2

Run a Report

You can generate a MATLAB Report Generator report using one of these methods:

* In the Report Explorer Outline pane, select a report and do one of these actions:

L 7

In the Report Explorer toolbar, click the Report button 7 .
¢ Press CTRL+R.
* Select File > Report.
* From the MATLAB command line, enter the report command. For example, to print
the systeml description report in PDF format, enter:

report systeml description -fpdf

Report Output Options

Before you generate a report, you can set options to control aspects of report generation
processing such as:
* Output file format (HTML, Microsoft Word, or PDF)

» Style sheet or templates for the selected output file format, to control the layout of the
report

* Output file location
*  Whether to view the report after it is generated

For details, see:

* “Report Output Format” on page 5-6
* “Location of Report Output File” on page 5-4




Generate a Report

“Create a Report Log File” on page 5-20
“Report Description” on page 4-5
“Change Report Locale” on page 5-16
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Select Report Generation Options

In this section...

“Report Options Dialog Box” on page 5-4

“Location of Report Output File” on page 5-4

“Report Output Format” on page 5-6

“PDF Style Sheets” on page 5-8

“Web Style Sheets” on page 5-9

“RTF (DSSSL Print) and Word Style Sheets” on page 5-10

“Report Generation Processing” on page 5-10

Report Options Dialog Box

To specify report generation options for a report, in the Report Explorer, use the Report
Options dialog box. The Report Options dialog box appears when you select the report
from the outline view.

To set the defaults for these options, use the Report Generator preferences. For details,
see “Report Generation Preferences” on page 5-12.

If you are creating a form-based report, instead use the Report Form Options dialog box.
See “Report Form” on page 16-17.

Location of Report Output File

Choose a folder to store the report file. You must have write privileges for that folder.
Folder

In the Report Explorer, in the Report Options dialog box, use the Directory field to
specify the name of the folder in which to store the generated report file. Specify a folder

to which you have write privileges.

The following table summarizes the report file location options.
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Folder Option

The same folder as the report |[Same as setup file

setup file

The current working folder Present working directory

Temporary folder Temporary directory

Another folder Custom.
Use the Browse button (...) to select from a list of
directories.

You can use %<VariableName> notation to specify a folder in the Custom text box.
Report File Name

In the Report Explorer, in the Report Options dialog box, use the Filename field to
specify a file name for the report file. Select one of the following options.

File Name Option
The same file name as the report Same as setup file (default)
setup file

A file name different from the report |[Custom.

setup file name
Enter the name of the report.

You can use %<VariableName> notation to specify a file name in the Custom text box.
Increment to Prevent Overwriting

To maintain the previous version of the setup file when you save updates to the setup file,
select If report already exists, increment to prevent overwriting.

Image Output File Location

Images are placed in a folder with the same name as the report file. For example,
testreport.html images are placed in a folder named testreport files.

3-5



5 Generatea Report

Report Output Format

Under Report Output Type and Style Sheets, from the File format list, select the
report output format. You can generate reports whose formatting is based on templates or
based on Report Explorer style sheets.

File Formats Using Report Templates

For faster report generation, set File format to use a template. Select one of these
options:

Direct PDF (from template)

HTML (from template) — Select this option if you want your report’s table of
contents to expand and collapse.

PDF (from Word template)

Single-file HTML (from template) — Select this option if you want your
report’s table of contents to expand and collapse and want the HTML report as a
single file.

Word (from template)

If you select a from template output format, then you can use a default template or a
customized template. For more information about using templates for report generation,
see “Generate a Report Using a Template” on page 7-13. For information on customizing
templates, see “Customize Report Conversion Templates”.

File Format Using Report Explorer Style Sheets

The output formats that do not include from template in the name use Report Explorer
style sheets for formatting. For those output formats, select a style sheet from the Style
Sheet list.
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Viewer Format Description Style Sheets

Adobe® Acrobat® |Adobe Acrobat Produce a PDF that |PDF (see “PDF Style

Reader (PDF) you can view using |Sheets” on page 5-8)
Adobe Acrobat

Reader software.

See “PDF: Image
Formats” on page 5-
7.

Word processor [(Word Document |Produce output that |Print (see “RTF (DSSSL
(RTF) orRich is compatible with Print) and Word Style
Text Format most word- Sheets” on page 5-10)
processing packages,
including Microsoft
Word software

See “RTF: Display of
Hidden Content” on

page 5-7.
DocBook DocBook (no Produce a reportin |N/A
transform) DocBook format

Tip To create and use customized styles, see “Create a New Style Sheet” on page 9-4.

PDF: Image Formats

PDF reports support only bitmap (. bmp), JPEG (. jpg), and Scalable Vector Graphics
(.svq).

The SVG format is supported only for Simulink models and Stateflow® charts. For
example, MATLAB figures do not display in SVG when you select the SVG format for PDF
reports.

RTF: Display of Hidden Content

RTF reports use placeholders (field codes) for dynamically generated content, such as
page numbers or images.

On Windows® platforms, to display that content, press Ctrl+A, and then press F9.
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On Linux® and Mac platforms, use the field code update interface for the program that
you are using to view the RTF document.

Change the Default Output Format

In the Report Generator Preferences pane, use the Format ID preference to specify
the default output format for reports.

Style Sheets

For each output format, you can choose from several style sheets for each report output
format. For details, see:

* “PDF Style Sheets” on page 5-8
* “Web Style Sheets” on page 5-9
* “RTF (DSSSL Print) and Word Style Sheets” on page 5-10

Note Some Web and Print style sheets include a generated list of titles, which includes
table titles and figures with titles.

PDF Style Sheets

PDF Style Sheet Description

Default print style Displays title page, table of contents, list of titles

sheet

Standard Print Displays title page, table of contents, list of titles

Simple Print Suppresses title page, table of contents, list of titles

Compact Simple Print Minimizes page count, suppresses title, table of contents,
list of titles

Large Type Print Uses 12-point font (slightly larger than Standard Print)

Very Large Type Print Uses 24-point font and landscape paper orientation

Compact Print Minimizes white space to reduce page count

Unnumbered Chapters & Uses unnumbered chapters and sections

Sections
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PDF Style Sheet

Description

Numbered Chapters &
Sections

Numbers chapters and sections

Paginated Sections

Prints sections with page breaks

Custom Header

Lets you specify custom headers and footers

Custom Titlepage

Lets you specify custom title page content and
presentation

Verbose Print

Lets you specify advanced print options

Web Style Sheets

Web Style Sheet

Description

Default HTML style sheet

HTML on a single page

Simulink book HTML style
sheet

HTML on multiple pages; suppresses chapter headings
and table of contents

Truth Table HTML style
sheet

HTML on multiple pages; suppresses chapter headings
and table of contents

Multi-page Web

HTML, with each chapter on a separate page

Single-page Web

HTML on a single page

Single-page Unnumbered
Chapters & Sections

HTML on a single page; chapters and sections are not
numbered

Single-page Numbered
Chapters & Sections

HTML on a single page; chapters and sections are
numbered

Single-page Simple

HTML on a single page; suppresses title page and table
of contents

Multi-page Simple

HTML on multiple pages; suppresses title page and
table of contents

Multi-page Unnumbered
Chapters & Sections

HTML on multiple pages; chapters and sections are not
numbered

Multi-page Numbered
Chapters & Sections

HTML on multiple pages; chapters and sections are
numbered

5-9




5 Generatea Report

5-10

RTF (DSSSL Print) and Word Style Sheets

RTF or Word Style sheet

Description

Standard Print

Displays title page, table of contents, list of titles

Simple Print

Suppresses title page, table of contents, list of titles

Compact Simple Print

Minimizes page count, suppresses title, table of contents,
list of titles

Large Type Print

Uses 12-point font (slightly larger than Standard Print)

Very Large Type Print

Uses 24-point font and landscape paper orientation

Compact Print

Minimizes white space to reduce page count

Unnumbered Chapters &
Sections

Uses unnumbered chapters and sections

Numbered Chapters &
Sections

Numbers chapters and sections

Report Generation Processing

The Report Options dialog box includes options for controlling report processing.

Option

Purpose

View report after generation

When report generation finishes, the viewer associated
with the report output format displays the report.

Note On Linux and Macintosh platforms, the report
output displays in Apache OpenOffice™, which must be
installed in /Applications/OpenOffice.app.

To view the report manually, open the file from the
location specified in the Report Options for the report,
under Report File Location.

Auto save before generation

Automatically save the report setup file before you
generate a report.




Select Report Generation Options

Option

Purpose

Compile model to report on
compiled information

Ensure that a report reflects compiled values.

By default, the Simulink Report Generator reports
uncompiled values of Simulink parameters. The
uncompiled values of some parameters, such as signal
data types, can differ from the compiled values used
during simulation.

This option causes the report generator to compile a
model before reporting on model parameters. After
generating the report, the report generator returns the
model to its uncompiled state.

Note When you select this option, whenever report
generation requires simulating the model (for example,
the report includes a Model Simulation component), the
report generator uncompiles the model and then
recompiles the model, if necessary, to report on model
contents. If a report requires multiple compilations, the
processing can be quite time-consuming.

To minimize compilations, consider using separate
reports to report on the contents of a model and on the
results of simulating that model.

Evaluate this string after
generation

Specify MATLAB code for processing to occur after the
report is generated. For example, you could specify to
close a model.
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Report Generation Preferences
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In this section...

“Report Generator Preferences Pane” on page 5-12
“File Format and Extension” on page 5-13

“Image Formats” on page 5-14

“Report Viewing” on page 5-14

“Reset to Defaults” on page 5-15

“Edit HTML Command” on page 5-15

Report Generator Preferences Pane

To set defaults for report generation options, use the Report Generator Preferences pane.
You can override these preferences with the Report Options dialog box or with individual
components.

To specify report generation options for a specific report, in the Report Explorer, use the
Report Options dialog box. For details, see “Select Report Generation Options” on page 5-
4,

To open the Report Generator Preferences pane, use one of these approaches:

» In the Report Explorer, select File > Preferences.

* From the MATLAB Toolstrip, in the Home tab, in the Environment section, select
Preferences > Report Generator.




Report Generation Preferences

MATLAB

Simulink

Computer Visien System Toolbox
Image Acquisition Toolbox
Image Processing Toolbox
MATLAE Report Generator
Parallel Computing Toolbox
Simscape

Simulink 30 Animation

Sirmulink Control Design

MATLAE Report Generator Preferences

Output Format Options
Foermat ID web (HTML)
Extension htrml
Simulink images | pNG 24-bit image
Stateflow images | pNG 24-bit image
HG images PNG 24-bit image
Visible in Repert Explorer
Command te Vie""’web(rptgen.ﬁlelum('%<FiIeName:- 1

Reset to Defaults

Preferences
Animate Report Explorer when generating reports
Command te edit HTML edit('%<FileNames");

File Format and Extension

Help

To specify the default file format for reports, use the Format ID preference. The default
preference isweb (HTML). You can select from a range of file formats, such as PDF or

Microsoft Word.

If you have Adobe Acrobat and acrobat.exe is on your system path, you can set it as the
default PDF format. Select a PDF format as the Format ID. Then, replace the command
in Command to view with system('acrobat %<FileName>"');

The Extension preference reflects the standard file extension for the file format specified
with the Format ID preference. You can change the extension.
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Image Formats

To set the default image formats associated with the output format for a report, use the
following preferences.

Preference Purpose

Simulink Images Specify the format for Simulink images to include in the
report.

Stateflow Images Specify the format for Stateflow charts to include in the
report.

HG Images Specify the format for Handle Graphics® images to
include in the report.

Note The default preferences for image formats should work in most viewing
environments. However, some image formats do not display in some viewing
environments.

Several components, such as the Figure Snapshot component, include an option for
specifying the image format. The component setting overrides the image format
preference.

Report Viewing

To control how you view a generated report, you can set the following preferences.

Preference Purpose
View command Specify the MATLAB command you want to use to view
the report.

Each file format has an associated default view command
preference. You can modify the view command (for
example, to support the use of a system browser).
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Preference Purpose
Animate Report Explorer Select this check box if you want components in the
when generating reports Outline pane to be animated as the report generates.

This box is selected by default.

To speed up the report generation processing, clear this
preference.

Reset to Defaults

To reset the Report Generator preferences under Output Format Options, click Reset
to Defaults. Resetting to defaults does not affect the options under Preferences.

Edit HTML Command

Enter the command to use to open HTML or PDF template files from the Report
Explorer's Document Conversion Template Editor (see “Report Templates” on page 7-
2). The default command opens the files in the MATLAB text editor.

To set this preference to an operating system command, use the MATLAB system
command. Use the file name token %<FileName> to specify where in the command the
template editor inserts the path to the file to edit. Make sure that the command is on your
system path.

This example shows a command that opens Report Generator HTML-based template files
in the notepad++ application. The ampersand character (&) executes the command in the
background.

system('notepad++ %<FileName> &');
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Change Report Locale

5-16

Versions 2.0 and later of the MATLAB Report Generator and Simulink Report Generator
software use the locale (system language settings) through the Oracle® Java interface;
therefore, they should use the language specified on your system.

Alternatively, you can change the language directly in Java from the MATLAB command
line. The following example sets the language to Italian:

java.util.Locale.setDefault(java.util.Locale.ITALY)
Alternatively, you can set the preferred language directly in your . rpt file:

1 Right-click the Report component and select Send to Workspace.

This displays the properties of the report, which are stored in the variable ans.
Access the report's Language property from the command line through this variable.
By default, Language is auto, which indicates that the system's default language is
in use.

2 Override the default value of Language by setting this property to your desired
language; for example, en for English or it for Italian.
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Convert XML Documents to Different File Formats

In this section...

“Why Convert XML Documents?” on page 5-17

“Convert XML Documents Using the Report Explorer” on page 5-17
“Convert XML Documents Using the Command Line” on page 5-19
“Edit XML Source Files” on page 5-19

Why Convert XML Documents?

You can generate a report in a different output file format without regenerating it by
using either the Report Explorer File Converter or the rptconvert command. These
utilities convert DocBook XML source files created by the report-generation process into
formatted documents such as HTML, RTF, or PDF.

Note The report-generation process can only convert XML source files created by the
latest version of the software.

Convert XML Documents Using the Report Explorer
To open the Convert Properties pane:
1 In the Report Explorer, select Tools > Convert Source File.

The Convert Source File Properties pane appears. All XML files in your current folder
appear in the Options pane in the middle.
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HRepurt Explorer - Convert - my_test

=0l x|

File Edit “iew Toolz Help
LSS & XS [ 7Rt
I Mame / Convert Source File

El% Fieport Gererator ? ry_tesst. sl The Source File Converter transforms DocBook ®ML zource files created by the Repart
T B e . Generator into a formatted document, such as HTML, RTF, ar PDF.
H_Ch Carvvert - my_test ? simulitik_tutorial sml . .
— Corversion Option
ﬁ Repart - Unnamed.rpt

4] |

o |

i

Source file; IH:'\m_l,l_test.:-tmI Browse. .. |

File farmat: |web (HTML] =

St_l,llesheet:lDefauIt HTML stylezhest j Edit... |

v Wiew report when done converting

Corweert file |

— File Preview

Hewvert Help

5-18

2 Select your XML source file using one of the following options:

Click Browse in the Properties pane on the right to browse to the location of your

XML source.

Double-click a file name in the Options pane in the middle to automatically enter it
into the Source file field in the Properties pane.

3  Select your output format and style sheet:

In the File format text box, select an output format.

In the Style sheet text box, select a style sheet. The style sheet choice depends
on the specified output format. You can use a predefined or customized style

sheet.

For more information about available formats and predefined style sheets, see
“Report Output Format” on page 5-6.




Convert XML Documents to Different File Formats

For more information about customizing style sheets, see “Create a New Style
Sheet” on page 9-4.

4 Use the View Report when done converting check box to indicate whether you
want to view the report after it has conversion.

5 To begin the conversion, click Convert file.

Convert XML Documents Using the Command Line

To convert files using the command line, use the rptconvertfunction.

Edit XML Source Files

Before you send a source file to the converter, edit it as text in the Report Explorer:

In the Outline pane on the left, open the File Converter.

Right-click MATLAB Report Generator and select Convert source file.
In the Options pane in the middle, select the source file to edit.

In the Properties pane on the right, click Edit as text.

Use the MATLAB Editor to edit and save the text.

g A W N =
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Create a Report Log File

5-20

A log file describes the report setup file report-generation settings and components. A log
file can be used for many purposes, including:

* As a debugger

* As areference to a report setup file

* To share information about a report setup file through email

A log file includes the following information:

* Report setup file outline

* Components and their attributes

* Generation status messages currently displayed in the Generation Status tab
To generate a log file, click File > Log File. An HTML version of the log file with the

name <report_ template file name log>.html is saved in the same folder as the
report setup file.



Generate MATLAB Code from Report Setup File

Generate MATLAB Code from Report Setup File

You can generate MATLAB code versions of report setup files in the form of a MATLAB file
(*.m). A MATLAB file of a report setup file is useful for various purposes, including
generating reports and modifying report setup files programmatically.

To update a MATLAB file, load a report setup file into the Report Explorer and click File
> Generate MATLAB File. After the MATLAB file generates, it opens in the MATLAB
Editor. The filename for the generated file is the file name of the report setup file ,
preceded by “build.”

Example 5.1. Generate Reports from MATLAB Files

This example generates a MATLAB file from the figloop tutorial. rpt report setup
file, which is part of the MATLAB Report Generator software. The example then uses the
report function to generate a report from the MATLAB file. For more information about
this function, see the report reference page.

Start the Report Explorer by entering report in the MATLAB Command Window.

In the Options pane in the middle, double-click figloop tutorial.rpt to open its
report setup file.

3 In the Outline pane on the left, click Report - figloop tutorial.rpt to select
it.

4 In the Report Explorer menu bar, click File > Generate MATLAB File.
The MATLAB Report Generator software generates MATLAB code for the
figloop tutorial. rpt report setup file. It saves this code in the

buildfigloop tutorial.m file in the folder you specify. Part of this file appears in
the following figure.
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buildfigloop_tutorial.m

File Edit Text Go Cell Tools Debug Desktop ‘Window Help k] | A X
Hjﬂ|d‘$—h:§]“]("|é|“**ﬁ-‘, m'aﬁ@%@ﬁlStack:lBasevl EE||I|E|51|E
c B - [ B -+ =i x| %% |0
1 lfunction [EptgenML CReportl] = buildfigloop tutorial ,D
& 5BUILDFIGLOOP_TUTORIAL I
3
4 ¥ Auto-generated by MATLAE on 0Z-Jan-2008 11:15:08
5
5] % Create RptgenML.CReport
7= ErtgenML CReportl = RptgenML.CReport('Description',...
=] ['L report which demonstrates advanced component types:',sprintf('n'),'',sprintfi{'‘n'}),
9 'Stylesheet' [ 'html-!'8ingleClearTitleTocLot!' ;...
10 'Format', 'htmwl' ;...
11 'DirectoryType'  'pud' ) :
1z % setedit (RptgenML CReportl):
13
14 % Create rptgen.cfr titlepage
L5 = rptogen ofr titlepagel = rptgen.ofr titlepage ('Copyright Date' [ '19098' ... o
16 "Author','The MathlWorks',...
17 'Subtitle' 'L Tutorial',...
1a 'Title','The Figure Loop'):
18 — rptogen ofr textl = rptgen.cfr text('Content', ...
20 'The Figure Loop produces s report which documents multiple figure windows. Each time t
2l — set (rptgen_cfr_titlepagel,'ibstractComp' ,rptgen cfr_textl):
ZZ — rptgen ofr texti = rptgen.cfr Cext:
23 - zetjrptgen ofr titlepagel, 'lLegallNoticeConwp' ,rptagen ofr textl):
24 — rptgen cfr imagel = rptgen.cfr image (' Filellamwe',''):
5 = getirptgen cfr titlepagel, ' ImageComp' ,rptgen cfr imagel) :
26 — setParent (rptgen cfr titlepagel, RptgenML CReportl):

5 To generate the figloop tutorial report from this MATLAB file, run the following
command in the MATLAB Command Window:

report(buildfigloop tutorial);

The MATLAB Report Generator software runs and displays the report.
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he Figure Loop =]

File Edit Yiew Go Debug Deskiop ‘Window Help

- O | =] | % | Lucatiun:|ﬁle:mH:,ftpesss13ar_5db0_4?c6_a198_949Fca0926?9.htm|

|>|—u

The Figure Loop
A Tutorial

The MathWorks b
02-Jan-2008 11:23:41
Abstract

The Figure Loop produces a report which docurments multiple figure windows. Each time the Figure Loop
component runs, it reports on a different figure.

Chapter 1. Code for Creating Figures

function hList=figloopfigures

FFICGLOOPFIGURES creates figures for figloop-tutorial.rpt
FIGLOZCPFICURES crestes five figures which sre used by
the Report Generator setup file "figloop-tutorial.rpt'™.
To run this tutorisl, type "setedit figloop-tutorial™
at the comwand prompt.

P

a

Figure 1: Membrane Data

Figure 2Z: Invisible Mewbrane Data

Figure 3: An Application
4
5

P

a

Figure An Invisible Application
Figure Peaks Data

P

a

Figures 2 and 4 are invisikble.
Figures 3 and 4 have HandleVisibility='off!
Figure & is the current figure

P

a

FIGLOZPFICURES deletes any existing ficgures which heswe
tay 'peaks' 'app' or 'membrane'

a

a

Copyright 1297-2004 The MathWorks, Inc.
§Revision: 1.1.6.2 § §Dace: 2004/04/15 00:12:57 §

a
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Troubleshooting Report Generation Issues

In this section...

“Memory Usage” on page 5-24
“HTML Report Display on UNIX Systems” on page 5-25

Memory Usage

The Report Generator software has two converters for generating documents. One uses
Java heap memory and the other does not.

To avoid Java heap memory issues, you can generate your report using the converter that
does not use Java heap memory. To do so, under the Report Options for the report, set
File format to one of the (from template) options, for example, HTML (from
template).

If you select one of the other options, you are using the converter that uses Java heap
memory and you might have memory issues. By default, MATLAB sets a limit of 384 MB
on the amount of memory the Oracle Java Virtual Machine (JVM™) software can allocate.
The memory that the report generation process uses to build a document must fit within
this limit. If you are having trouble processing large reports, you can try increasing the
amount of memory that the software can allocate by:

* Running MATLAB without a desktop
» Increasing the memory allocation limit

Run MATLAB Without a Desktop

To run the MATLAB software without a desktop, start MATLAB using the -nodesktop
option. In this case, you must generate the report from the command line using the
report command.

Increase the MATLAB JVM Memory Allocation Limit

To increase the amount of JVM memory available by increasing the MATLAB JVM memory
allocation limit, from the MATLAB Toolstrip, in the Home tab, in the Environment
section, click Preferences. Use the General > Java Heap Memory pane to increase the
memory.
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HTML Report Display on UNIX Systems

HTML reports might not display in the Report Generator Web viewer on some UNIX®
platforms. If this happens, configure the Report Generator software to launch an external

browser.

In the Report Explorer, click File > Preferences.

Enter this command in the View command field, where file name is the name of your
report setup file:

web(rptgen.file2urn('%file name'), '-browser')
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* “Components” on page 6-2

* “Report Structure Components” on page 6-4

» “Table Formatting Components” on page 6-5

* “Property Table Components” on page 6-6

* “Summary Table Components” on page 6-17

* “Logical and Looping Components” on page 6-21
+ “Edit Figure Loop Components” on page 6-22
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Components

6-2

Components are MATLAB objects that specify the content of a report. Add components to
specify the types of content that commonly occur in reports. The MATLAB Report
Generator provides a set of components for specifying the types of content that commonly
occur in MATLAB-based reports. The Simulink Report Generator provides additional
components to facilitate generation of reports from Simulink models. You can also create
custom components to handle content specific to your application.

Using the Report Explorer, you interactively combined components to create a report
setup that specifies the content of a particular report or type of report. For general
information about working with components, see:

* “Insert Components” on page 4-12

* “Set Component Properties” on page 4-13

You used a combination of the following types of components in your report setup file,
based on your goals for the report.

Type of Component Description
“Report Structure Components” on page 6- |Include a title page, chapters, sections,
4 paragraphs, lists, tables, and other

standard document structure elements.

“Table Formatting Components” on page 6- |Organize generated content into tables.
5

“Property Table Components” on page 6- Display tables with property name/property

6 value pairs for objects.

“Summary Table Components” on page 6- |Display tables with specified properties for
17 objects.

“Logical and Looping Components” on page |Run child components a specified number
6-21 of times. There are several looping

components, including logical loops and

Handle Graphics loops.




Components

Component Formatting

When you generate a report, in the Report Options dialog box, in the File format field you
specify the type of report output you want. For example, you can generate a report in
PDE HTML, or Microsoft Word format.

For each format, you can choose to apply styles from either of these style definition
sources:

* An HTML or Word report conversion template
* A Model Explorer style sheet for HTML, Word, or PDE.

The output format and the associated template or style sheet that you select for a report
determines most aspects of the formatting of the generated report. For example, a report
template or style sheet typically uses different font sizes for chapter titles and section
titles. For details, see “Report Output Format” on page 5-6.

Several components include properties that you can set to specify formatting details for
that specific instance of a component. For example, for the MATLAB Property Table,
you can specify formatting such as whether to display table borders or the alignment of
text in table cells.
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Report Structure Components

Use report structure components to organize the content of your report into chapters,
sections, paragraphs, lists, tables, and other standard document structure elements. The
table summarizes the report structure components.

Component Usage

Title Page Generate a title page for a report.

Chapter/ Parent components that generate the content of a chapter or
Subsection chapter subsection.

Paragraph Specify the content and text format of a paragraph of text. Can

serve as the parent of one or more text components, enabling use
of multiple text formats (for example, bold, regular, or italic) in the
same paragraph.

Text Format generated text.

List Generate a list from a cell array of numbers or text or parent
components (for example, Paragraph components) that specify the
items in a list. You can create multilevel lists by embedding list
components within list components.

Link Generate a hyperlink from one location in a report to another or to
an external location on the user’s file system or the Worldwide
Web.

Image Insert an image into a report.

Array-Based Generate a table from a cell array of numbers or text.

Table

Table Parent a table body component. See “Table Formatting

Components” on page 6-5.
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Table Formatting Components

Use table formatting components to organize generated content into tables. The following
table summarizes the table formatting components.

Component Usage

Table Parent a table body component. Can also parent column
specification components and a table header and a table
footer component. Specifies properties of the table as a whole
(for example, its title, number of columns, and border).

Table Body Parent the rows that make up the table body. Specifies the

default vertical alignment of entries in a table body.

Table Column
Specification

Specify attributes of a table column, such as its width and
borders and the default horizontal alignment of column
entries.

Table Entry

Parent a component that determines a table entry’s content,
such as a paragraph, image, list, or another table component.
Specifies attributes of a table entry, such as the number of
rows and columns that it spans.

Table Footer

Parent the row components that generate the content of a
table footer.

Table Header

Parent the row components that generate the content of a
table header.

Table Row

Parent the table entry components that generate the content
of a table row.

Tip Inserting a Table component into a setup also inserts all the descendant components
required to generate a 2x2 table, creating a table template. Edit this template to create a

table that suits your needs.
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Property Table Components
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In this section...

“About Property Table Components” on page 6-6

“Open the Example Report Template” on page 6-8

“Examine the Property Table Output” on page 6-8

“Select Object Types” on page 6-9

“Display Property Name/Property Value Pairs” on page 6-9
“Edit Table Titles” on page 6-12

“Enter Text into Table Cells” on page 6-12

“Add, Replace, and Delete Properties in Tables” on page 6-13
“Format Table Columns, Rows, and Cells” on page 6-14
“Zoom and Scroll” on page 6-16

“Select a Table” on page 6-16

About Property Table Components

Property Table components display property name/property value pairs for objects in
tables. The following example shows a property table from the figloop-tutorial
report.




Property Table Components

* Web Browser - The Figure Loop

File Edit View Go Debug Desktop

Window Help

= [l 3

'!|?|X

Chapter 2. Figures in Report

Membrane Data

Name

Membrane Data

HandleVisibility

on

Tag
1]

membrane

Dione

Many types of property table components are available, including:

* MATLAB Property Table

* Simulink Property Table (requires Simulink Report Generator)
* Stateflow Property Table (requires Simulink Report Generator)

_>l_I
o

The component used in this example represents MATLAB Report Generator property

table components, all of which exhibit similar behavior.



6 Add Content with Components

Open the Example Report Template

This example uses the figloop-tutorial report template. To open the figure loop
tutorial report template, at the MATLAB command line enter:

setedit figloop-tutorial

Examine the Property Table Output

Property pages for all property table components are similar in form. In the Outline pane,
select the Figure Prop Table component. To modify table settings, in the Handle
Graphics Property Table dialog box, click the Edit... button.

Handle Graphics Property Table
—Select Graphics Object

IFigure :I

™ Filter by dlass: I

—Table

Preset table: I-- Select Table - LI Apply | ¥ split property/value cells

Edit... | ¥ Display outer border

—Table Cells —Cell Properties

<no title> Contents: I%q:Name:b

Ye<Mame >

%e<HandleVisibility > Show as: [PROPERTY Value x|

Ye<Tag=

%o Visible = Alignment: ICenter :I

W Lower border

v Right border

Revert Help
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Select Object Types

Property table components offer multiple object types on which to report. For example,
the Handle Graphics Property Table lets you report on a figure, an axes object, or a
Handle Graphics object.

You can select a different object type on which to report in the Object type list in the
Properties pane for the component.

Display Property Name/Property Value Pairs

Split Property/Value Cells

1 In the Properties pane for the Handle Graphics Property Table component, clear the
Split property/value cells check box.

2 Click Edit. The table is now in nonsplit mode. Nonsplit mode supports more than one
property name/property value pair per cell and text.

) Figure Prop Table - <no title> o [=] 3

ISeIed a preset table 'I annhy

W Spit property/value celis

;I Il.hain Properties j

-

FileName

nValue

I Hame

HName
I Tag

HandlgVigibility | hv\Value
Tag | tValue
Visible | vialue
=l
o
+I ~ I 1| I » << Add |
u x =+ | : . o | — = = | —= I vI
4. | il :IE aocl Els | & | i | = = = | __=| PROPERTY Value

3  For the property name and property value to appear in adjacent horizontal cells in
the table, select the Split property/value cells check box. The table is now in split
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6-10

mode. Split mode supports only one property name/property value pair per cell. If
more than one property pair appears in a cell, only the first pair appears in the
report; all subsequent pairs are ignored.

) Figure Prop Table - <no title> =1of x|
|Seled a preset table 'I Lpply | W Spiit propertyfvalue cells

;I Il.hain Properties j

-

FileName

H Hame
I Hame | n'alue I Tag

HandleVizibility | hvValue

Tag | fValue

Visible | vialue

‘ =l
-
| -14 | L’_‘ << Add |

a‘xl [H; | & | B3 | =l = (= | = ||Pr0|:|erty\.|'ﬂlue 'I

T+

E

Display Options

Property name/property value pairs can appear in cells in several ways. To specify how a
given property name/property value pair appears in a cell, select that field in the table
(for this tutorial, select the Name property). Choose Value from the display options drop-
down list at the bottom of the dialog box. In the selected table row, only the value
appears.



Property Table Components

) Figure Prop Table - <no title> =10l ]|
ISeIec:t a preset table i | Lpply | W Spiit propertyivalue celis

;I IMain Properties j

FY

Filetame
Name
. Tag
I n\alue I
HandleVisibility | hwWalue J
Tag |tValue
Visible |vWalue

w
|- 14 | L[_‘ << Add |

| B|@m|E| =

T

E

Format Options

To specify alignment for text in a given cell, in the toolbar at the bottom of the dialog box
use the four justification buttons.

Select the HandleVisibility table row. Then select the double-justify button (the last
button to the right).
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Edit Table Titles

Table titles can contain properties and text. By default, the title of a table is the same as
the value of the %<Name> property. You can modify this property to modify the table title.

Note Table titles are always in nonsplit mode.

Enter Text into Table Cells

For the text to be visible, the table must be in nonsplit mode. Clear Split property/value
cells.

To enter text into the HandleVisibility table cell, double-click the cell. A gray box
appears with the label for the cell property.
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If you type text outside the angle brackets, the text appears as is in the report. Text inside
the angle brackets must specify a valid property name. If you enter an invalid property
name, the property name appears in the report without a property value.

Add, Replace, and Delete Properties in Tables
Adding Table Properties

To add a Handle Graphics property to a table, use the following steps.

1 In the Figure Property Table window, select a table row above which you want add a
new property.
Click the Add Row Above Current Cell button

A new row appears above the current row.
3 Add the property to the new table row.

a Select the new table row.
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b In the Properties Type drop-down list at the upper-right of the dialog box, select
a property type.
In the Properties list, select the property you want to add.

d  Click the << Add button, or double-click the property name. The property
appears in the table row.

Alternatively, if you know the name of the property you want to add, enter the
property name directly into the cell as described in “Enter Text into Table Cells” on
page 6-12. For information about adding new table rows, see “Add and Delete
Columns and Rows” on page 6-14.

Replace Table Properties

To replace a property in a cell of a table in split mode, follow the instructions in “Adding
Table Properties” on page 6-13.

Note You cannot use these steps to delete a property in a cell when the table is in
nonsplit mode.

Delete Table Properties

Delete a property by backspacing over it or using the Delete key.

Format Table Columns, Rows, and Cells

Add and Delete Columns and Rows

To add or delete a column or row, select a cell and then click one of the buttons described
in the following table.

Note You cannot delete a row or column when it is the only row or column in the table.

Button Action
" Add column (added to the left of the selected column)
T




Property Table Components

Button Action
- Delete selected column
fn
o Add row (added above the selected row)
E

Delete selected row

g

Resize Columns
To resize the width of a column, click and drag its vertical borders as needed.
Merge and Split Cells

To merge or split table cells, select a row and then click one of the buttons described in
the following table.

Button Action
Merge cells downward

Merge cells to the right

Split cells

|EE ||3; =

Display or Hide Cell Borders

To toggle cell borders on and off:

1  Place your cursor in a cell and right-click to invoke its context menu.

2 Choose Cell borders > Top, Bottom, Right, or Left to toggle the specified border
on or off.
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Zoom and Scroll

You can zoom in and out of the table with the zoom buttons, which are located to the left
of the horizontal scroll bar.

Button Action
H Zoom in
3 Zoom out

You can scroll vertically and horizontally using the table scroll bars.

Select a Table

To display property name/property value pairs, you can select a preset table or use a
custom table.

* A preset table is built-in and formatted. You can select a preset table in the preset
table selection list in the upper-left of the Figure Prop Table window. To apply a preset
table, select the table and click Apply.

» To create a custom table, select a preset table and modify it to fit your needs by adding
and/or deleting rows and properties. You may want to start with the Blank 4x4 preset
table.

Note You cannot save a custom table as a preset table. If you do so, you lose all
changes to the custom table.
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Summary Table Components

In this section...

“About Summary Table Components” on page 6-17
“Open the Example Report Template” on page 6-18
“Select Object Types” on page 6-19

“Add and Remove Properties” on page 6-19

“Set Relative Column Widths” on page 6-20

“Set Object Row Options” on page 6-20

About Summary Table Components

Summary table components insert tables that include specified properties for objects into
generated reports. Summary tables contain one object per row, with each object property
appearing in a column, as shown in the following summary table in the figloop-
tutorial report.
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RI=ThS
File Edit Miew Go Debug Desktop Window Help
Table 1.1. Figure Properties -
Name Tag Yisible HandleVisibility
Mernbrane membranejon iyl
Diata
Invisible  |membrane|off on
Mermbrang
Diata
A app an off
Application [
A app off off
Irvisible
Application
Peaks peaks an on
Data
Rl | B

i

Many types of summary table components are available, including:

* Handle Graphics Summary Table
* Simulink Summary Table (requires Simulink Report Generator)
» Stateflow Summary Table (requires Simulink Report Generator)

The component used in this example represents MATLAB Report Generator summary
table components, all of which exhibit similar behavior

Open the Example Report Template

This example uses the figloop-tutorial report template. To open the figure loop
tutorial report template, enter the following at the MATLAB command line:



Summary Table Components

setedit figloop-tutorial

Select Object Types

You can use the Object type selection list to choose Handle Graphics object types for the
summary table, including blocks, signals, systems, and models. The figloop-tutorial
reports on figure objects.

Add and Remove Properties

You can select object properties to appear in the summary table from the Property
Columns pane. To add a property to the summary table, select the property category from
the property category drop-down box to the right of the Property columns table. Each
property category has its own list of properties, which appear in the field under the box.
The following figure shows Main Properties as the selected category.

—Property Columns
Prooertv Nar| Width| Header |Main Properties =]
Tag 1| <auto=
ﬁ. Children
Mame 3| <auto> FileMNarme
Visible 1| <auto > "’ Mame
HandleVisibility 1| <auto= Tag
X
Jm

v Remove empty columns

To add a property:

Select the category from the property category drop-down box.
Select a property in the properties list.

Click the Add property il button.

The property appears in the Property columns table.
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To remove a property from the table:

1 Select the property in the Property columns table.
2 x|
Click the Delete property button.

The property name is removed from the Property columns table.

Note After making changes in the Report Explorer, click Apply to make the changes take
effect.

You can define your own properties by entering their names into the Property columns
table using valid variable notation.

Set Relative Column Widths

To apply a relative column width to the summary table columns in the generated report,
double-click on the Width column of a row in the Property columns table . If you do not
specify a value for this field, column widths automatically set.

Set Object Row Options

You can use the Object Rows pane to set options for table rows, including anchor,
filtering, and sorting options. Select Insert anchor for each row to place an anchor in
each table row in the report. Use the Include figures list to specify what objects to
include in the summary table.

Summary table components in figloop-tutorial report on figure objects. For more
information on options for these figure objects, see the following sections:

* “Loop on the Current Figure” on page 6-24

* “Loop on Visible Figures” on page 6-24

* “Loop on Figures with Tags” on page 6-24



Logical and Looping Components

Logical and Looping Components

Logical and looping components execute conditionally, determining when a child
component executes or how many times a child component executes.

A looping component runs its child components a specified number of times. There are
several looping components, such as logical loops and Handle Graphics loops.

For an example that uses loop components, see “Edit Figure Loop Components” on page
6-22.
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Edit Figure Loop Components
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In this section...

“Figure Loop in a Report” on page 6-22
“Figure Properties” on page 6-23

“Loop on the Current Figure” on page 6-24
“Loop on Visible Figures” on page 6-24
“Loop on Figures with Tags” on page 6-24
“Modify Loop Section Options” on page 6-24

Figure Loop in a Report

This example uses the Figure Loop, which is representative of many types of loops. The
Figure Loop component runs its child components several times. In each iteration, the
Figure Loop applies its child components to Handle Graphics figures. The figloop-
tutorial report setup file creates a report that documents several Handle Graphics
figures.

1

At the MATLAB command prompt, enter:

setedit figloop-tutorial
To display the Handle Graphics figures, enter:

figloopfigures

The figures Membrane Data, An Application, and Peaks Data appear on the
screen because their visible property is 'on'. The Invisible Membrane Data
and An Invisible Application figures do not appear on screen because their
visible property is 'off'. These invisible figures exist, but they are hidden.

In the Report Explorer, in the Outline pane on the left, select the Figure Loop
component called Figure Loop Section 1.

The Properties pane for the Figure Loop component appears.
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FigureLoop

Figure Selection

Indude figures: [AII figures with tags:

app
membrane

Match with regular expressions

Loop Figure List

Membrane Data
Invisible Membrane Data
An Application

An Invisible Application

Section Options

Create section for each objectin loop
|| Display the object type in the section title
Create link anchor for each objectin loop

Figure Properties

Revert

Figure properties control which figures appear in the report. Table 1.1 of the figloop-
tutorial report includes a summary of the properties of the figures used in this tutorial.

Table 1.1. Figure Properties

Name Tag Visible HandleVisibility
Membrane Data membrane on on
Invisible Membrane Data membrane off on
An Application app on off
An Invisible Application app off off
Peaks Data peaks on on
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For this example, do not change these properties. For more information, see “Add,
Replace, and Delete Properties in Tables” on page 6-13.

Loop on the Current Figure

To include only the current figure in the report, from the Include figures list, select
Current figure only. The current figure is the figure that is current when the report
generates. This figure may not be the same figure that you selected as the current figure
in the Report Explorer before report generation. For example, if the report generation
process creates figures in your report, the last figure created with HandleVisibility
set to 'on' is the current figure.

Loop on Visible Figures

To include snapshots of all visible figures in your report, in the Include figures selection
list, select Visible figures. This option inserts a snapshot and Property Table for all
figures that are currently open and visible.

1  Select the Data figures only (Exclude applications) option to exclude figures from
the loop whose HandleVisibility parameteris 'off'.

2 To generate the report, in the Report Explorer toolbar click the Report button.
In the generated report, scroll down to “Chapter 2 Figures in Report.” The Membrane
Data and Peaks Data figures appear in the generated report.

Loop on Figures with Tags

To include figures with specified tags in the report:

1 From the Include figures list, select ALl figures with tags.
2 In the list of tags, delete membrane.
3 Click Report to generate the report.

The An Application and An Invisible Application figures appear in the report.
They both have an app tag.

Modify Loop Section Options

In a loop, a section refers to a space in the generated report in which information,
including text, images, and tables, appears. You can alter the appearance of sections in
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each loop appear in the report by using the options in the Figure Loop component's
Section Options pane.

* Create Section for Each Object in Loop — Create an individual section for each
object found in the loop, using the object title as the section title. This option is useful
when a loop does not contain a Chapter/Subsection component that organizes the

loop results.

* Display the Object Type in the Section Title — Precede section titles with object
titles. Enable this option by selecting Create section for each object in loop. For

example:

1 Enter membrane back in the list of tags.

2 Generate the figloop-tutorial report.

The figures produced by the loop are:

Membrane Data
Invisible Membrane Data
An Application
An Invisible Application

Enable the Create section for each object in loop option.

4 Enable the Display the Object Type in the Section Title option.

Generate the figloop-tutorial report.

The figures produced are now:

Figure
Figure
Figure
Figure

Membrane Data
Invisible Membrane Data
An Application
An Invisible Application

The figures produced are now:

Figure
Figure
Figure
Figure

Membrane Data
Invisible Membrane Data
An Application
An Invisible Application

* Create a Link Anchor for Each Object in Loop — Create a hyperlink to the object
in the generated report.
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* “Report Templates” on page 7-2

* “Create a Report Template” on page 7-7

* “Copy a Template” on page 7-8

* “Set a Template’s Properties” on page 7-9

* “Open a Template” on page 7-11

* “Generate a Report Using a Template” on page 7-13

* “Default Template Contents” on page 7-14

* “Customize Microsoft Word Report Styles” on page 7-20

* “Customize Microsoft Word Component Templates” on page 7-23
* “Customize a Microsoft Word Title Page Template” on page 7-33
* “Create a Custom HTML or PDF Template” on page 7-38
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Report Templates

7-2

In this section...

“Template-Based Output Types” on page 7-2

“Templates Versus XSL and DSSSL Style Sheets” on page 7-3
“Component Styles” on page 7-4

“Component Templates” on page 7-5

“Component Holes” on page 7-5

“Template Cache” on page 7-5

The Report Explorer allows you to use templates to format your reports. A template is an
HTML or Word document that specifies the fixed content, format, and layout of your
report. You can use Microsoft Word templates to format Word and PDF reports and HTML
templates to format HTML and PDF reports. The MATLAB Report Generator comes with a
default set of Word templates for PDF and Word reports and HTML templates for PDF and
HTML reports. You can create your own templates by copying and customizing these
default templates.

Template-Based Output Types

The Report Explorer provides a set of template-based report output types. These output
types appear in the File format drop-down list in your report generator’s root Form or
Reporter component. Selecting a template-based output type populates the adjacent
drop-down list with the templates available for that output type, including the Report
Explorer’s built-in templates and any templates that existed on the MATLAB path or in the
current directory a the start of your MATLAB session. By default the Report Explorer uses
a default template to format a report for the specified output type. You can specify
another template by selecting from the adjacent list.
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Template-Based Output Types

Name on Form |Name on Report |Generates
Component Component
Direct PDF |Direct PDF Formatting Objects (FO) representation of a
(from report’s content and format based on an HTML
template) template with PDF-specific extensions. The Report
Explorer uses the Apache Formatting Objects
processor (FOP) to convert the FO representation
to PDE.
PDF (from PDF (from Word |Microsoft Word report from a Microsoft Word
Word) template) template and then uses Microsoft Word to convert
the Word report to PDFE. This output type is
available only on Windows. Report size is limited by
Word'’s pagination capacity, typically about 500
pages.
HTML HTML ( f rom HTML report package from an HTML template
template) package. Both the report and the template are zip

files that contain HTML documents, style sheets,
images, and JavaScripts.

Single-File

Single-File

HTML report from an HTML template package. The

HTML HTML (from HTML report is a single HTML file that embeds the
template) report’s text, style sheets, images, and JavaScripts.

Word Word (from Microsoft Word report from a Word report.
template)

Templates Versus XSL and DSSSL Style Sheets

Besides templates, the Report Explorer supports use of XSL or DSSSL style sheets to
format reports. An XSL style sheet is a program, written in a dialect of XML called XSL,
that converts and formats your report’s intermediate XML content to HTML or PDF
output. A DSSSL style sheet is a program, written in a dialect of Lisp, that converts your
report’s intermediate XML content to Microsoft Word output. The Report Explorer
supports style-sheet-based formatting to provide backward compatibility with report
generators developed with the Report Explorer in releases that preceded availability of
templates. You should use templates exclusively for new report generators that you
develop with the Report Explorer. This is because templates have significant advantages
over style sheets:
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* Formatting: XSL and DSSL style sheets have limited formatting options. For example,
all titles and all body paragraphs in your report must have the same format. By
contrast, templates allow you to use all formatting options available in Microsoft Word
and HTML documents.

* Scalability: The Report Explorer uses a MATLAB-based file converter, called db2dom,
to convert reports based on templates. The Report Explorer uses Java-based file
converters, xs1t and JADE, to convert reports based on XSL and DSSSL style sheets.
The db2dom converter is typically an order of magnitude faster than xs1t and JADE
and uses no Java memory for Word and HTML output and much less memory for PDF
output. As a result, the Report Explorer can generate much larger reports with
templates than with style sheet-based output.

Component Styles

Every report template contains a style sheet. This style sheet, not to be confused with an
XSL or DSSSL style sheet, is a document that defines named sets of text, paragraph, list,
and table formats called styles. During report generation, the Report Explorer’s file
converter, db2dom, copies the template style sheet into the generated report and assigns
the style names to paragraphs, text, lists, and tables generated by your report generator’s
components. The program that you use to display or print your report, such as an HTML
browser or Microsoft Word, uses the styles to format your report.

The Report Explorer’s default templates defines all the styles needed to format a report
generated by the Report Explorer from your report setup file. To distinguish them from
other styles, the names of these styles begin with the prefix, rg, for example,
rgParagraph. You can modify the appearance of a report by customizing the definitions
(but not the names) of these styles in a copy of a default template and using the copy to
generate the report.

You can also define your own styles in a customized template and assign them to
components whose dialogs contains a StyleName property. Components that have a
StyleName property include the Text and Paragraph components. In this way, you can
customize the appearance of individual instances of a component. For example, the
default style of a Paragraph component is rgParagraph. By creating and assigning your
own style, for example, myParagraph, to a particular Paragraph component, you can
differentiate the appearance of this component’s output from that of paragraphs that have
the default rgParagraph style.
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Component Templates

The Report Explorer’s default templates contain a component template library. A
component template library is a document that defines templates for Report Explorer
components, such as the Title Page component and the Chapter/Section component.
Each template in the library has a name, for example, rgRectoTitlePage, which
enables the Report Generator to locate the component template in the library. The
component library allows a single template, called the main template, to contain all the
templates needed to format a report generated from the main template.

You can change the format of a report component, such as a title page, by customizing its
template in a copy of a default template and using that customized template to generate
the report. You can also create and store templates for Subform components in a Form
component’s main template. In this way, you can create custom report components with
custom content and custom formats. For example, you can create a custom title page
template and use it with a Subform component to generate a title page that contains
content not defined by the Title Page component, such as a sign-off block.

Component Holes

The Report Explorer’s default component templates contain placeholders, called holes,
that designate where to insert generated content relative to the template’s fixed content
and other generated content. For example, the Title Page component’s templates contain
holes for a report’s title, subtitle, author, abstract, etc. The Report Explorer replaces
these holes with generated content during report generation. For example, it replaces the
title hole in the Title Page template with the title specified by the Title Page
component’s Title property.

You can alter the layout and content of a component that specifies content by rearranging
or deleting its holes. For example, you can delete or adjust the location of a title page’s
subtitle by moving or deleting the subtitle hole in the Title Page component’s template.
You can also include holes in the templates that you create for Form and Subform
components and fill those holes using Template Hole components in your report
generator setup file. In this way, for example, you can generated a title page that exactly
fits your title page layout and format requirements.

Template Cache

The first time you open the Report Explorer in a MATLAB session it searches the
MATLAB path for templates. It stores all the templates that it finds in a cache. It also adds
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any templates that you create in the session to the cache. Subsequently it searches the
cache for any template that you specify that is not in the current directory. This avoids the
need to search the MATLAB path every time the Report Explorer needs to generate a
report based on a template. If you try to use a template that is not on the MATLAB path at
the beginning of the MATLAB session, the Report Explorer indicates that it cannot find
the template. In this case, you can either change MATLAB working directory to the
directory to the template directory or you can add the directory to the MATLAB path and
refresh the cache. To refresh the cache, execute

>> rptgen.db2dom.TemplateCache.getTheCache(true);

at the MATLAB command line.

See Also

Related Examples

. “Create a Report Template” on page 7-7

. “Generate a Report Using a Template” on page 7-13

. “Customize Microsoft Word Report Styles” on page 7-20

. “Customize Microsoft Word Component Templates” on page 7-23
. “Customize a Microsoft Word Title Page Template” on page 7-33
. “Create a Custom HTML or PDF Template” on page 7-38

More About
. “Default Template Contents” on page 7-14



Create a Report Template

Create a Report Template

To create a report template for use with the Report Explorer:

1

ga A W N

Copy an existing template, either one of the Report Explorer’s default templates or a
template based on one of the default templates.

Set the template’s properties.

Open the template in a template editor.

Edit the template to meet your requirements.
Save the template.

See Also

Related Examples

“Copy a Template” on page 7-8

“Set a Template’s Properties” on page 7-9

“Open a Template” on page 7-11

“Customize Microsoft Word Report Styles” on page 7-20
“Customize Microsoft Word Component Templates” on page 7-23
“Customize a Microsoft Word Title Page Template” on page 7-33

More About

“Report Templates” on page 7-2
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Copy a Template

In Report Explorer, select Tools > Edit Document Conversion Template.

In the template library (center) pane, select the template you want to copy. For
example, select the Default HTML Template.

In the template dialog (right) pane, click Copy template. A file browser appears.

In the file browser, navigate to a folder where you want to save the template. The
folder should be on the MATLAB path (for example, in the MATLAB folder in your
home folder).

Specify the file name, using the default file extension for the kind of template you are
copying: a Microsoft Word template(.dotx), an HTML template (. htmtx), single-file
HTML template (. htmt), or PDF template (. pdftx).

Click Save. The new template appears in the list of templates in the Report
Explorer’s center pane.

Select the new template. The template’s dialog appears in the right pane. The initial
name of the copy in the list of templates is Copy of ORIGINAL, where ORIGINAL is
the name of the template that you copied.

Set the new template’s properties.
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Set a Template’s Properties

In this section...

“Set Template Properties Interactively” on page 7-9
“Set Template Properties Programmatically” on page 7-9

A conversion template’s properties allows the Report Explorer to keep track of the
templates that you create. You can set the properties interactively or programmatically.

Set Template Properties Interactively
1 In Report Explorer, select Tools > Edit Document Conversion Template to display
the Report Explorer’s template library (if it is not already displayed).

2 From the list of templates in the Report Explorer’s center pane, select the template
whose properties you want to set. The template’s dialog appears in the right pane
displaying the template’s current properties.

3 In the dialog box, enter values for the template’s properties in the following fields:

Template id Unique value used by the Report Explorer to identify this

template.
Display Appears in the drop-down list of templates in the Form and
name Report component dialogs.

Description Describes this template’s purpose.
Creator Specifies this template’s creator.

4 To save the template properties you entered, click outside of the Report Explorer’s
dialog pane.

Set Template Properties Programmatically

Use the DOM API's mlreportgen.dom.Document.getCoreProperties and
mlreportgen.dom.Document.setCoreProperties methods to get and set a
conversion template’s properties. Set the template’s core properties as follows to
correspond to the properties that appear on the template’s dialog in the Report Explorer:
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Dialog Property Core Property
Template id Identifier
Display name Title
Description Description
Creator Creator
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Open a Template

You can open a custom template to edit it. Opening a Word template opens the template
in Microsoft Word. Opening a single-file HTML template opens the file in the HTML editor
specified by your Report Generator preferences (the MATLAB editor by default). Opening
an HTML or PDF packaged template unzips the template and then opens the main
template document and the document part template library in the HTML editor. To learn
more about contents of templates, see “Default Template Contents” on page 7-14.

You cannot edit a default template. If you want to customize a default template, you must
create a copy of the template and edit the copy. See “Copy a Template” on page 7-8.

Tip The Report Generator repackages an open HTML or PDF template before running a
report based on the template. Run a report after editing an HTML or PDF template to
ensure that your changes are saved.

In Report Explorer, select Tools > Edit Document Conversion Template.

Select a custom template from the list of templates in the Report Explorer’s template
list (center) pane. The template’s dialog appears in the right pane.

Note If your custom template does not appear in the list, refresh the Report
Explorer’s template cache (see “Template Cache” on page 7-5).

3 Click Open template to open the report’s template and component template library
for PDF and HTML templates.

4 Click Open style sheet to open the template’s style sheet.

See Also
Related Examples

. “Edit HTML or PDF Styles in a Template” on page 7-40
. “Create a Report Template” on page 7-7
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More About
. “Report Templates” on page 7-2
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Generate a Report Using a Template

1 In Report Explorer, in the outline pane, select the top-level component of the report.
2 In the dialog box, set File format to one of these options, depending on whether the
root component is a Form component or a Report component:
Form Component Report Component
Direct PDF Direct PDF (from template)
HTML HTML (from template)
PDF (from Word) PDF (from Word template)
Single-File HTML Single-File HTML (from template)
Word Word (from template)
3 Optionally, from the list of templates available for the current file format, select a
template.
4 Ifyou select HTML or HTML (from template) for the file format, choose a
packaging option for the output files.
* Unzipped — Generate the report files in a subfolder of the current folder. The
subfolder has the report name.
* Zipped — Package report files in a single compressed file that has the report
name, with a . zip extension.
* Both Zipped and Unzipped
> In the toolbar, click the Report button 7.
See Also
More About

“Report Templates” on page 7-2
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Default Template Contents

7-14

In this section...

“Default Styles” on page 7-14
“Component Templates” on page 7-17

A default report template contains an empty main document that is copied to the report
output to hold the report content during report generation. In addition, it contains:

* A style sheet with default style definitions for report elements.

* A template library that contains templates for the title page, table of contents,
chapters, and chapter and section titles. The templates define page headers and
footers, page size, page margins, and page orientation for a report’s title page, table of
contents, and chapters. The templates also include toc and autonumber fields used by
Microsoft Word and HTML browsers to generate table of contents and chapter and
section numbers when they open a report.

Default Styles

A default report template includes styles that the Report Explorer uses to format
components during report generation. Most styles begin with rg (for example, rgTitle).
Styles for syntax highlighting MATLAB code begin with MWSG, for example,
MWSHKeywords. The default style names and formatting are the same for the Word and
HTML templates, to the extent applicable. For example, page break formatting applies
when you use a Word template or an HTML template used for formatting PDF reports, but
not an HTML template used for formatting HTML reports..

You can modify the built-in styles, but do not delete them. In addition, you can define your
own styles and use them in components that allow you to specify a style, such as the
Paragraph component.

Style Component to which the style applies
MWSHComment MATLAB code comment

MWSHKeywords MATLAB code keywords

MWSHstrings MATLAB code character vectors
rgAbstract Title Page component abstract




Default Template Contents

Style Component to which the style applies

rgAbstractTitle Title Page component abstract section

rgAuthor Title Page component front page author

rgAuthorVerso Title Page component back page author

rgBody Text component

rgChapter Chapter component

rgChapterTitle Chapter component title

rgCopyright Title Page component copyright

rgFigure Paragraph that contains an image generated by a snapshot
or Image component, to adjust the spacing of images relative
to adjacent paragraphs

rgFigureCaption The caption for Image component and snapshot components

rgFigureTitle The Image component and snapshot components title

rgFigureTitleNumber |The Image component and snapshot components title
number

rgFigureTitlePrefix |The Image component and snapshot components title prefix

rgFigureTitleText The Image component and snapshot components title text

rgLegalNotice Title Page component legal notice section

rgListStyle Specifies the style of lists generated by the List component.

rgListTitle The List component title

rgListTitleNumber The List component title number

rgListTitlePrefix The List component title prefix

rgListTitleText The List component title text

rgParagraph Paragraph component text

rgParagraphTitle Paragraph component title

rgProgramListing Code generated by:

* Text component with Show text as syntax highlighted
MATLAB code option is selected

* MATLAB Function Block component
* Truth Table component
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Style Component to which the style applies

rgPubDate Title page report creation date

rgPubDatePrefix Title page report creation date prefix

rgSectlTitle Section title for first-level section in a chapter
rgSectlTitleNumber Number for Section title for first-level section in a chapter
rgSectlTitlePrefix Prefix for Section title for first-level section in a chapter
rgSectlTitleText Text for Section title for first-level section in a chapter
rgSect2Title Section title for second-level section in a chapter
rgSect2TitleNumber Number for Section title for second-level section in a chapter
rgSect2TitlePrefix Prefix for Section title for second-level section in a chapter
rgSect2TitleText Text for Section title for second-level section in a chapter
rgSect3Title Section title for third-level section in a chapter
rgSect3TitleNumber Number for Section title for third-level section in a chapter
rgSect3TitlePrefix Prefix for Section title for third-level section in a chapter
rgSect3TitleText Text for Section title for third-level section in a chapter
rgSect4Title Section title for fourth-level section in a chapter
rgSect4TitleNumber Number for Section title for fourth-level section in a chapter
rgSect4TitlePrefix Prefix for Section title for fourth-level section in a chapter
rgSect4TitleText Text for Section title for fourth-level section in a chapter
rgSect5Title Section title for fifth-level section in a chapter
rgSect5TitleNumber Number for Section title for fifth-level section in a chapter
rgSect5TitlePrefix Prefix for Section title for fifth-level section in a chapter
rgSect5TitleText Text for Section title for fifth-level section in a chapter
rgSubTitle Title Page component subtitle

rgTable Table content

rgTableTitle Table title

rgTableTitleNumber Table title number

rgTableTitlePrefix Table title prefix

rgTableTitleText Table title text




Default Template Contents

Style Component to which the style applies

rgTitle Title Page component front page title abstract, and legal
notice section

rgTitleVerso Title Page component back page title abstract, and legal
notice section

rgT0CSection Table of contents

Component Templates

The component template library of a default report template contain templates to
determine the page layout and formats of report sections, such as the title page, table of
contents, and chapters.

Part Template Report Explorer Components the Part
Template Formats
rgRectoTitlePage Title Page

Front title page contents, including the
report title, subtitle, author, and an image.

rgVersoTitlePage Title Page

Back title page contents, including the date
published, copyright, legal notice, and

abstract.
rgTOCSectionTitle The table of contents automatically
generated for Word and PDE.
rgChapter Chapter/Section

Chapter (top-level section), including the
title (prefix, such as Chapter, number, and
title) and for the content.
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rgChapterTitlePrefix | prefix
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Part Template

Report Explorer Components the Part
Template Formats

rgSectlTitle Chapter/Section
rgSect2Title Title for a section (sections below the
_ chapter level). The title can include a prefix

rgSect3Title (such as Chapter), number, and title.

rgSect4Title

rgSect5Title

rgListTitle List
Title of the list.

rgTableTitle Table, Array-BasedTable, and table
components such as Handle Graphics
Property Table
Table title, including prefix (such as Table,
number, and title) and for the content.

rgFigureTitle Table and Array-BasedTable

Table title, including prefix (such as Table,
number, and title) and for the content.

Component Template Holes

Component templates include fill-in-the-blanks hole markup. The Report Explorer fills
holes with content that components generate.

For example, the rgChapter template in the default Word template includes an

rgChapterTitle hole.

* rgChapterTitleNumber | ,umber) | o™ rdChapterTitle | titje 1]

rgChapterContent Chapter -content - rgChapterContent q




See Also

The Report Explorer fills the rgChapterTitle hole with the contents of the Title
property of top-level Chapter/Section components in a report.

You can rearrange or delete holes to change the order in which generated content
appears in the report or to omit content. Do not add holes for content that a component
does not specifically address. If you add holes, the Report Explorer ignores them. If you
need to add content to a Title Page or other component, use a Form or Subform
component instead.

See Also

Related Examples

“Generate a Report Using a Template” on page 7-13

“Copy a Template” on page 7-8

“Customize Microsoft Word Report Styles” on page 7-20
“Customize Microsoft Word Component Templates” on page 7-23
“Customize a Microsoft Word Title Page Template” on page 7-33

More About

“Report Templates” on page 7-2
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Customize Microsoft Word Report Styles

7-20

In this section...

“Customize Default Microsoft Word Component Styles” on page 7-20
“Create Styles in a Microsoft Word Template” on page 7-21

You can customize report styles in a custom Word template or add styles to a custom
Word template.

For more information about Word styles, see the Microsoft Word documentation.

Customize Default Microsoft Word Component Styles

Note You cannot customize a default template’s styles directly. You must create a copy of
the default template and customize the copy’s styles, see “Copy a Template” on page 7-8.

1 In the Report Explorer, select Tools > Edit Document Conversion Template.

2 From the list of templates, select the custom template that contains the style you
want to customize.

Note If the template does not appear in the template list, refresh the Report
Explorer’s template cache, see “Template Cache” on page 7-5.

3 In the dialog box, click Open style sheet. Microsoft Word’s Manage Styles dialog
box appears.

4 Use the Manage Styles dialog box to modify or create styles.

Styles that begin with rg (for example, rgParagraph) are the default styles used for
report components. A default style applies to all instances of a component with which
it is associated. (In the Report Explorer, some components allow you to replace the
name of a default style with the name a style that you create. You can then specify
different styles for different instances of the same component.)

Close the Manage Styles dialog box.
6 Save the template.


https://office.microsoft.com/en-us/word-help/

Customize Microsoft Word Report Styles

Create Styles in a Microsoft Word Template

In the Report Explorer, select Tools > Edit Document Conversion Template.
From the list of templates, select a custom template.

In the dialog box, click Open style sheet.

If applicable, select an existing style to use as a starting point for the new style.
Click New Style .

gua A W N

Manage Styles @

Edit | Recommend | Restrict | et Defautts |

Sort order: | As Recommended |Z| [T show recommended styles anly

Select a style to edit

I
T rgAbstract ||
T rgAuthor b
T rgluthorVerso
T4 rgBody
T rgChapter
T rgCopyright
T rgFigure
T rgFigureCaption
T4 rgFigureTitle =

Preview of Normal:

Font: [Default] «Body (Calibri), Left
Line spacing: single, Space
After 10 pt, Widow/Orphan control, Style: Show in the Styles gallery

@ Onlyin this document () Mew documents based on this template

Cancel

6 Specify a name for the new style and define the style characteristics. To save the new
style definition, click OK and close the dialog box.

In the Manage Styles dialog box, click OK.

In Word, save and close the template.
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See Also

Related Examples

. “Customize Microsoft Word Component Templates” on page 7-23
. “Customize a Microsoft Word Title Page Template” on page 7-33

More About

. “Report Templates” on page 7-2
. “Default Template Contents” on page 7-14
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Customize Microsoft Word Component Templates

In this section...

“Custom Word Component Templates” on page 7-23
“Display the Developer Ribbon in Word” on page 7-24
“Customize a Word Component Template” on page 7-24
“Set Default Text Style for a Hole” on page 7-25
“Distinguish Inline and Block Holes” on page 7-27

“Avoid Changing Block Holes to Inline Holes” on page 7-28
“Delete a Hole” on page 7-28

“Add an Inline Hole” on page 7-29

“Add a Block Hole” on page 7-30

“Remove or Modify Chapter Prefix” on page 7-31

Custom Word Component Templates

You can customize a Word component template (such as a title page template) to:

» Tailor report formatting to meet your specific formatting requirements.

* Delete content by deleting a hole. For a description of holes, see “Component Holes”
on page 7-5.

* Change component layout by changing the order of holes.

* Change a title page, table of contents, or chapter page layout, including page size,
page orientation, page margins, and header and footer content and format.

If you delete a hole in a component template, the generated report does not include the
component data associated with that hole. For example, the rgRectoTitlePage part
template includes an rgAuthor hole. If you delete the rgAuthor hole, then reports
generated with the template do not include the author, even if the report has a Title Page
component that specifies a value for the Author property.

The Report Explorer ignores holes in a component template that do not correspond to
content properties specified by the component. If you need to generate content not
addressed by one of the Report Explorer’s components, use a Form or Subform
component to generate the content. For example, you can use a Subform component with
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a custom template to generate a title page that contains content, such as a sign-off block,
not addressed by the Title Page component.

Display the Developer Ribbon in Word

To work with holes in a Word template, use the Word Developer ribbon. If the Developer
tab is not showing in your Word ribbon, add it to the ribbon.

In Word, select File > Options.

In the Word Options dialog box, select Customize Ribbon.

In the Customize the Ribbon list, select the Developer check box and click OK.

Tip If you do not see Developer check box in the list, set Customize the Ribbon to
Main Tabs.

Customize a Word Component Template

To customize a report element such as a title page, replace the appropriate default
component template with a customized copy of the template. For an example of creating a
custom Word component template, see “Customize a Microsoft Word Title Page Template”
on page 7-33.

Note You cannot customize a default template’s styles directly. You must create a copy of
the default template and customize the copy’s styles, see “Copy a Template” on page 7-8.

In the Report Explorer, select Tools > Edit Document Conversion Template.
In the list of templates in the middle pane, select a custom template.

Note If the template does not appear in the template list, refresh the Report
Explorer’s template cache, see “Template Cache” on page 7-5.

3 In the Properties pane, click Open template.

At the beginning of the template, position the cursor in the first paragraph and click
the Quick Parts button.

In the Insert tab, select the Quick Parts D button.



Customize Microsoft Word Component Templates

In the Quick Parts Gallery, select the part template (for example, rgChapter).

7 Edit the copy of the part template. For example, remove a hole by right-clicking and
selecting Remove Content Control.

In the template, select the part template, including all of its holes.
In the Quick Parts Gallery, select Save Selection to Quick Part Gallery.

10 In the Create New Building Block dialog box, set Name to the part template name
(for example, rgChapter) and the Category to mlLreportgen. Click OK.

11 In the template, delete the customized part template.
12 Save the main template.

Set Default Text Style for a Hole

Your template can specify the name of a style to use as a default to format text generated
for a hole.

1 In the Report Explorer, select Tools > Edit Document Conversion Template.

2 In the list of templates in the middle pane, select the custom template that has the
hole you want to set the default text style for.

3 In the Template Browser, click Open template.

In the Insert tab, select the Quick Parts D button.

5 In the Quick Parts Gallery, select the part template that contains the hole (for
example, rgChapter).

6 Right-click in the text area of the hole whose default text style you want to specify.
For example, in rgChapter, right-click in the rgChapterTitle hole.

-+ -+

ZrgChapterTitle

prefix "/ rgChapterTitleNumber | number) | o | rgChapterTitle Lme ‘“

rgChapterContent| chapter -content - rgChapterContent - ¢

7  Select Properties.

8 In the Content Control Properties dialog box, select the Use a style to format text
typed into the empty control check box.
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9 From the Style list, select a style to use an existing style or select New Style to
create a new style to use as the default style and click OK.

10 Select the part template and click the Quick Parts button.
11 Click Save Selection to Quick Part Gallery.

|;| 4 A [ signature Line - g

Quick WordArt D F.;:l_.Date&Time Eauat S
(V[ vordAl rop quation ym
Parts - - Cap~ [~ object ~ . .
mireportgen

rgChapter

prefis munber. titie

rgFigureTitle

prefin number. Titke

rglistTitle

Tonse

rgRectoTitlePage

Report Title
Report Subtitle
| rgSect1Title
oD
Ll AutoTest

[E2 Docurnent Property

[mm] Field...

=1 Building Blocks Organizer...

I-—‘H Save Selection to Quick Part Gallery...

s
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12 [n the Create New Building Block dialog box, set Name to the part template name
(for example, rgChapter) and the Category to mlreportgen. Click OK.

13 Save and close the template.

Distinguish Inline and Block Holes

The Report Explorer supports two types of holes: inline and block.

* Use an inline hole is for content that you can include in a Word paragraph.
* Use a block hole for content that you cannot embed in a paragraph.

You can configure the Word editor to provide visual cues that indicate whether a hole is
an inline or block hole.

1 Open the custom Word template.
On the Word ribbon, select the Home tab.

Click the Show/Hide ¥ button to display Word paragraph markers.
4  On the Word ribbon, select the Developer tab.

Click Design Mode to see the Word markup for holes.

Click a hole to determine whether it is an inline or block hole.

* Inline hole — The bounding box does not include the paragraph marker.

= rgChapterTitle

n rgCha pterTitle title ‘“

* Block hole — The bounding box does include the paragraph marker.

zrgChapterContent

rgChapterContent Chapter -content - rgChapterContent q
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Avoid Changing Block Holes to Inline Holes
Do not change a block hole to an inline hole.

You can accidentally change a block hole to an inline hole by removing the paragraph
marker of an inline hole that is followed by a block hole. For example, if you delete the
paragraph marker for the rgChapterTitle inline hole, the rgChapterContent block
hole changes to an inline hole.

rgChapterTitlePrefix prefix " rgChapterTitleNumber |, mber. | o™ rdChapterTitle | jtje 1]

rgChapterContent Chapter -content - rgChapterContent q

Delete a Hole

In the Report Explorer, select Tools > Edit Document Conversion Template.

In the list of Word templates in the middle pane, select the custom template that you
want to edit.

3 In the Template Browser, click Open template.
To display Word paragraph markers (if they are not already visible), on the Word
ribbon in the Home tab, click the Show/Hide ¥ button.
In the Word ribbon, in the Insert tab, click the Quick Parts [ - button.

6 Select the part template to customize. For example, select rgChapter to customize
the part template for a chapter.
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Tip To display Word markup for the part template, on the Word ribbon, in the
Developer tab, click Design Mode.

Write down the name of the part template you are customizing, because you need to
enter that name later in this procedure.

In the rgChapter part template, delete the rgChapterTitlePrefix hole. Select
the hole markup and click the Delete key.

In the template, select all of the contents of the part template.
Right-click and select Properties.

In the Content Control Properties dialog box, in the Title and Tag fields, enter the
name of the template part you are customizing rgChapter. Click OK.

In the template, select all of the contents of the part template. In the Insert tab, click
the Quick Parts button.

Click Save Selection to Quick Part Gallery.

In the Create New Building Block dialog box, set Name to the part template name
(for example, rgChapter) and the Category to mlreportgen. Click OK.

In the template, select all of the contents of the part template and click the Delete
button.

Save and close the template.

Add an Inline Hole

1

In the Report Explorer, select Tools > Edit Document Conversion Template.
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10

11
12

13

14

In the list of Word templates in the middle pane, select the custom template that you
want to edit.

In the Template Browser, click Open template.

To display Word paragraph markers, click the Show/Hide ' button.

Position the Word insertion mark at the point in a paragraph where you want to add
an inline hole.

Tip If the hole is the only content in a paragraph or is at the end of a paragraph, add
several blank spaces and insert the hole before the spaces.

Click the Rich Text Control button . Word inserts a rich text control at the
insertion point.

To see hole markup, on the Word ribbon, in the Developer tab click Design Mode.
Right-click in the hole and select Properties.

In the dialog box, in the Title and Tag fields, enter the name of the hole. Use a
Report Explorer hole name. For example, if you insert an rgChapterTitlePrefix
hole, set the Title and Tag fields to rgChapterTitlePrefix.

In the template, select all of the contents of the part template. In the Insert tab, click
the Quick Parts button.

Click Save Selection to Quick Part Gallery.

In the Create New Building Block dialog box, set Name to the part template name
(for example, rgChapter) and the Category to mlreportgen. Click OK.

In the template, select all of the contents of the part template and click the Delete
button.

Save and close the template.

Add a Block Hole

Creating a block-level hole in a Word document is essentially the same as creating an
inline hole. The main difference is that rich text content control must contain an (empty)
paragraph instead of residing in a paragraph. Create an empty paragraph at the point
where you want to create a block-level hole. If you are at the end of a document, create a
second empty paragraph.



See Also

Remove or Modify Chapter Prefix

Reports that use the default templates include the word Chapter as a prefix in the
chapter title. If you do not want to use the prefix, you can delete from your template
before you create a report. If you want to use a word other than Chapter, for example,
for localization, you can replace the prefix.

1 Open the template.
On the Word Insert ribbon, in the Text area, click the Explore Quick Parts button.
3 Toinsert an instance of the part you want to modify in your template, select the
rgChapter quick part.
4 Edit the instance. You can remove the prefix hole, or you can replace it with fixed
text.
Make sure that the style applied to this line is still rgChapter.
rghbstractTitle Ta
rghuthar T
rgAuthorverso T
%uml:er. tltle rgBody 1a
rgChapter 1T|
Chapter content rgCopyright T
rgFigure T
5 Select the edited instance. Then, on the Insert ribbon, click the Explore Quick
Parts button and select Save Selection to Quick Parts Gallery.
6 In the dialog box, set Name to rgChapter and Category to mlreportgen, and then
click OK. Confirm that you want to overwrite the previous version.
7 Save and close the template.
See Also

Related Examples

“Create a Report Template” on page 7-7
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. “Customize Microsoft Word Report Styles” on page 7-20
. “Customize a Microsoft Word Title Page Template” on page 7-33

More About

. “Report Templates” on page 7-2
. “Default Template Contents” on page 7-14
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Customize a Microsoft Word Title Page Template

In this section...

“Create a Custom Template” on page 7-33
“Change the Color of a Report Title” on page 7-34
“Assign the Template to a Report” on page 7-35

“Customize Title Page Content and Layout” on page 7-36

The Report Explorer default Word document conversion template contains document part
templates for the front (recto) and back (verso) side of a report title page. The Report
Explorer file converter for the Word (from template) output type uses the title page
part templates to produce the title pages in the Word output.

This example shows how to create a custom template that changes the color of the title
and how to customize the layout of a title page. The example uses a custom template with
the Report Generator magic square report example.

Create a Custom Template

Note To complete the rest of this example, you need a custom Word conversion template.
If you have a custom template that you want to use for this example, you can skip to
“Change the Color of a Report Title” on page 7-34.

In the Report Explorer, select Tools > Edit Document Conversion Template.
In the list of templates, select the Default Word Template.
In the Template Browser, click Copy template.

A W N -

In the file browser, navigate to the folder on the MATLAB path that you want to use
for the custom template. For the file name, enter magic-square and click Save.

In the list of templates, select Copy of Default Word Template.
6 At the top of the Template Properties dialog box, use these settings:
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7

Template: Copy of default-rg-doox
Template Properties
Path: H:\Documents MATLAB \magic-square . dotx
Template id:  magic-square-docx
Display name: Magic Square Template

Description:  Template for magic square Word reports

Creator: ABC, Inc.|

Apply the properties by selecting another template in the list of templates.

Change the Color of a Report Title

You can customize the Magic Square Template (see “Create a Custom Template” on

page 7-33) to use blue text for the report title.

1
2

In the Report Explorer, select Tools > Edit Document Conversion Template.
In the Report Explorer list of Word templates, select Magic Square Template.
In the Template Browser, click Open style sheet. In Word, the template opens, with

the Manage Styles dialog box displayed.

In the Manage Styles dialog box, select the rgTitle style and click Modify.

Manage Styles @

Edit | Recommend I Restrict I Set Defaults |

sort order: | As Recommended |Z| [T show recommended styles anly

Select a style to edit

T rgSect3Title -
T rgSectdTitle
T rgSectTitle
T rgSubtitle
T rgTable

hiE] rETabIeTitle

T rgTitleVerso
T3 rgTOCSectionTitle
14 TOC Title 2

Preview of rgTitle:

Arial [

Font: [Default] Arial, 24.5 pt, Bold, Do not check spelling or grammar, -
Centered
Line spacing: At least 32,35 pt, Space B
Before: 18.65 pt, Keep with next, Don't hyphenate, Style: Show in the s

Hew Style...

@ Onlyin this document () Mew documents based on this template
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5 In the Modify Style dialog box for rgTitle, click the down arrow for Automatic.
Select the blue color box and click OK.

Madify Style 7 =]
Properties
Hame: rgTitle
Style ype: Faragraph [=]
Style based on: T Mormal |z|
Style for following paragraph: T Mormal |z|
Formatting
Arial [+] 22.1] I u Automatic [ =]
_ . _ B Avtomatic
= E] = = - - = Theme Colors
H EEEEER
Sample Text Sampl I ext
Sample Text Sampl | I I TH TR
Sample Text Sampl sc.iara coiors ext
Sample Text Sampl®® mEnEEext
we  More Colors..
Font: (Default) Arial, 24.5 pt, Bold, Do not check spelnng or grammar, Centerea -

Line spacing: At least 32,35 pt, Space
Before: 18.65 pt, Keep with next, Don't hyphenate, Style: Show in the Styles gallery
Based on: Normal o

Add to the Styles gallery  [] Automatically update

@ Only in this document () Mew documents based on this template

In the Manage Styles dialog box, click OK.
Save and close the template.
Assign the Template to a Report

You can assign the customized template to the magic-square. rpt Report Explorer
report.

1 In the Report Explorer, select Report Generator node.
2 Inthe Report Explorer, in the list of reports, select magic square. rpt.
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| Report Explorer
File Edit View Tools Help

O

Name ~|  magic_squares.rpt

7-36

4 | Report Generator

4] Document Conversion Templates

£ - MATLAB (\frome-00-3hibaretts\Do Actions
f/f SDD_custom.rpt 3 R

% SDD_customLrpt —

& demoReport.pt # | Generate report

# ex_link_to_section.rpt
# inpart_outport.rpt
# link_report.rpt

# magicsquare-ink.rpt

Description

This report creates a series of magic squares
s

Z 1 A magic square is a matrix in which the
% magic squaresrpt . | columns, rows, and diagonal all add up to the
% report.rpt b same number.

% simuilnk_tutorial.rpt

In the Report Options pane, click Open report.

In the magic_squares report, add a Title Page component. In the Title Page dialog
box, set the Title field to Magic Squares.

Below the Title Page component, add a Chapter component.

In the Report Options dialog box, set File format to Word (from template) and
instead of Default Word Template, select Magic Squares Template.

Report Qutput Type and Templates

File format: |W0rd (from template) - | lDefauIt Word Template - ]

Default Word Template
DocBook-- updated

My Custom Word Template
/| View report after generation Magic Square Template

Generation Options

Generate the report. Select the magic squares report. In the Report Explorer

e

toolbar, click the Report 7 button.

In the generated report, the title, Magic Squares, appears in blue.

Customize Title Page Content and Layout

This example assumes you have created a custom Magic Square Template (see “Create a
Custom Template” on page 7-33). You can use a different custom Word template.

1
2

In the Report Explorer, select Tools > Edit Document Conversion Template.

In the Report Explorer list of Word templates, select Magic Square Template. In
the Report Options pane, click Open template.

With the cursor in the first (and only visible) paragraph in the template, in the Insert
tab, select the Quick Parts button.



See Also

4 In the Quick Parts gallery, select rgRectoTitlePage to insert of the front title page
part template in the main document conversion template.

Tip To display Word markup for the part template, on the Word ribbon, in the
Developer tab, click Design Mode.

Highlight the rgImage hole and drag it above the rgTitle hole.

Delete the rgAuthor hole.

Select the rgRectoTitlePage part template and click the Quick Parts button.
Click Save Selection to Quick Part Gallery.

© 00 N o U

In the Create New Building Block dialog box, set Name to rgRectoTitlePage and
the Category to mlreportgen. Click OK.

10 In the template, select the contents of the part template (including the section break)
and click the Delete button.

11 Save and close the template.

Suppose that you use the custom template to generate a report that has a Title Page
component that specifies an image and an author. The generated report displays the
image at the top of the title page and does not include an author.

See Also

Related Examples
. “Copy a Template” on page 7-8
. “Customize Microsoft Word Report Styles” on page 7-20

More About

. “Report Templates” on page 7-2
. “Default Template Contents” on page 7-14
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Create a Custom HTML or PDF Template

7-38

In this section...

“Copy the Template” on page 7-38

“Assign the Template to a Report” on page 7-39
“Select an HTML Editor” on page 7-39

“Edit HTML or PDF Templates” on page 7-40

“Edit HTML or PDF Styles in a Template” on page 7-40

You can copy a default template as the basis for your custom template. Alternatively, you
can use mlreportgen.dom.Document.createTemplate to create a template
programmatically.

Copy the Template

To customize the format styles used in the default HTML, single-file HTML, or PDF
template, copy the template and modify or add style definitions in the copy.
In Report Explorer, select Tools > Edit Document Conversion Template.

In the Library pane, select the template you want to copy. For example, select the
Default HTML Template.

3 In the Properties pane, click Copy template.
In the file browser, navigate to where you want to save the template file.

Select a path that is on the MATLAB path (for example, in the MATLAB folder in your
home folder).

Specify the file name, using the default file extension for an HTML template
(. htmtx), single-file HTML template (. htmt), or PDF template (. pdftx). Click Save.

From the list of templates, select the template copy.

In the dialog box, in the Template id and Display name boxes, specify a unique ID
and display name for the template.

The display name is the name that appears in the Report Explorer list of templates.
Use the template ID to identify a template in your code.

7 To save the template properties you entered, click outside of the Properties pane.
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Assign the Template to a Report

You can assign your template to a Report Explorer report.

1 In the Report Explorer, select Report Generator node.
2 From the list of reports, select the report you want to assign the template to.

| Report Explorer
File Edit View Tools Help

U

Name ~|  magic_squares.rpt

4 #%| Report Generator

5 - MATLAB (\thome-00-ah\bartlett§\Do Actions
£4) Document Conversion Templates 5/; (i b P
SDD_custom.rpt ﬂ
4 (8] openreport
£ SDD_customLrpt
2 demoReport.rpt Generate repart

% ex_link_to_section.rpt
% inport_outport.rpt
& link_repart.rpt

# magic-square-link.rpt

Description

This report creates a series of magic squares
and displays them as images.

i

F 1 A magic square is a matrix in which the
i magic_squares.rpt I columns, rows, and diagonal all add up to the
# report.rpt b same number.

% smuink_tutorial.rpt

3 In the Report Options dialog box, set File format to one of the (from template)
options. Select your template from the list.

Report Qutput Type and Templates

File farmat: IWnrd (from template) VI lDefauIt Word Template - ]
Default Word Template
DocBook-- updated

My Custom Word Template
View report after generation Magic Square Template

Generation Options

Select an HTML Editor

By default, when you edit an HTML or PDF style sheet, the style sheet appears in the
MATLAB Editor.

To use a different editor:

1 In the Report Explorer, select File > Preferences.

2 In Edit HTML Command, enter a MATLAB expression that opens the HTML editor
you want to use. For example:

system('Dreamweaver %<FileName> &')
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When you open an HTML style sheet, the Report Explorer replaces FileName with
the template that you selected. The ampersand (&) opens the editor in the
background.

Edit HTML or PDF Templates

The templates consist of the main part (root.html), which defines the default page, and
the document part templates (docpart templates.html). For a single-file HTML
template, all parts of the template are in a single file with an . htmt extension. You can
make similar types of changes in these templates as you can in Word templates. See
“Customize Microsoft Word Component Templates” on page 7-23.

The HTML and PDF templates in Report Explorer are similar, with these exceptions:

* PDF templates define a page layout, including page headers and footers. You can
modify the document part templates for these layout elements. PDF templates can use
a set of DOM API HTML tags supplied for this purpose. See “DOM API HTML
Elements” on page 13-44.

» PDF templates can use only a subset of standard HTML elements. See “Standard
HTML Elements” on page 13-47.

HTML and PDF templates use DOM API HTML tags to define a document part library and
the document part templates within them. The <dplibrary> element defines the library.
Your template can contain only one <dplibrary> tag, which is in place in the default
template. The <dptemplate> element defines a document part. It takes an argument for
the name. For example:

<dptemplate name="rgChapter">

Look in the docpart templates.html file in your template for some examples.

Edit HTML or PDF Styles in a Template

You can customize or add format styles in your HTML or PDF template. You edit the styles
using cascading style sheets (CSS).

For HTML templates, you can use any CSS property or selector. For PDF, you can use a
subset. See “PDF Style Sheets” on page 5-8. You can also use XSL formatting objects (FO)
to format elements in a PDF template. However, to simplify and streamline your code, use
FO only for properties you cannot define using CSS.



See Also

1 From the list of templates in the middle pane, select the template that you want to
edit.

Tip If the Report Explorer middle pane does not show a list of templates, then select
Tools > Edit Document Conversion Template.

In the Properties pane, click Open style sheet.
In the HTML editor, edit the CSS.

For information about editing a cascading style sheet, see documentation such as the
W3Schools.com CSS tutorial.

4  Save the style sheet.

See Also

mlreportgen.dom.Document.createTemplate

Related Examples

. “Generate a Report Using a Template” on page 7-13

. “Customize Microsoft Word Report Styles” on page 7-20

. “Customize Microsoft Word Component Templates” on page 7-23
More About

. “Report Templates” on page 7-2

External Websites
. FO Summary
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* “Create Custom Components” on page 8-2

* “Define Components” on page 8-5

» “Specify Tasks for a Component to Perform” on page 8-12
“Define Report Variables” on page 8-18
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Note Do not create new reports using the Report Explorer app. This information is
provided for maintaining existing reports only. To create a new report generator, use the
Report and DOM APIs. See “Create a Report Program” on page 13-3.

You can create custom components if you want to generate a report that uses
functionality that is not available by using the supplied MATLAB Report Generator
components. Custom components help you to generate complex content in your report
using a single component. For example, you can create a custom component that builds a
table and inserts content into the table based on criteria that you program.

After you complete the process of creating a custom component, you can use the
component in the report setup file as you can any component.

1 Open the Report Explorer.

2 Select one of the component creation choices from the Tools menu:

| Tacls Help

ﬁﬂ Create Component

?35 Create Component From
ﬁﬁ Create Component Fram 1

* To create a custom component, select Create Component.

» To create a custom component from an existing component, select Create
Component from.

* To create a component from an existing version 1 component, select Create
Component from V1.

Tip You can also create a custom component by clicking the Create a new user-
defined reporting component link in the Report Explorer Properties pane on the
right.

The Report Explorer displays as follows:
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* The Outline pane on the left displays the structure of components you create.
* The Options pane in the middle lists properties you add to components.
* The Properties pane on the right specifies the behavior of component properties.

gReport Explorer - Component - CUserDefined o =] P

File Edit “iew Toolz Help
EEEIEEEER R X

| | Mame Create Component: Main
E% Repart Generatar (5 - Mumeric Properties -  Build
- Component - CU gerDefined ﬂ Mew_Double_Property
ﬂ Mew_Integer_Property
(7 - Sting Propetiss - Fiebuild Constructor | Create new constructor for existing component
ﬂ Mew_Sting_Property
ﬂ Mew_ParzedSking_Property
ﬂ Mew_Stingyector_Property Clazz directorny: IEUserDefined
I~ - Enumerated Properties -
ﬂ Mew_Enumerated_Property )
ﬂ Mew_TrueF alze_Property e et IH:\

wirite files to: H:4@R ptgenCustomiE@CL serDefined Edit...

Build Companent % arming: Component "'FptgenCustom. CUserD efined” exists and will be overwritten

— Component File Location

Package directory: IHptgenEustom

— Component Dizplay Option

Display name: INew Component

Description: I

Categomy name:IEustom Components LI

™ Component may contain children

— Propertie:

Add Property | Edit Froperty...

i I LI Revert | Help

3 Specify properties of the component in the Properties pane of the Report Explorer.

Specify tasks you want the component to perform by editing the MATLAB files that
comprise the framework of the component.

5 Build the component.
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Note You must restart the MATLAB session before using a new or rebuilt component.

See Also

Related Examples

. “Build Components” on page 8-10

. “Specify Tasks for a Component to Perform” on page 8-12
. “Define Components” on page 8-5

8-4
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Define Components

In this section...

“Required Component Data” on page 8-5

“Specify the Location of Component Files” on page 8-5
“Set Component Display Options” on page 8-6
“Specify Component Properties” on page 8-7

“Modify Existing Components” on page 8-10

“Build Components” on page 8-10

“Rebuild Existing Components” on page 8-11

“Remove a Component” on page 8-11

Required Component Data

You must specify the following information when you create a component:

1 The path where you want to put the folder that contains all files for the component.
For information on how to specify this folder, see “Specify the Location of Component
Files” on page 8-5.

2 Properties of the component. For more information, see “Specify Component
Properties” on page 8-7.

3 Display options for the component, including its display name, category, and
description. For more information, see “Set Component Display Options” on page 8-
6.

Specify the Location of Component Files

You can create components that perform similar functions and group them in Package
Directories. Each package folder must have a Parent Directory that is in the MATLAB
path. When you build a new component, the MATLAB Report Generator software creates
files that make up the component. These files are stored in the folder structure
<parent>/@package name/@class name.

Specify these directories in the following fields in the Component File Location area of
the Properties pane:
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Class Directory field. Specify a class name for your component. The build process
creates a folder with the name you specify and places the component's files in it. The
class folder name must be unique for each component in the package. By convention,
component class names begin with an uppercase or lowercase letter c; for example,
cUserDefinedComponent.

Package Directory field. Specify the folder in which to store files for groups of
components you create. Files for each component are stored in a subfolder with the
name you entered into Class Directory Field.

Parent Directory field. Specify this folder when you create a package for the first
time. This folder is the parent folder of the Package Directory.

Set Component Display Options

You can specify how you want your component to appear in the Report Explorer by
entering data in the Component Display Options area of the Properties pane. Enter the
following information:

1

2

8-6

Display Name. Specify a display name for the component to appear in the list of
components for its associated category. Component categories and display names
appear in the Options pane in the middle of the Report Explorer.

For information on specifying component categories, see step 3, Category Name.

The following example shows how to create a component called My First
Component in a category called My Category.

— Component Dizplay Option

Dizplay name: IM_I,I First Component

Description: IThe first compaonent

Categaory narme:; I by Eategnrﬂ j

[~ Component may contain childen

Description. Enter a description for the component. This description appears when
you click the component name or category name in the Options pane in the middle of
the Report Explorer. Make the description informative, but brief.
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Category Name. Specify the category of components to which the new component
belongs. The component appears under this category in the Options pane in the
middle of the Report Explorer.

Predefined choices appear in the Category name list. Select a component category
from this list.

— Companent Digplay Option

Digplay name: IE:-:ampIe String Companent
Dezcription: I.-“-‘-. FATLAE String
Category name: | MATLAB ﬂ

[~ Comporent |Formatting B
Handle Graphics

Logical and Flow Control
MaT LR

Feal-Time ‘\wWorkzhop —
Report Generator

Add Property || Fieguirements b anagement Interface

Sirnulink. -

Simulink, Blocks
Simulink Fixed Poirt d|
To create a custom component category, type the name for the category into the

Category name field. This category name appears in the list of available categories
in the Report Explorer.

= Propertiez

Category name; I by category j

[T Component may contain childen

child components.

Select the Component may contain children check box if you want the component
to have child components. Child components appear under the component in the
Report Explorer hierarchy. During report generation, the component runs all child
components and includes their output in the report.

Specify Component Properties

Component properties determine how a component behaves and what information it
inserts into a report. To see the current value of a component's property, double-click it in

8-7
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the Outline pane on the left in the Report Explorer. For example, the figure shows the
property values for New String Property.

HRepurt Explorer - Component - CUserDefined* =10l x|

File Edit ‘“iew Toolz Help

It E 828X 3|7 |+ 3 e
I Mame I Create Component: Property
- | Report Generatar £ - MNumefic Propertiss - - Propertie 1=

E- 8 Companent - ClserDefined: %a| Mew_Double_Property
- [4g| Mew_String_Property i Mew Integer_Property
[~ - Sting Properties - Data type:IString |
%8l Mew_String Property
%8| Mew_ParsedSting_Property
ﬂ Mew_Stringvector Property Dialog pronpt: INew ztring property L
i - Erumerated Properties -
ﬂ Mew Enumerated Property

ﬂ Mew_TrueFalze_Property ‘l |_’I_

l [ _’I Fievert | Help

Property nane: INew_String_F'ropert_l,J

Default value: I'Default value'

Code Preview

4

Add Properties to Components

You add properties to a component from the properties list. Each property has a default
value that you can modify as needed.

There are several ways to add properties to components:

1 Right-click the name of the component to which you want to add properties in the
Outline pane on the left. Select Add new property from its context menu.

Add new property

Build component

Ticker

M ewStingPrope
MewStingtect: Cose il
- '] NewTueF alseF Send bo Workspace

2 Right-click the name of a predefined property in the Options pane in the middle.
From the context menu, select Add property.
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3 Left-click the name of a property in the Options pane, and then drag it on top of a

M ewStringProperty
N ewS i

MewTri

add property

component in the Outline pane on the left.

4 Double-click the property name in the Options pane in the middle. The property is
added to the component and property values appear in the Properties pane on the

right.
HRepurt Explorer - Component - CStockTicker® 101 =l
File Edit “iew Toolz Help
IS E | 23X 3|7 |48 e
| I I Marme _«|||Create Component: Property
El% Repaort Generator Iljl - Mumenic Propertigs - ~ Propertie
ﬁ Repart - stnckreport.rp_t ﬂ Mew Double_Property Frzsel name:INew_Stling_F'mpert_l,l
= Companent - CStock Ticker® ﬂ Mew Integer_Property
i a| Mew_Sting_Property 7= - String Propertiss - Data type: | String |
‘| Mew_String_Property Default value: I'Default walue'
ﬂ Mews ParzedString_Property ; .
4a] Mew Stringvector Property Dialog prompt; INew slring property
| - Enumerated Properties - o ‘| |_’I
ﬂ Mews Enumerated Property -
Fewvert | Help
4| | B
A

5 Click the Add Property button on the Properties pane on the right.

— Propertiesz

j

Add FProperty

Mame Data Type Factom Y alue

by First_Property | int32 1000
My _Second_Properl double 10000
by Third_Froperty | String Thiz iz my third property.'
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Specify Component Properties

1 Property Name. Create a name for the new property. A property name must be a
valid MATLAB variable name, and must be unique within a component.

2 Data Type. Specify the property's data type. Options are:

Double
Enumeration
Integer

String

String Vector
%<Parsed String>

Use this data type to include the value of a variable in the MATLAB workspace in
a component.

True/False

3 Default Value. Set a default value for the property. The default value must be
compatible with the data type. If incompatibilities exist between the default value and
the data type, the component might not build.

4 Dialog Prompt. This text appears next to the widget on the component's dialog box.
It indicates what the property does and how it affects report generation.

Note When the component builds, a colon is appended to your entry in the Dialog
prompt field. Your entry appears in the Properties pane with the colon appended.

Modify Existing Components

Report components are modifiable. You can derive a new component from an existing
component by double-clicking the name of the component and modifying its values and
properties.

Build Components

After you have entered all data required for defining the component, you build it by
clicking the Build Component button. The build process creates all files needed for the
component and stores them in the specified folder. For more information about specifying
where components are stored, see “Specify the Location of Component Files” on page 8-5.
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Note Existing files in this location are overwritten.

Rebuild Existing Components

To add, remove, or change properties of an existing component, use the Rebuild
Constructor button. This button becomes active only after you have previously created a
component using the Build Component button. To activate the Rebuild Constructor
button, specify the Package name and Class name for an existing component. These
fields are located in the Component File Location area of the Properties pane.

If you select a component using Tools > Create component from, the component's
fields are filled in automatically and the button becomes active.

After you have finished modifying the component, click the Rebuild Constructor button
to rebuild the component. Writable files in the component's folder location are not
overwritten.

Remove a Component

To remove a component:

1 Delete its class folder, <root>/@package name/@class name. If the component
you want to remove is the only component in the package, delete the entire package.

2 Edit <root>/@package name/rptcomps2.xml to remove the XML element that
registers the component.
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Specify Tasks for a Component to Perform
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In this section...

“About Component Customization” on page 8-12

“Required Customization: Specify Format and Content of Report Output” on page 8-12
“Change a Component's Outline Text in the Report Explorer Hierarchy” on page 8-14
“Modify the Appearance of Properties Dialog Boxes” on page 8-15

“Specify Additional Component Properties” on page 8-16

About Component Customization

Building a component creates MATLAB files in the MATLAB workspace. Specify tasks that
you want your component to perform by editing these MATLAB files.

Note You must specify the format and content of your report output by editing
execute.m. This file is called during report generation to invoke your component's tasks.
Optionally, you can specify additional component properties and behavior by editing other
MATLAB files.

For more information, see the following sections:

* “Required Customization: Specify Format and Content of Report Output” on page 8-
12

* “Change a Component's Outline Text in the Report Explorer Hierarchy” on page 8-14

* “Modify the Appearance of Properties Dialog Boxes” on page 8-15

» “Specify Additional Component Properties” on page 8-16

Required Customization: Specify Format and Content of
Report Output

After you build the component, specify the format and content of your report output by
editing the execute.m file.

The execute command has the following syntax:
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out = execute(thisComp, parentDoc)
Where:

* thisComp is a handle to the component that you are running.
* parentDoc is a handle to the document that you are generating.
* out is a Document Object Model (DOM) node or string to add to the report.

For information on manipulating DOM nodes, see xmlwrite in the MATLAB
documentation.

One or more default lines of code within the execute.m file show each property for the
component. Here is an example of a component property line within an execute.m file:

pstring = thisComp.NewStringProperty; % New string property;

The following sections describe how to edit execute.m to create additional report
elements.

Create Tables

To create a table, replace the Source property value with the name of a cell array or
structure:

out = execute(rptgen.cfr_table(...
'Source', tableSrc,...
'numHeaderRows',1, ...
'TableTitle', 'Example Title'),...
parentDoc);

For more information, enter help(rptgen.cfr table) at the MATLAB command line.
Create Lists

To create a list, replace the Source property value with the name of a cell vector:

out = execute(rptgen.cfr list(...
'Source', listSrc,...
'ListStyle', 'orderedlist’, ...
'ListTitle', 'Example List'),...
parentDoc);

For more information, enter help(rptgen.cfr list) at the MATLAB command line.
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Create Text

To create text, replace the ParaText property value with a character vector:
out = execute(rptgen.cfr_paragraph(...
'ParaText', paraSrc,...
parentDoc);
For more information, enter help(rptgen.cfr paragraph) at the command line.

Create Figures

To create figures, specify a figure in the FigureHandle property value.

figSrc = gcf;
out = execute(rptgen hg.chg fig snap(...
'FigureHandle', figSrc,...

'"Title', '', ...
'isResizeFigure', 'manual',...
'"PrintSize', [6 4],...
'"PrintUnits', 'inches'),...
parentDoc);

For more information, enter help(rptgen hg.chg fig snap) at the MATLAB
command line.

Run Child Components

The following code runs child components. The first line calls execute.m for child
components. The second line appends the results of running the child components to the
report:

childOut = thisComp.runChildren(parentDoc);
out = parentDoc.createDocumentFragment(out, childOut);

Change a Component's Outline Text in the Report Explorer
Hierarchy

To change the string used to describe the component in the Report Explorer hierarchy,
edit the getOutlineString MATLAB file. By default, getoutlinestring returns the
display name of the component. The getOutlineString command has the following
syntax:
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olstring = getOutlineString(thisComp)
Where:

* thisComp is the component whose description you are specifying.
* olstring is a single-line that displays information about the component. It can
contain a maximum of 32 characters.

Customize the string to include additional information about the component, such as
information about its properties. In the following example, the truncatestring function
converts input data into a single-line character vector. If the data is empty, the second
argument is the return value, The third argument is the maximum allowed size of the
resulting character vector.

cInfo = '"';
pstring = rptgen.truncateString(thisComp.string, '<empty>',16);

Use a dash (-) as a separator between the name and additional component information,
as follows:

if ~isempty(cInfo)

olstring = [olstring, '-', cInfo];
end

Modify the Appearance of Properties Dialog Boxes

You can edit the getdialogschema.m file to control most aspects of dialog box layout,
including:

* Creation and placement of widgets
* Organization of widgets into panes
* Creation of the top-level display within which panes reside

The syntax of the command is:
dlgstruct = getdialogschema(thisComp, name)
Where:

* thisComp is the instance of the component being edited.

* name is a character vector that is passed to getdialogschema to build a specific type
of pane. Usually, name is empty in the Report Explorer.
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Note Do not modify fields that are not explicitly included in this file. These fields are
subject to change in future releases.

Specify Additional Component Properties

You can edit additional MATLAB files to customize your component further. To access
these files, right-click the component in the Outline pane on the left in the Report
Explorer and select Edit files from its context menu.

g mem e ———

E| +-i=,.' Component - DemaoC)

: Dremo_String_Pre :

‘... oS Companent - ClserD SRR

Edit files

Close Chr[-t

Add new property

Send to Workspace

For more information, see the following sections:

* “Specify Whether Components Can Have Children Components” on page 8-16
* “Modify a Component Description” on page 8-16

* “Change a Component Display Name” on page 8-17

* “Change a Component Category Name” on page 8-17

» “Register Components” on page 8-17

+ “Display Component Help in the MATLAB Help Browser” on page 8-17

Specify Whether Components Can Have Children Components

To specify whether a component can have children, edit getParentable.m. This
command returns the value true or false. For example, if you no longer want your
component to have child components, modify the value within the code as follows:

p = false;
Modify a Component Description

The description in getDescription.mis the same value as the Description field in the
Report Explorer. The following example shows how to edit the compDesc value in this file
to change a component's description to An example component:
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compDesc = 'An example component';
Change a Component Display Name

The display name in getName.m is the same value as the Display name field in the
Report Explorer. The following example shows how to edit the compName value in this file
to change a component's display name to Example Component:

compName = 'Example Component';
Change a Component Category Name

The category name in getType.mis the same value as the Category name field in the
Report Explorer. The following example shows how to edit the compCategory value in
this file to change a component's category name to Custom Components:

compCategory = 'Custom Components';
Register Components

You can register components in the Report Explorer using rptcomps2.xml. This file also
helps build the list of available components.

The content of this file must be consistent with the values in the getName.m and
getType.mfiles. If you have changed values in either of these files, you must also change
their values in rptcomps2.xml. You must restart the MATLAB software session for the
Report Explorer to display new information.

Display Component Help in the MATLAB Help Browser

The viewHelp.m file displays a help file for the component within the MATLAB Help
browser. To display the help file, highlight the name of the component in the Report
Explorer and click Help.
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Define Report Variables

You can have your report use variables defined in the MATLAB workspace to specify
values to be used by components. You can create these variables in the MATLAB
workspace before running the report. However, a better solution is to let the report create
the variables, using the Evaluate MATLAB Expression component.

For an example, see “Specify Report Variables” on page 2-16.
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* “Style Sheets” on page 9-2

* “Create a New Style Sheet” on page 9-4

+ “Edit, Save, or Delete a Style Sheet” on page 9-5

+ “Edit Style Sheet Data Items” on page 9-9

» “Style Sheet Cells for Headers and Footers” on page 9-24
* “Customized Style Sheets” on page 9-29

* “Configure PDF Fonts” on page 9-40
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Style Sheets
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In this section...

“Built-In Versus Custom Style Sheets” on page 9-2
“Customize Style Sheets Using Data Items” on page 9-3

Built-In Versus Custom Style Sheets

Style Sheets specify formatting and display settings for reports. The report-generation
process uses style sheets to convert reports from DocBook XML format to a format that
you specify. If you want to generate the given report in a different format than initially
specified, you can convert the XML document using a different or modified style sheet.

The following table lists report output formats and their default style sheets.

Report Format |Default Style Sheet

HTML Uses style sheets for either single- or multiple-page documents

PDF Formatting Object (FO) style sheet

RTE, Word Document Style Semantics and Specification Language (DSSSL) style
sheet

The following table shows a list of properties for the built-in style sheets.
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Properties of Style Sheets

Name Description

Description A description of the style sheet.

Display name |The style sheet name that appears in the Options pane.

Transform type |The process used to generate reports that use a specified style sheet.
Supported types are:

« HTML

* FO (Formatting Object) for PDF reports

* DSSSL (Document Style Semantics and Specification Language) for
RTF and Word reports

Note This field is not editable.

In most cases, the style sheets provided with the MATLAB Report Generator software
should be more than adequate for your needs. However, you may want to modify the built-
in style sheets to meet special requirements. For example, suppose one of the built-in
style sheets meets your requirements, but you want to change the page orientation. You
can create a custom style sheet by editing the built-in style sheet to your specifications.

Customize Style Sheets Using Data Items

Each built-in style sheet includes editable styles, also called data items, organized in
categories. These data items specify styles that the file converter uses for a given report.
You can edit these data items to customize style sheets for your reports.

Data items can be of different types, some of which require different editing methods. For
more information about editing data items, see “Edit Style Sheet Data Items” on page 9-
9.

Tip See the Help area at the bottom of the Properties pane on the right for a description
of a specific data item that you are editing.
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Create a New Style Sheet

9-4

To create a style sheet:

Open the Report Explorer.

From the menu bar, click Tools > Edit Style Sheet.

In the Properties pane on the right, choose the built-in style sheet for the format with
which you want to work. Options are:

* New HTML. Creates a style sheet for HTML reports.

* New multi-page HTML. Creates a style sheet for HTML reports with more than
one page.

* New FO (PDF). Creates a style sheet for PDF reports.
* New DSSSL (RTF). Creates a style sheet for RTF reports.

The new style sheet appears in the Outline pane on the left.

In the Properties pane on the right, modify the properties for the style sheet as

needed. Add data items to the new style sheet:

a Drag the data item you want to add from the Options pane in the middle to the
style sheet in the Outline pane on the left.

b In the Properties pane on the right, edit the data items for the selected style. For
more information, see “Edit Style Sheet Data Items” on page 9-9

Save the style sheet. For information about how to save a style sheet, see “Save a
Style Sheet” on page 9-7.



Edit, Save, or Delete a Style Sheet

Edit, Save, or Delete a Style Sheet

In this section...

“Edit a Style Sheet” on page 9-5
“Save a Style Sheet” on page 9-7
“Delete a Style Sheet” on page 9-8

Edit a Style Sheet

To edit a style sheet:

1 In Report Explorer, select a report setup file in the Outline pane on the left.
2  From the menu bar, click Tools > Edit Style Sheet.

The Report Explorer displays as follows.

* The Outline pane on the left displays the structure of style sheets you create.
* The Options pane in the middle lists style sheets available for customizing.

Tip Double-click a category to collapse it. Double-click it again to expand it.

* The Properties pane on the right shows properties of style sheets, such as name and
description.
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You can use the Report Explorer to work with style sheets as follows.
Task Pane to Use |Action
Create a style sheet Properties Click the link that corresponds to the
kind of style sheet you want to create
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converting an XML source file

Task Pane to Use |Action

Open an existing style sheet Properties Click the name of the style sheet,
which appear in the Open Style
Sheets area

Select a style sheet to use for Options Select a sty